1421afa94a
Fixes <http://bugs.gnu.org/20102>. * gnu/packages/patches/gcc-arm-link-spec-fix.patch: New file. * gnu-system.am (dist_patch_DATA): Add it. * gnu/packages/gcc.scm (gcc-4.8, gcc-4.9): Add patch. * gnu/packages/cross-base.scm (cross-gcc): Preserve patches from gcc-4.8. Co-Authored-By: Ludovic Courtès <ludo@gnu.org>
17 lines
594 B
Diff
17 lines
594 B
Diff
Do not pass -dynamic-linker to linker when !shared.
|
|
Fixes <http://bugs.gnu.org/20102>.
|
|
|
|
Patch by Ludovic Courtès <ludo@gnu.org>.
|
|
|
|
--- gcc-4.8.4/gcc/config/arm/linux-elf.h.orig 2015-04-08 20:31:20.376900478 +0200
|
|
+++ gcc-4.8.4/gcc/config/arm/linux-elf.h 2015-04-08 20:31:36.437014437 +0200
|
|
@@ -65,7 +65,7 @@
|
|
%{symbolic:-Bsymbolic} \
|
|
%{!static: \
|
|
%{rdynamic:-export-dynamic} \
|
|
- -dynamic-linker " GNU_USER_DYNAMIC_LINKER "} \
|
|
+ %{!shared:-dynamic-linker " GNU_USER_DYNAMIC_LINKER "}} \
|
|
-X \
|
|
%{mbig-endian:-EB} %{mlittle-endian:-EL}" \
|
|
SUBTARGET_EXTRA_LINK_SPEC
|