385ae063c9
* gnu/packages/patches/unzip-CVE-2014-9636.patch, gnu/packages/patches/unzip-allow-greater-hostver-values.patch, gnu/packages/patches/unzip-increase-size-of-cfactorstr.patch, gnu/packages/patches/unzip-initialize-symlink-flag.patch, gnu/packages/patches/unzip-remove-build-date.patch: New files. * gnu-system.am (dist_patch_DATA): Add them. * gnu/packages/zip.scm (unzip)[source]: Add patches. [arguments]: Use 'modify-phases'. Remove custom 'configure' phase; pass additional make-flags instead. Add custom 'build' phase that builds "generic_gcc" target; remove "generic_gcc" from make-flags.
19 lines
424 B
Diff
19 lines
424 B
Diff
Copied from Debian.
|
|
|
|
From: sms
|
|
Subject: Increase size of cfactorstr array to avoid buffer overflow
|
|
Bug-Debian: http://bugs.debian.org/741384
|
|
X-Debian-version: 6.0-11
|
|
|
|
--- a/list.c
|
|
+++ b/list.c
|
|
@@ -97,7 +97,7 @@
|
|
{
|
|
int do_this_file=FALSE, cfactor, error, error_in_archive=PK_COOL;
|
|
#ifndef WINDLL
|
|
- char sgn, cfactorstr[10];
|
|
+ char sgn, cfactorstr[12];
|
|
int longhdr=(uO.vflag>1);
|
|
#endif
|
|
int date_format;
|