7ef4119f0a
* gnu/packages/patches/qemu-CVE-2015-5154-pt1.patch, gnu/packages/patches/qemu-CVE-2015-5154-pt2.patch, gnu/packages/patches/qemu-CVE-2015-5154-pt3.patch, gnu/packages/patches/qemu-CVE-2015-5158.patch: New files. * gnu-system.am (dist_patch_DATA): Add them. * gnu/packages/qemu.scm (qemu-headless)[source]: Add patches.
72 lines
2.0 KiB
Diff
72 lines
2.0 KiB
Diff
From 1d3c2268f8708126a34064c2e0c1000b40e6f3e5 Mon Sep 17 00:00:00 2001
|
|
From: Kevin Wolf <kwolf@redhat.com>
|
|
Date: Wed, 3 Jun 2015 14:41:27 +0200
|
|
Subject: [PATCH 3/3] ide: Clear DRQ after handling all expected accesses
|
|
|
|
This is additional hardening against an end_transfer_func that fails to
|
|
clear the DRQ status bit. The bit must be unset as soon as the PIO
|
|
transfer has completed, so it's better to do this in a central place
|
|
instead of duplicating the code in all commands (and forgetting it in
|
|
some).
|
|
|
|
Signed-off-by: Kevin Wolf <kwolf@redhat.com>
|
|
---
|
|
hw/ide/core.c | 16 ++++++++++++----
|
|
1 file changed, 12 insertions(+), 4 deletions(-)
|
|
|
|
diff --git a/hw/ide/core.c b/hw/ide/core.c
|
|
index 44fcc23..50449ca 100644
|
|
--- a/hw/ide/core.c
|
|
+++ b/hw/ide/core.c
|
|
@@ -2028,8 +2028,10 @@ void ide_data_writew(void *opaque, uint32_t addr, uint32_t val)
|
|
*(uint16_t *)p = le16_to_cpu(val);
|
|
p += 2;
|
|
s->data_ptr = p;
|
|
- if (p >= s->data_end)
|
|
+ if (p >= s->data_end) {
|
|
+ s->status &= ~DRQ_STAT;
|
|
s->end_transfer_func(s);
|
|
+ }
|
|
}
|
|
|
|
uint32_t ide_data_readw(void *opaque, uint32_t addr)
|
|
@@ -2053,8 +2055,10 @@ uint32_t ide_data_readw(void *opaque, uint32_t addr)
|
|
ret = cpu_to_le16(*(uint16_t *)p);
|
|
p += 2;
|
|
s->data_ptr = p;
|
|
- if (p >= s->data_end)
|
|
+ if (p >= s->data_end) {
|
|
+ s->status &= ~DRQ_STAT;
|
|
s->end_transfer_func(s);
|
|
+ }
|
|
return ret;
|
|
}
|
|
|
|
@@ -2078,8 +2082,10 @@ void ide_data_writel(void *opaque, uint32_t addr, uint32_t val)
|
|
*(uint32_t *)p = le32_to_cpu(val);
|
|
p += 4;
|
|
s->data_ptr = p;
|
|
- if (p >= s->data_end)
|
|
+ if (p >= s->data_end) {
|
|
+ s->status &= ~DRQ_STAT;
|
|
s->end_transfer_func(s);
|
|
+ }
|
|
}
|
|
|
|
uint32_t ide_data_readl(void *opaque, uint32_t addr)
|
|
@@ -2103,8 +2109,10 @@ uint32_t ide_data_readl(void *opaque, uint32_t addr)
|
|
ret = cpu_to_le32(*(uint32_t *)p);
|
|
p += 4;
|
|
s->data_ptr = p;
|
|
- if (p >= s->data_end)
|
|
+ if (p >= s->data_end) {
|
|
+ s->status &= ~DRQ_STAT;
|
|
s->end_transfer_func(s);
|
|
+ }
|
|
return ret;
|
|
}
|
|
|
|
--
|
|
1.8.3.1
|
|
|