7ef4119f0a
* gnu/packages/patches/qemu-CVE-2015-5154-pt1.patch, gnu/packages/patches/qemu-CVE-2015-5154-pt2.patch, gnu/packages/patches/qemu-CVE-2015-5154-pt3.patch, gnu/packages/patches/qemu-CVE-2015-5158.patch: New files. * gnu-system.am (dist_patch_DATA): Add them. * gnu/packages/qemu.scm (qemu-headless)[source]: Add patches.
29 lines
788 B
Diff
29 lines
788 B
Diff
From aa851d30acfbb9580098ac1dc82885530cb8b3c1 Mon Sep 17 00:00:00 2001
|
|
From: Kevin Wolf <kwolf@redhat.com>
|
|
Date: Wed, 3 Jun 2015 14:17:46 +0200
|
|
Subject: [PATCH 2/3] ide/atapi: Fix START STOP UNIT command completion
|
|
|
|
The command must be completed on all code paths. START STOP UNIT with
|
|
pwrcnd set should succeed without doing anything.
|
|
|
|
Signed-off-by: Kevin Wolf <kwolf@redhat.com>
|
|
---
|
|
hw/ide/atapi.c | 1 +
|
|
1 file changed, 1 insertion(+)
|
|
|
|
diff --git a/hw/ide/atapi.c b/hw/ide/atapi.c
|
|
index 950e311..79dd167 100644
|
|
--- a/hw/ide/atapi.c
|
|
+++ b/hw/ide/atapi.c
|
|
@@ -983,6 +983,7 @@ static void cmd_start_stop_unit(IDEState *s, uint8_t* buf)
|
|
|
|
if (pwrcnd) {
|
|
/* eject/load only happens for power condition == 0 */
|
|
+ ide_atapi_cmd_ok(s);
|
|
return;
|
|
}
|
|
|
|
--
|
|
1.8.3.1
|
|
|