f5ac2352e9
* gnu/packages/patches/pulseaudio-volume-test.patch: New file. * gnu-system.am (dist_patch_DATA): Add it. * gnu/packages/pulseaudio.scm (pulseaudio): Use it. Remove #:tests? #t.
30 lines
1.2 KiB
Diff
30 lines
1.2 KiB
Diff
Fix seemingly random failures of 'volume-test' in particular on 32-bit
|
|
machines. See <https://bugs.freedesktop.org/show_bug.cgi?id=72374> for
|
|
details.
|
|
|
|
From 27e47c72a25846e107b6e450c3a1480a2742382e Mon Sep 17 00:00:00 2001
|
|
From: Tanu Kaskinen <tanu.kaskinen@linux.intel.com>
|
|
Date: Sat, 14 Dec 2013 07:21:22 +0000
|
|
Subject: volume-test: Increase the allowed number of rouding errors
|
|
|
|
BugLink: https://bugs.freedesktop.org/show_bug.cgi?id=72374
|
|
---
|
|
diff --git a/src/tests/volume-test.c b/src/tests/volume-test.c
|
|
index a2daf3e..1ab0b5c 100644
|
|
--- a/src/tests/volume-test.c
|
|
+++ b/src/tests/volume-test.c
|
|
@@ -138,7 +138,13 @@ START_TEST (volume_test) {
|
|
pa_log("max deviation: %lu n=%lu", (unsigned long) md, (unsigned long) mdn);
|
|
|
|
fail_unless(md <= 1);
|
|
- fail_unless(mdn <= 251);
|
|
+
|
|
+ /* mdn counts the times there were rounding errors during the test. The
|
|
+ * number of rounding errors seems to vary slightly depending on the
|
|
+ * hardware. The original limit was 251 errors, but it was increased to 253
|
|
+ * when the test was failing on Tanu's laptop.
|
|
+ * See https://bugs.freedesktop.org/show_bug.cgi?id=72374 */
|
|
+ fail_unless(mdn <= 253);
|
|
}
|
|
END_TEST
|