c3499ad6b8
* gnu/packages/patches/icecat-CVE-2015-4477.patch, gnu/packages/patches/icecat-CVE-2015-7207.patch, gnu/packages/patches/icecat-CVE-2016-1952-pt01.patch, gnu/packages/patches/icecat-CVE-2016-1952-pt02.patch, gnu/packages/patches/icecat-CVE-2016-1952-pt03.patch, gnu/packages/patches/icecat-CVE-2016-1952-pt04.patch, gnu/packages/patches/icecat-CVE-2016-1952-pt05.patch, gnu/packages/patches/icecat-CVE-2016-1952-pt06.patch, gnu/packages/patches/icecat-CVE-2016-1954.patch, gnu/packages/patches/icecat-CVE-2016-1960.patch, gnu/packages/patches/icecat-CVE-2016-1961.patch, gnu/packages/patches/icecat-CVE-2016-1962.patch, gnu/packages/patches/icecat-CVE-2016-1964.patch, gnu/packages/patches/icecat-CVE-2016-1965.patch, gnu/packages/patches/icecat-CVE-2016-1966.patch, gnu/packages/patches/icecat-CVE-2016-1974.patch, gnu/packages/patches/icecat-bug-1248851.patch: New files. * gnu-system.am (dist_patch_DATA): Add them. * gnu/packages/gnuzilla.scm (icecat)[source]: Add patches.
38 lines
1.2 KiB
Diff
38 lines
1.2 KiB
Diff
Copied from upstream:
|
|
https://hg.mozilla.org/releases/mozilla-esr38/raw-rev/8c1d40e45a72
|
|
|
|
# HG changeset patch
|
|
# User Xidorn Quan <quanxunzhen@gmail.com>
|
|
# Date 1456199544 -28800
|
|
# Node ID 8c1d40e45a72c6432e879137a0afa519dc6c9841
|
|
# Parent 1dd0ca8e70bd77b6fd93f36cc4e9c2cebfe8ba0a
|
|
Bug 1248851 - r=sicking, a=ritu
|
|
|
|
diff --git a/dom/indexedDB/ActorsParent.cpp b/dom/indexedDB/ActorsParent.cpp
|
|
--- a/dom/indexedDB/ActorsParent.cpp
|
|
+++ b/dom/indexedDB/ActorsParent.cpp
|
|
@@ -14823,22 +14823,19 @@ ObjectStoreAddOrPutRequestOp::DoDatabase
|
|
}
|
|
|
|
snappy::RawCompress(uncompressed, uncompressedLength, compressed,
|
|
&compressedLength);
|
|
|
|
uint8_t* dataBuffer = reinterpret_cast<uint8_t*>(compressed);
|
|
size_t dataBufferLength = compressedLength;
|
|
|
|
- // If this call succeeds, | compressed | is now owned by the statement, and
|
|
- // we are no longer responsible for it.
|
|
rv = stmt->BindAdoptedBlobByName(NS_LITERAL_CSTRING("data"), dataBuffer,
|
|
dataBufferLength);
|
|
if (NS_WARN_IF(NS_FAILED(rv))) {
|
|
- moz_free(compressed);
|
|
return rv;
|
|
}
|
|
}
|
|
|
|
nsCOMPtr<nsIFile> fileDirectory;
|
|
nsCOMPtr<nsIFile> journalDirectory;
|
|
|
|
if (mFileManager) {
|
|
|