bfb48f4f33
Includes fixes for CVE-2016-5250, CVE-2016-5257, CVE-2016-5261, CVE-2016-5270, CVE-2016-5272, CVE-2016-5274, CVE-2016-5276, CVE-2016-5277, CVE-2016-5278, CVE-2016-5280, CVE-2016-5281, and CVE-2016-5284. * gnu/packages/gnuzilla.scm (mozilla-patch): New procedure. (icecat): Update to 45.3.0-gnu1. [source]: Add alternate source URI for the beta release. Update patches. [inputs]: Replace 'sqlite' input with a customized sqlite with SQLITE_ENABLE_DBSTAT_VTAB support. [native-inputs]: Add 'which'. * gnu/packages/patches/icecat-avoid-bundled-includes.patch: Rename to... * gnu/packages/patches/icecat-avoid-bundled-libraries.patch: ... and adapt to version 45. * gnu/packages/patches/icecat-CVE-2016-2818-pt1.patch, gnu/packages/patches/icecat-CVE-2016-2818-pt2.patch, gnu/packages/patches/icecat-CVE-2016-2818-pt3.patch, gnu/packages/patches/icecat-CVE-2016-2818-pt4.patch, gnu/packages/patches/icecat-CVE-2016-2818-pt5.patch, gnu/packages/patches/icecat-CVE-2016-2818-pt6.patch, gnu/packages/patches/icecat-CVE-2016-2818-pt7.patch, gnu/packages/patches/icecat-CVE-2016-2818-pt8.patch, gnu/packages/patches/icecat-CVE-2016-2818-pt9.patch, gnu/packages/patches/icecat-CVE-2016-2819.patch, gnu/packages/patches/icecat-CVE-2016-2821.patch, gnu/packages/patches/icecat-CVE-2016-2824.patch, gnu/packages/patches/icecat-CVE-2016-2828.patch, gnu/packages/patches/icecat-CVE-2016-2831.patch: Delete files. * gnu/local.mk (dist_patch_DATA): Update accordingly.
51 lines
1.5 KiB
Diff
51 lines
1.5 KiB
Diff
Fixes needed when avoiding bundled libraries.
|
|
|
|
--- icecat-45.3.0/xpcom/build/moz.build.orig
|
|
+++ icecat-45.3.0/xpcom/build/moz.build
|
|
@@ -92,10 +92,5 @@
|
|
'/docshell/base',
|
|
]
|
|
|
|
-if CONFIG['MOZ_VPX']:
|
|
- LOCAL_INCLUDES += [
|
|
- '/media/libvpx',
|
|
- ]
|
|
-
|
|
if CONFIG['MOZ_WIDGET_TOOLKIT'] == 'cocoa':
|
|
CXXFLAGS += CONFIG['TK_CFLAGS']
|
|
--- icecat-45.3.0/storage/moz.build.orig
|
|
+++ icecat-45.3.0/storage/moz.build
|
|
@@ -108,7 +108,6 @@
|
|
DEFINES['SQLITE_MAX_LIKE_PATTERN_LENGTH'] = 50000
|
|
|
|
LOCAL_INCLUDES += [
|
|
- '/db/sqlite3/src',
|
|
'/dom/base',
|
|
]
|
|
|
|
--- icecat-45.3.0/dom/indexedDB/moz.build.orig
|
|
+++ icecat-45.3.0/dom/indexedDB/moz.build
|
|
@@ -96,7 +96,6 @@
|
|
SOURCES['Key.cpp'].flags += ['-Wno-error=type-limits']
|
|
|
|
LOCAL_INCLUDES += [
|
|
- '/db/sqlite3/src',
|
|
'/dom/base',
|
|
'/dom/storage',
|
|
'/dom/workers',
|
|
--- icecat-45.3.0/modules/libmar/tests/Makefile.in.orig
|
|
+++ icecat-45.3.0/modules/libmar/tests/Makefile.in
|
|
@@ -10,12 +10,5 @@
|
|
ifndef MOZ_PROFILE_GENERATE
|
|
libs::
|
|
$(INSTALL) ../tool/signmar$(BIN_SUFFIX) $(TESTROOT)/unit
|
|
- $(INSTALL) $(DEPTH)/dist/bin/$(DLL_PREFIX)nss3$(DLL_SUFFIX) $(TESTROOT)/unit
|
|
-ifndef MOZ_FOLD_LIBS
|
|
- $(INSTALL) $(DEPTH)/dist/bin/$(DLL_PREFIX)nssutil3$(DLL_SUFFIX) $(TESTROOT)/unit
|
|
- $(INSTALL) $(DEPTH)/dist/bin/$(DLL_PREFIX)plc4$(DLL_SUFFIX) $(TESTROOT)/unit
|
|
- $(INSTALL) $(DEPTH)/dist/bin/$(DLL_PREFIX)nspr4$(DLL_SUFFIX) $(TESTROOT)/unit
|
|
- $(INSTALL) $(DEPTH)/dist/bin/$(DLL_PREFIX)plds4$(DLL_SUFFIX) $(TESTROOT)/unit
|
|
-endif
|
|
endif
|
|
endif # Not Android
|