fd9a5b0fc3
* gnu/packages/patches/qemu-CVE-2015-6855.patch: Delete file. * gnu/packages/patches/qemu-virtio-9p-use-accessor-to-get-thread-pool.patch, gnu/packages/patches/qemu-CVE-2015-8558.patch, gnu/packages/patches/qemu-CVE-2015-8567.patch, gnu/packages/patches/qemu-CVE-2015-8613.patch, gnu/packages/patches/qemu-CVE-2015-8701.patch, gnu/packages/patches/qemu-CVE-2015-8743.patch, gnu/packages/patches/qemu-CVE-2016-1568.patch, gnu/packages/patches/qemu-CVE-2016-1922.patch: New files. * gnu-system.am (dist_patch_DATA): Remove 'qemu-CVE-2015-6855.patch'; add the new patches. * gnu/packages/qemu.scm (qemu): Update to 2.5.0. [source]: Remove old patches and add new ones. [arguments]: Add 'disable-test-qga' phase. (%glib-memory-vtable-patch, %glib-duplicate-test-patch): Remove variables.
66 lines
2.1 KiB
Diff
66 lines
2.1 KiB
Diff
From 4c1396cb576c9b14425558b73de1584c7a9735d7 Mon Sep 17 00:00:00 2001
|
|
From: P J P <ppandit@redhat.com>
|
|
Date: Fri, 18 Dec 2015 11:35:07 +0530
|
|
Subject: [PATCH] i386: avoid null pointer dereference
|
|
|
|
Hello,
|
|
|
|
A null pointer dereference issue was reported by Mr Ling Liu, CC'd here. It
|
|
occurs while doing I/O port write operations via hmp interface. In that,
|
|
'current_cpu' remains null as it is not called from cpu_exec loop, which
|
|
results in the said issue.
|
|
|
|
Below is a proposed (tested)patch to fix this issue; Does it look okay?
|
|
|
|
===
|
|
From ae88a4947fab9a148cd794f8ad2d812e7f5a1d0f Mon Sep 17 00:00:00 2001
|
|
From: Prasad J Pandit <pjp@fedoraproject.org>
|
|
Date: Fri, 18 Dec 2015 11:16:07 +0530
|
|
Subject: [PATCH] i386: avoid null pointer dereference
|
|
|
|
When I/O port write operation is called from hmp interface,
|
|
'current_cpu' remains null, as it is not called from cpu_exec()
|
|
loop. This leads to a null pointer dereference in vapic_write
|
|
routine. Add check to avoid it.
|
|
|
|
Reported-by: Ling Liu <liuling-it@360.cn>
|
|
Signed-off-by: Prasad J Pandit <pjp@fedoraproject.org>
|
|
Message-Id: <alpine.LFD.2.20.1512181129320.9805@wniryva>
|
|
Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
|
|
Signed-off-by: P J P <ppandit@redhat.com>
|
|
---
|
|
hw/i386/kvmvapic.c | 15 ++++++++++-----
|
|
1 file changed, 10 insertions(+), 5 deletions(-)
|
|
|
|
diff --git a/hw/i386/kvmvapic.c b/hw/i386/kvmvapic.c
|
|
index c6d34b2..f0922da 100644
|
|
--- a/hw/i386/kvmvapic.c
|
|
+++ b/hw/i386/kvmvapic.c
|
|
@@ -634,13 +634,18 @@ static int vapic_prepare(VAPICROMState *s)
|
|
static void vapic_write(void *opaque, hwaddr addr, uint64_t data,
|
|
unsigned int size)
|
|
{
|
|
- CPUState *cs = current_cpu;
|
|
- X86CPU *cpu = X86_CPU(cs);
|
|
- CPUX86State *env = &cpu->env;
|
|
- hwaddr rom_paddr;
|
|
VAPICROMState *s = opaque;
|
|
+ X86CPU *cpu;
|
|
+ CPUX86State *env;
|
|
+ hwaddr rom_paddr;
|
|
|
|
- cpu_synchronize_state(cs);
|
|
+ if (!current_cpu) {
|
|
+ return;
|
|
+ }
|
|
+
|
|
+ cpu_synchronize_state(current_cpu);
|
|
+ cpu = X86_CPU(current_cpu);
|
|
+ env = &cpu->env;
|
|
|
|
/*
|
|
* The VAPIC supports two PIO-based hypercalls, both via port 0x7E.
|
|
--
|
|
2.6.3
|
|
|