1b7d5242c3
* gnu/packages/patches/libarchive-CVE-2013-0211.patch, gnu/packages/patches/libarchive-fix-lzo-test-case.patch, gnu/packages/patches/libarchive-mtree-filename-length-fix.patch: New files. * gnu-system.am (dist_patch_DATA): Add them. * gnu/packages/backup.scm (libarchive)[source]: Add patches.
19 lines
580 B
Diff
19 lines
580 B
Diff
Description: Patch to fix filename length calculation when writing mtree archives.
|
|
Author: Dave Reisner <dreisner@archlinux.org>
|
|
Origin: upstream
|
|
|
|
--- a/libarchive/archive_write_set_format_mtree.c
|
|
+++ b/libarchive/archive_write_set_format_mtree.c
|
|
@@ -1855,9 +1855,9 @@
|
|
return (ret);
|
|
}
|
|
|
|
- /* Make a basename from dirname and slash */
|
|
+ /* Make a basename from file->parentdir.s and slash */
|
|
*slash = '\0';
|
|
- file->parentdir.length = slash - dirname;
|
|
+ file->parentdir.length = slash - file->parentdir.s;
|
|
archive_strcpy(&(file->basename), slash + 1);
|
|
return (ret);
|
|
}
|