335bc6833f
* gnu/packages/patches/duplicity-piped-password.patch: New patch. * gnu/packages/patches/duplicity-test_selection-tmp.patch: New patch. * gnu-system.am (dist_patch_DATA): Add them. * gnu/packages/backup.scm (duplicity)[source]: Add patches field. [inputs]: Add util-linux and tzdata. [arguments]: rename patch-tests phase to check-setup. Set HOME and TZDIR for tests.
19 lines
753 B
Diff
19 lines
753 B
Diff
Reported upstream at https://bugs.launchpad.net/duplicity/+bug/1375019
|
|
|
|
--- duplicity-0.6.24/testing/unit/test_selection.py 2014-05-09 08:27:40.000000000 -0500
|
|
+++ duplicity-0.6.24/testing/unit/test_selection.py 2014-09-28 12:28:53.932324380 -0500
|
|
@@ -431,10 +431,10 @@
|
|
[(), ('1',), ('1', '1'), ('1', '2'), ('1', '3')])
|
|
|
|
self.root = Path("/")
|
|
- self.ParseTest([("--exclude", "/home/*"),
|
|
- ("--include", "/home"),
|
|
+ self.ParseTest([("--exclude", "/tmp/*"),
|
|
+ ("--include", "/tmp"),
|
|
("--exclude", "/")],
|
|
- [(), ("home",)])
|
|
+ [(), ("tmp",)])
|
|
|
|
if __name__ == "__main__":
|
|
unittest.main()
|