e5da4d8b40
Also delete two stray patches that were added in92ae98e2a0
and lost in a subsequent merge (mupdf/fixed was already gone ate90e0fad1b
). * gnu/packages/patches/mupdf-CVE-2017-5896.patch, gnu/packages/patches/mupdf-CVE-2017-5991.patch, gnu/packages/patches/mupdf-mujs-CVE-2016-10132.patch, gnu/packages/patches/mupdf-mujs-CVE-2016-10133.patch: Delete files. * gnu/local.mk (dist_patch_DATA): Remove them. * gnu/packages/patches/mupdf-build-with-openjpeg-2.1.patch: Adjust. * gnu/packages/pdf.scm (mupdf): Update to 1.11. [source]: Remove mujs patches. Adjust snippet to source rename.
28 lines
713 B
Diff
28 lines
713 B
Diff
Make it possible to build MuPDF with OpenJPEG 2.1, which is the latest
|
|
release series and contains many important bug fixes.
|
|
|
|
Patch adapted from Debian:
|
|
|
|
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=745246
|
|
|
|
And related to this upstream commit:
|
|
|
|
http://git.ghostscript.com/?p=mupdf.git;a=commit;h=f88bfe2e62dbadb96d4f52d7aa025f0a516078da
|
|
|
|
diff --git a/source/fitz/load-jpx.c b/source/fitz/load-jpx.c
|
|
index 6b92e5c..72dea50 100644
|
|
--- a/source/fitz/load-jpx.c
|
|
+++ b/source/fitz/load-jpx.c
|
|
@@ -444,11 +444,6 @@
|
|
|
|
#else /* HAVE_LURATECH */
|
|
|
|
-#define OPJ_STATIC
|
|
-#define OPJ_HAVE_INTTYPES_H
|
|
-#if !defined(_WIN32) && !defined(_WIN64)
|
|
-#define OPJ_HAVE_STDINT_H
|
|
-#endif
|
|
#define USE_JPIP
|
|
|
|
#include <openjpeg.h>
|