8e28d22c91
* gnu/packages/patches/libtiff-CVE-2012-4564.patch, gnu/packages/patches/libtiff-CVE-2013-1960.patch, gnu/packages/patches/libtiff-CVE-2013-1961.patch, gnu/packages/patches/libtiff-CVE-2013-4231.patch, gnu/packages/patches/libtiff-CVE-2013-4232.patch, gnu/packages/patches/libtiff-CVE-2013-4243.patch, gnu/packages/patches/libtiff-CVE-2013-4244.patch, gnu/packages/patches/libtiff-CVE-2014-8127-pt1.patch, gnu/packages/patches/libtiff-CVE-2014-8127-pt2.patch, gnu/packages/patches/libtiff-CVE-2014-8127-pt3.patch, gnu/packages/patches/libtiff-CVE-2014-8127-pt4.patch, gnu/packages/patches/libtiff-CVE-2014-8128-pt1.patch, gnu/packages/patches/libtiff-CVE-2014-8128-pt2.patch, gnu/packages/patches/libtiff-CVE-2014-8128-pt3.patch, gnu/packages/patches/libtiff-CVE-2014-8128-pt4.patch, gnu/packages/patches/libtiff-CVE-2014-8128-pt5.patch, gnu/packages/patches/libtiff-CVE-2014-8129.patch, gnu/packages/patches/libtiff-CVE-2014-9330.patch, gnu/packages/patches/libtiff-CVE-2014-9655.patch: New files. * gnu-system.am (dist_patch_DATA): Add them. * gnu/packages/image.scm (libtiff)[source]: Add patches.
35 lines
1.3 KiB
Diff
35 lines
1.3 KiB
Diff
Copied from Debian
|
|
|
|
From 266bc48054b018a2f1d74562aa48eb2f509436d5 Mon Sep 17 00:00:00 2001
|
|
From: erouault <erouault>
|
|
Date: Sun, 21 Dec 2014 17:36:36 +0000
|
|
Subject: [PATCH] * tools/tiff2pdf.c: check return code of TIFFGetField() when
|
|
reading TIFFTAG_SAMPLESPERPIXEL
|
|
|
|
---
|
|
ChangeLog | 5 +++++
|
|
tools/tiff2pdf.c | 10 +++++++++-
|
|
2 files changed, 14 insertions(+), 1 deletion(-)
|
|
|
|
Index: tiff-4.0.3/tools/tiff2pdf.c
|
|
===================================================================
|
|
--- tiff-4.0.3.orig/tools/tiff2pdf.c
|
|
+++ tiff-4.0.3/tools/tiff2pdf.c
|
|
@@ -1164,7 +1164,15 @@ void t2p_read_tiff_init(T2P* t2p, TIFF*
|
|
t2p->tiff_pages[i].page_tilecount;
|
|
if( (TIFFGetField(input, TIFFTAG_PLANARCONFIG, &xuint16) != 0)
|
|
&& (xuint16 == PLANARCONFIG_SEPARATE ) ){
|
|
- TIFFGetField(input, TIFFTAG_SAMPLESPERPIXEL, &xuint16);
|
|
+ if( !TIFFGetField(input, TIFFTAG_SAMPLESPERPIXEL, &xuint16) )
|
|
+ {
|
|
+ TIFFError(
|
|
+ TIFF2PDF_MODULE,
|
|
+ "Missing SamplesPerPixel, %s",
|
|
+ TIFFFileName(input));
|
|
+ t2p->t2p_error = T2P_ERR_ERROR;
|
|
+ return;
|
|
+ }
|
|
if( (t2p->tiff_tiles[i].tiles_tilecount % xuint16) != 0 )
|
|
{
|
|
TIFFError(
|