ae71cd8ac9
Includes fixes for CVE-2018-12383 and CVE-2018-12385. * gnu/packages/patches/icecat-CVE-2018-12383.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/patches/icecat-avoid-bundled-libraries.patch: Adapt to apply cleanly to IceCat 60. * gnu/packages/gnuzilla.scm (mozilla-patch): Update to fetch from mozilla-esr60. (icecat): Add selected changesets from upstream mozilla-esr60.
36 lines
1.0 KiB
Diff
36 lines
1.0 KiB
Diff
Fixes needed when avoiding bundled libraries.
|
|
|
|
--- icecat-60.2.0/xpcom/build/moz.build.orig 2018-09-13 17:46:49.000000000 -0400
|
|
+++ icecat-60.2.0/xpcom/build/moz.build 2018-09-22 04:26:50.659564554 -0400
|
|
@@ -99,10 +99,5 @@
|
|
'/docshell/base',
|
|
]
|
|
|
|
-if CONFIG['MOZ_VPX']:
|
|
- LOCAL_INCLUDES += [
|
|
- '/media/libvpx',
|
|
- ]
|
|
-
|
|
if CONFIG['MOZ_WIDGET_TOOLKIT'] == 'cocoa':
|
|
CXXFLAGS += CONFIG['TK_CFLAGS']
|
|
--- icecat-60.2.0/storage/moz.build.orig 2018-09-13 17:51:11.000000000 -0400
|
|
+++ icecat-60.2.0/storage/moz.build 2018-09-22 04:26:50.659564554 -0400
|
|
@@ -117,7 +117,6 @@
|
|
DEFINES['MOZ_MEMORY_TEMP_STORE_PRAGMA'] = True
|
|
|
|
LOCAL_INCLUDES += [
|
|
- '/db/sqlite3/src',
|
|
'/dom/base',
|
|
]
|
|
|
|
--- icecat-60.2.0/dom/indexedDB/moz.build.orig 2018-09-13 17:49:42.000000000 -0400
|
|
+++ icecat-60.2.0/dom/indexedDB/moz.build 2018-09-22 04:26:50.663564574 -0400
|
|
@@ -102,7 +102,6 @@
|
|
CXXFLAGS += ['-Wno-error=shadow']
|
|
|
|
LOCAL_INCLUDES += [
|
|
- '/db/sqlite3/src',
|
|
'/dom/base',
|
|
'/dom/storage',
|
|
'/ipc/glue',
|