8e28d22c91
* gnu/packages/patches/libtiff-CVE-2012-4564.patch, gnu/packages/patches/libtiff-CVE-2013-1960.patch, gnu/packages/patches/libtiff-CVE-2013-1961.patch, gnu/packages/patches/libtiff-CVE-2013-4231.patch, gnu/packages/patches/libtiff-CVE-2013-4232.patch, gnu/packages/patches/libtiff-CVE-2013-4243.patch, gnu/packages/patches/libtiff-CVE-2013-4244.patch, gnu/packages/patches/libtiff-CVE-2014-8127-pt1.patch, gnu/packages/patches/libtiff-CVE-2014-8127-pt2.patch, gnu/packages/patches/libtiff-CVE-2014-8127-pt3.patch, gnu/packages/patches/libtiff-CVE-2014-8127-pt4.patch, gnu/packages/patches/libtiff-CVE-2014-8128-pt1.patch, gnu/packages/patches/libtiff-CVE-2014-8128-pt2.patch, gnu/packages/patches/libtiff-CVE-2014-8128-pt3.patch, gnu/packages/patches/libtiff-CVE-2014-8128-pt4.patch, gnu/packages/patches/libtiff-CVE-2014-8128-pt5.patch, gnu/packages/patches/libtiff-CVE-2014-8129.patch, gnu/packages/patches/libtiff-CVE-2014-9330.patch, gnu/packages/patches/libtiff-CVE-2014-9655.patch: New files. * gnu-system.am (dist_patch_DATA): Add them. * gnu/packages/image.scm (libtiff)[source]: Add patches.
34 lines
1022 B
Diff
34 lines
1022 B
Diff
Copied from Debian
|
|
|
|
Index: tiff-4.0.3/tools/ppm2tiff.c
|
|
===================================================================
|
|
--- tiff-4.0.3.orig/tools/ppm2tiff.c 2013-06-23 10:36:50.779629492 -0400
|
|
+++ tiff-4.0.3/tools/ppm2tiff.c 2013-06-23 10:36:50.775629494 -0400
|
|
@@ -89,6 +89,7 @@
|
|
int c;
|
|
extern int optind;
|
|
extern char* optarg;
|
|
+ tmsize_t scanline_size;
|
|
|
|
if (argc < 2) {
|
|
fprintf(stderr, "%s: Too few arguments\n", argv[0]);
|
|
@@ -237,8 +238,16 @@
|
|
}
|
|
if (TIFFScanlineSize(out) > linebytes)
|
|
buf = (unsigned char *)_TIFFmalloc(linebytes);
|
|
- else
|
|
- buf = (unsigned char *)_TIFFmalloc(TIFFScanlineSize(out));
|
|
+ else {
|
|
+ scanline_size = TIFFScanlineSize(out);
|
|
+ if (scanline_size != 0)
|
|
+ buf = (unsigned char *)_TIFFmalloc(TIFFScanlineSize(out));
|
|
+ else {
|
|
+ fprintf(stderr, "%s: scanline size overflow\n",infile);
|
|
+ (void) TIFFClose(out);
|
|
+ exit(-2);
|
|
+ }
|
|
+ }
|
|
if (resolution > 0) {
|
|
TIFFSetField(out, TIFFTAG_XRESOLUTION, resolution);
|
|
TIFFSetField(out, TIFFTAG_YRESOLUTION, resolution);
|