698d228001
* gnu/packages/patches/abiword-explictly-cast-bools.patch New file. * gnu/packages/patches/abiword-link-plugins-against-backend.patch: New file. * gnu/packages/patches/abiword-no-include-glib-internal-headers.patch: New file. * gnu/packages/patches/abiword-pass-no-undefined-to-linker.patch * gnu/packages/patches/abiword-use-proper-png-api.patch: New file. * gnu/packages/patches/abiword-wmf-version-lookup-fix.patch: New file. * gnu/packages/abiword.scm: New file. * gnu-system.am (GNU_SYSTEM_MODULES): Add abiword.scm. (dist_patch_DATA): Add the 6 patches for abiword. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
14 lines
340 B
Diff
14 lines
340 B
Diff
Include glib.h instead of an internal header.
|
|
|
|
--- a/goffice-bits/goffice/app/goffice-app.h 2007-01-17 00:17:27.000000000 +0100
|
|
+++ b/goffice-bits/goffice/app/goffice-app.h 2014-09-05 19:02:59.402064713 +0200
|
|
@@ -22,7 +22,7 @@
|
|
#ifndef GOFFICE_APP_H
|
|
#define GOFFICE_APP_H
|
|
|
|
-#include <glib/gmacros.h>
|
|
+#include <glib.h>
|
|
|
|
G_BEGIN_DECLS
|
|
|