6a20289d5a
* gnu/packages/patches/python-2.7-search-paths.patch, gnu/packages/patches/python-3-search-paths.patch: New files. * gnu-system.am (dist_patch_DATA): Add them. * gnu/packages/python.scm (python-2)[source]: Use first patch. [arguments]: Remove now unneeded CPPFLAGS and LDFLAGS. (python)[source]: Use second patch. (python-minimal)[arguments]: Remove CPPFLAGS and LDFLAGS.
20 lines
897 B
Diff
20 lines
897 B
Diff
Make sure the build system honors CPATH and LIBRARY_PATH when looking for
|
|
headers and libraries.
|
|
|
|
--- setup.py 2015-10-07 23:32:58.891329173 +0200
|
|
+++ setup.py 2015-10-07 23:46:29.653349924 +0200
|
|
@@ -507,11 +507,8 @@ class PyBuildExt(build_ext):
|
|
# if a file is found in one of those directories, it can
|
|
# be assumed that no additional -I,-L directives are needed.
|
|
if not cross_compiling:
|
|
- lib_dirs = self.compiler.library_dirs + [
|
|
- '/lib64', '/usr/lib64',
|
|
- '/lib', '/usr/lib',
|
|
- ]
|
|
- inc_dirs = self.compiler.include_dirs + ['/usr/include']
|
|
+ lib_dirs = os.getenv('LIBRARY_PATH', '').split(os.pathsep)
|
|
+ inc_dirs = os.getenv('CPATH', '').split(os.pathsep)
|
|
else:
|
|
lib_dirs = self.compiler.library_dirs[:]
|
|
inc_dirs = self.compiler.include_dirs[:]
|