e858326a0f
* gnu/packages/scheme.scm (bigloo): Update to 4.0b. Patch the `configure-gc' scripts. Remove `patch-absolute-file-names' phase. * gnu/packages/patches/bigloo-gc-shebangs.patch: Adjust to new version.
19 lines
787 B
Diff
19 lines
787 B
Diff
Patch shebangs in source that gets unpacked by `configure'.
|
|
|
|
--- bigloo4.0b/gc/install-gc-7.3alpha3-20130330 2013-08-19 10:45:20.000000000 +0200
|
|
+++ bigloo4.0b/gc/install-gc-7.3alpha3-20130330 2013-08-19 10:46:36.000000000 +0200
|
|
@@ -29,10 +29,12 @@ fi
|
|
|
|
# untar the two versions of the GC
|
|
$tar xfz $src -C ../gc || (echo "$tar xfz $src failed"; exit 1)
|
|
-/bin/rm -rf "../gc/$gc"_fth
|
|
+rm -rf "../gc/$gc"_fth
|
|
+find ../gc/$gc -perm /111 -type f | xargs sed -i -e"s|/bin/sh|`type -P sh`|g"
|
|
mv ../gc/$gc "../gc/$gc"_fth || (echo "mv $gc failed"; exit 1)
|
|
|
|
$tar xfz $src -C ../gc || (echo "$tar xfz $src failed"; exit 1)
|
|
+find ../gc/$gc -perm /111 -type f | xargs sed -i -e"s|/bin/sh|`type -P sh`|g"
|
|
|
|
# general Bigloo patch
|
|
(cd "../gc/$gc"_fth && $patch -p1 < ../$gc.patch > /dev/null)
|