9f533d60df
* gnu/packages/linux.scm (util-linux): Update to 2.25.2. Remove util-linux-perl.patch, and add util-linux-tests.patch. Adjust 'snippet'. [arguments]: Remove 'patch-chkdupexe' phase. Add 'pre-check' phase. [native-inputs]: Add NET-BASE. * gnu/packages/patches/util-linux-perl.patch: Remove. * gnu/packages/patches/util-linux-tests.patch: New file. * gnu-system.am (dist_patch_DATA): Adjust accordingly.
31 lines
1.1 KiB
Diff
31 lines
1.1 KiB
Diff
This test checks whether 'root' is successfully translated to UID/GID 0,
|
|
using 'getpwnam' in libmount. This doesn't work in the chroot because
|
|
/etc/passwd doesn't contain an entry for 'root' so skip it.
|
|
|
|
|
|
--- util-linux-2.25.2/tests/ts/libmount/optstr 2015-01-23 13:58:41.181151194 +0100
|
|
+++ util-linux-2.25.2/tests/ts/libmount/optstr 2015-01-23 13:58:42.829161716 +0100
|
|
@@ -84,10 +84,6 @@ ts_init_subtest "apply-user" # add user,
|
|
ts_valgrind $TESTPROG --apply --user "noexec,nosuid,loop=/dev/looop0" 0x408 &> $TS_OUTPUT
|
|
ts_finalize_subtest
|
|
|
|
-ts_init_subtest "fix"
|
|
-ts_valgrind $TESTPROG --fix "uid=root,gid=root" &> $TS_OUTPUT
|
|
-ts_finalize_subtest
|
|
-
|
|
ts_init_subtest "deduplicate"
|
|
ts_valgrind $TESTPROG --dedup bbb,ccc,AAA,xxx,AAA=a,AAA=bbb,ddd,AAA=ccc,fff=eee AAA &> $TS_OUTPUT
|
|
ts_finalize_subtest
|
|
|
|
|
|
The expected output for this test seems to lack a carriage return.
|
|
|
|
--- util-linux-2.25.2/tests/expected/more/regexp 2015-01-23 14:02:21.098557632 +0100
|
|
+++ util-linux-2.25.2/tests/expected/more/regexp 2015-01-23 14:02:23.598573648 +0100
|
|
@@ -1,4 +1,4 @@
|
|
|
|
...skipping
|
|
-foo
|
|
+
|
|
foo
|
|
xyzzy
|