74d72608b3
* gnu/packages/patches/curl-gss-api-fix.patch: New file. * gnu-system.am (dist_patch_DATA): Add it. * gnu/packages/curl.scm (curl): Update to 7.40.0. Add patch.
39 lines
1.4 KiB
Diff
39 lines
1.4 KiB
Diff
Copied from upstream:
|
|
https://github.com/bagder/curl/commit/5c0e66d63214e0306197c5a3f162441e074f3401.patch
|
|
|
|
From 5c0e66d63214e0306197c5a3f162441e074f3401 Mon Sep 17 00:00:00 2001
|
|
From: Steve Holme <steve_holme@hotmail.com>
|
|
Date: Thu, 8 Jan 2015 19:23:53 +0000
|
|
Subject: [PATCH] sasl_gssapi: Fixed build on NetBSD with built-in GSS-API
|
|
|
|
Bug: http://curl.haxx.se/bug/view.cgi?id=1469
|
|
Reported-by: Thomas Klausner
|
|
---
|
|
lib/curl_sasl_gssapi.c | 3 ++-
|
|
1 file changed, 2 insertions(+), 1 deletion(-)
|
|
|
|
diff --git a/lib/curl_sasl_gssapi.c b/lib/curl_sasl_gssapi.c
|
|
index 6dda0e9..a50646a 100644
|
|
--- a/lib/curl_sasl_gssapi.c
|
|
+++ b/lib/curl_sasl_gssapi.c
|
|
@@ -6,6 +6,7 @@
|
|
* \___|\___/|_| \_\_____|
|
|
*
|
|
* Copyright (C) 2014, Steve Holme, <steve_holme@hotmail.com>.
|
|
+ * Copyright (C) 2015, Daniel Stenberg, <daniel@haxx.se>, et al.
|
|
*
|
|
* This software is licensed as described in the file COPYING, which
|
|
* you should have received as part of this distribution. The terms
|
|
@@ -126,7 +127,7 @@ CURLcode Curl_sasl_create_gssapi_user_message(struct SessionHandle *data,
|
|
|
|
/* Import the SPN */
|
|
gss_major_status = gss_import_name(&gss_minor_status, &spn_token,
|
|
- gss_nt_service_name, &krb5->spn);
|
|
+ GSS_C_NT_HOSTBASED_SERVICE, &krb5->spn);
|
|
if(GSS_ERROR(gss_major_status)) {
|
|
Curl_gss_log_error(data, gss_minor_status, "gss_import_name() failed: ");
|
|
|
|
--
|
|
2.2.1
|
|
|