gnu: trilinos-for-dealii-openmpi: Fix build.
This fixes the error error: ‘std::hypot’ has not been declared caused by using an older version of gcc, but requires some patches to placate newer versions of gcc. * gnu/packages/maths.scm (trilinos-for-dealii-openmpi)[origin]: Add patches. [native-inputs]: Remove gcc-7. * gnu/packages/patches/teuchos-remove-duplicate-using.patch: New file. * gnu/packages/patches/tpetra-remove-duplicate-using.patch: Likewise. * gnu/local.mk (dist_patch_DATA): Register them. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
This commit is contained in:
parent
c942f4dcab
commit
fed6ac2ae1
@ -2026,6 +2026,7 @@ dist_patch_DATA = \
|
|||||||
%D%/packages/patches/texinfo-5-perl-compat.patch \
|
%D%/packages/patches/texinfo-5-perl-compat.patch \
|
||||||
%D%/packages/patches/telegram-desktop-allow-disable-libtgvoip.patch \
|
%D%/packages/patches/telegram-desktop-allow-disable-libtgvoip.patch \
|
||||||
%D%/packages/patches/telegram-purple-adjust-test.patch \
|
%D%/packages/patches/telegram-purple-adjust-test.patch \
|
||||||
|
%D%/packages/patches/teuchos-remove-duplicate-using.patch \
|
||||||
%D%/packages/patches/texi2html-document-encoding.patch \
|
%D%/packages/patches/texi2html-document-encoding.patch \
|
||||||
%D%/packages/patches/texi2html-i18n.patch \
|
%D%/packages/patches/texi2html-i18n.patch \
|
||||||
%D%/packages/patches/thefuck-test-environ.patch \
|
%D%/packages/patches/thefuck-test-environ.patch \
|
||||||
@ -2036,6 +2037,7 @@ dist_patch_DATA = \
|
|||||||
%D%/packages/patches/tla2tools-build-xml.patch \
|
%D%/packages/patches/tla2tools-build-xml.patch \
|
||||||
%D%/packages/patches/tlf-support-hamlib-4.2+.patch \
|
%D%/packages/patches/tlf-support-hamlib-4.2+.patch \
|
||||||
%D%/packages/patches/tofi-32bit-compat.patch \
|
%D%/packages/patches/tofi-32bit-compat.patch \
|
||||||
|
%D%/packages/patches/tpetra-remove-duplicate-using.patch \
|
||||||
%D%/packages/patches/transcode-ffmpeg.patch \
|
%D%/packages/patches/transcode-ffmpeg.patch \
|
||||||
%D%/packages/patches/trytond-add-egg-modules-to-path.patch \
|
%D%/packages/patches/trytond-add-egg-modules-to-path.patch \
|
||||||
%D%/packages/patches/trytond-add-guix_trytond_path.patch \
|
%D%/packages/patches/trytond-add-guix_trytond_path.patch \
|
||||||
|
@ -6425,13 +6425,13 @@ revised simplex and the branch-and-bound methods.")
|
|||||||
(string-replace-substring version "." "-")))))
|
(string-replace-substring version "." "-")))))
|
||||||
(file-name (git-file-name "trilinos" version))
|
(file-name (git-file-name "trilinos" version))
|
||||||
(sha256
|
(sha256
|
||||||
(base32 "0fnwlhzsh85qj38cq3igbs8nm1b2jdgr2z734sapmyyzsy21mkgp"))))
|
(base32 "0fnwlhzsh85qj38cq3igbs8nm1b2jdgr2z734sapmyyzsy21mkgp"))
|
||||||
|
(patches
|
||||||
|
(search-patches "teuchos-remove-duplicate-using.patch"
|
||||||
|
"tpetra-remove-duplicate-using.patch"))))
|
||||||
(build-system cmake-build-system)
|
(build-system cmake-build-system)
|
||||||
(native-inputs
|
(native-inputs
|
||||||
(list
|
(list
|
||||||
;; The build fails with the current gcc.
|
|
||||||
;; Use the version from when Trilinos was added.
|
|
||||||
gcc-7
|
|
||||||
gfortran
|
gfortran
|
||||||
;; Trilinos's repository contains several C-shell scripts, but adding
|
;; Trilinos's repository contains several C-shell scripts, but adding
|
||||||
;; tcsh to the native inputs does not result in the check phase running
|
;; tcsh to the native inputs does not result in the check phase running
|
||||||
|
34
gnu/packages/patches/teuchos-remove-duplicate-using.patch
Normal file
34
gnu/packages/patches/teuchos-remove-duplicate-using.patch
Normal file
@ -0,0 +1,34 @@
|
|||||||
|
commit e27d9ae98502626d8407045a4e082797682ba56b
|
||||||
|
Author: Christian Glusa <caglusa@sandia.gov>
|
||||||
|
Date: Fri Jul 3 18:02:27 2020 -0600
|
||||||
|
|
||||||
|
Teuchos Comm test: remove duplicate 'using ...'
|
||||||
|
|
||||||
|
diff --git a/packages/teuchos/comm/test/Comm/reduce.cpp b/packages/teuchos/comm/test/Comm/reduce.cpp
|
||||||
|
index c05ebc0dc34..eac1975ef83 100644
|
||||||
|
--- a/packages/teuchos/comm/test/Comm/reduce.cpp
|
||||||
|
+++ b/packages/teuchos/comm/test/Comm/reduce.cpp
|
||||||
|
@@ -53,9 +53,6 @@ bool
|
||||||
|
testReduceSum (bool& success, std::ostream& out,
|
||||||
|
const int root, const Teuchos::Comm<int>& comm)
|
||||||
|
{
|
||||||
|
-#ifdef HAVE_TEUCHOS_MPI
|
||||||
|
- using Teuchos::MpiComm;
|
||||||
|
-#endif // HAVE_TEUCHOS_MPI
|
||||||
|
using Teuchos::reduce;
|
||||||
|
using Teuchos::TypeNameTraits;
|
||||||
|
using std::endl;
|
||||||
|
diff --git a/packages/teuchos/comm/test/Comm/scatter.cpp b/packages/teuchos/comm/test/Comm/scatter.cpp
|
||||||
|
index 0ca961d2846..001009029c4 100644
|
||||||
|
--- a/packages/teuchos/comm/test/Comm/scatter.cpp
|
||||||
|
+++ b/packages/teuchos/comm/test/Comm/scatter.cpp
|
||||||
|
@@ -53,9 +53,6 @@ bool
|
||||||
|
testScatter (bool& success, std::ostream& out,
|
||||||
|
const int root, const Teuchos::Comm<int>& comm)
|
||||||
|
{
|
||||||
|
-#ifdef HAVE_TEUCHOS_MPI
|
||||||
|
- using Teuchos::MpiComm;
|
||||||
|
-#endif // HAVE_TEUCHOS_MPI
|
||||||
|
using Teuchos::scatter;
|
||||||
|
using Teuchos::TypeNameTraits;
|
||||||
|
using std::endl;
|
18
gnu/packages/patches/tpetra-remove-duplicate-using.patch
Normal file
18
gnu/packages/patches/tpetra-remove-duplicate-using.patch
Normal file
@ -0,0 +1,18 @@
|
|||||||
|
commit 919ceb0acbf4c6bc4f463433504a338c643612c2
|
||||||
|
Author: Karen D. Devine <kddevin@sandia.gov>
|
||||||
|
Date: Tue Feb 2 13:49:13 2021 -0700
|
||||||
|
|
||||||
|
tpetra: removed duplicate using statement #8673
|
||||||
|
|
||||||
|
diff --git a/packages/tpetra/core/src/Tpetra_Details_FixedHashTable_def.hpp b/packages/tpetra/core/src/Tpetra_Details_FixedHashTable_def.hpp
|
||||||
|
index a76f78c41a8..69d4dc46d03 100644
|
||||||
|
--- a/packages/tpetra/core/src/Tpetra_Details_FixedHashTable_def.hpp
|
||||||
|
+++ b/packages/tpetra/core/src/Tpetra_Details_FixedHashTable_def.hpp
|
||||||
|
@@ -1094,7 +1094,6 @@ init (const keys_type& keys,
|
||||||
|
|
||||||
|
// Allocate the array of (key,value) pairs. Don't fill it with
|
||||||
|
// zeros, because we will fill it with actual data below.
|
||||||
|
- using Kokkos::ViewAllocateWithoutInitializing;
|
||||||
|
typedef typename val_type::non_const_type nonconst_val_type;
|
||||||
|
nonconst_val_type val (ViewAllocateWithoutInitializing ("Tpetra::FixedHashTable::pairs"),
|
||||||
|
theNumKeys);
|
Loading…
Reference in New Issue
Block a user