gnu: bitcoin-core: Update to 0.20.1.
* gnu/packages/finance.scm (bitcoin-core): Update to 0.20.1. [source]: Remove obsolete patch. [native-inputs]: Add autoconf, automake and libtool. [inputs]: Remove protobuf. [arguments]: Add "set-no-git-flag" phase to indicate the build is not taking place within a git repository. * gnu/packages/patches/bitcoin-core-python-compat.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it. Signed-off-by: Christopher Baines <mail@cbaines.net>
This commit is contained in:
parent
5a6c861db9
commit
fa268b28e1
@ -846,7 +846,6 @@ dist_patch_DATA = \
|
|||||||
%D%/packages/patches/binutils-loongson-workaround.patch \
|
%D%/packages/patches/binutils-loongson-workaround.patch \
|
||||||
%D%/packages/patches/binutils-mingw-w64-timestamp.patch \
|
%D%/packages/patches/binutils-mingw-w64-timestamp.patch \
|
||||||
%D%/packages/patches/binutils-mingw-w64-deterministic.patch \
|
%D%/packages/patches/binutils-mingw-w64-deterministic.patch \
|
||||||
%D%/packages/patches/bitcoin-core-python-compat.patch \
|
|
||||||
%D%/packages/patches/blender-2.79-gcc8.patch \
|
%D%/packages/patches/blender-2.79-gcc8.patch \
|
||||||
%D%/packages/patches/blender-2.79-gcc9.patch \
|
%D%/packages/patches/blender-2.79-gcc9.patch \
|
||||||
%D%/packages/patches/blender-2.79-newer-ffmpeg.patch \
|
%D%/packages/patches/blender-2.79-newer-ffmpeg.patch \
|
||||||
|
@ -108,7 +108,7 @@
|
|||||||
(define-public bitcoin-core
|
(define-public bitcoin-core
|
||||||
(package
|
(package
|
||||||
(name "bitcoin-core")
|
(name "bitcoin-core")
|
||||||
(version "0.19.1")
|
(version "0.20.1")
|
||||||
(source (origin
|
(source (origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
(uri
|
(uri
|
||||||
@ -116,11 +116,13 @@
|
|||||||
version "/bitcoin-" version ".tar.gz"))
|
version "/bitcoin-" version ".tar.gz"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"1h3w7brc18145np920vy7j5ms5hym59hvr40swdjx34fbdaisngj"))
|
"0y5rad68b398arh0abr2wgiwybdw0i5a4dxz9s3fk9fgdbyn5gab"))))
|
||||||
(patches (search-patches "bitcoin-core-python-compat.patch"))))
|
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
(native-inputs
|
(native-inputs
|
||||||
`(("pkg-config" ,pkg-config)
|
`(("autoconf" ,autoconf)
|
||||||
|
("automake" ,automake)
|
||||||
|
("libtool" ,libtool)
|
||||||
|
("pkg-config" ,pkg-config)
|
||||||
("python" ,python) ; for the tests
|
("python" ,python) ; for the tests
|
||||||
("util-linux" ,util-linux) ; provides the hexdump command for tests
|
("util-linux" ,util-linux) ; provides the hexdump command for tests
|
||||||
("qttools" ,qttools)))
|
("qttools" ,qttools)))
|
||||||
@ -130,7 +132,6 @@
|
|||||||
("libevent" ,libevent)
|
("libevent" ,libevent)
|
||||||
("miniupnpc" ,miniupnpc)
|
("miniupnpc" ,miniupnpc)
|
||||||
("openssl" ,openssl)
|
("openssl" ,openssl)
|
||||||
("protobuf" ,protobuf)
|
|
||||||
("qtbase" ,qtbase)))
|
("qtbase" ,qtbase)))
|
||||||
(arguments
|
(arguments
|
||||||
`(#:configure-flags
|
`(#:configure-flags
|
||||||
@ -154,6 +155,13 @@
|
|||||||
;; Make Qt deterministic.
|
;; Make Qt deterministic.
|
||||||
(setenv "QT_RCC_SOURCE_DATE_OVERRIDE" "1")
|
(setenv "QT_RCC_SOURCE_DATE_OVERRIDE" "1")
|
||||||
#t))
|
#t))
|
||||||
|
(add-before 'build 'set-no-git-flag
|
||||||
|
(lambda _
|
||||||
|
;; Make it clear we are not building from within a git repository
|
||||||
|
;; (and thus no information regarding this build is available
|
||||||
|
;; from git).
|
||||||
|
(setenv "BITCOIN_GENBUILD_NO_GIT" "1")
|
||||||
|
#t))
|
||||||
(add-before 'check 'set-home
|
(add-before 'check 'set-home
|
||||||
(lambda _
|
(lambda _
|
||||||
(setenv "HOME" (getenv "TMPDIR")) ; tests write to $HOME
|
(setenv "HOME" (getenv "TMPDIR")) ; tests write to $HOME
|
||||||
|
@ -1,28 +0,0 @@
|
|||||||
Get rid of deprecation warning emitted by Python 3.8, which causes a test failure(!).
|
|
||||||
|
|
||||||
https://github.com/bitcoin/bitcoin/pull/17931
|
|
||||||
|
|
||||||
Taken from upstream:
|
|
||||||
|
|
||||||
https://github.com/bitcoin/bitcoin/commit/f117fb00da747147cddfb071c1427a2754c278cd
|
|
||||||
|
|
||||||
diff --git a/test/functional/p2p_invalid_messages.py b/test/functional/p2p_invalid_messages.py
|
|
||||||
index 20864881c165..07eacf410d88 100755
|
|
||||||
--- a/test/functional/p2p_invalid_messages.py
|
|
||||||
+++ b/test/functional/p2p_invalid_messages.py
|
|
||||||
@@ -145,13 +145,13 @@ def run_test(self):
|
|
||||||
def test_magic_bytes(self):
|
|
||||||
conn = self.nodes[0].add_p2p_connection(P2PDataStore())
|
|
||||||
|
|
||||||
- def swap_magic_bytes():
|
|
||||||
+ async def swap_magic_bytes():
|
|
||||||
conn._on_data = lambda: None # Need to ignore all incoming messages from now, since they come with "invalid" magic bytes
|
|
||||||
conn.magic_bytes = b'\x00\x11\x22\x32'
|
|
||||||
|
|
||||||
# Call .result() to block until the atomic swap is complete, otherwise
|
|
||||||
# we might run into races later on
|
|
||||||
- asyncio.run_coroutine_threadsafe(asyncio.coroutine(swap_magic_bytes)(), NetworkThread.network_event_loop).result()
|
|
||||||
+ asyncio.run_coroutine_threadsafe(swap_magic_bytes(), NetworkThread.network_event_loop).result()
|
|
||||||
|
|
||||||
with self.nodes[0].assert_debug_log(['PROCESSMESSAGE: INVALID MESSAGESTART ping']):
|
|
||||||
conn.send_message(messages.msg_ping(nonce=0xff))
|
|
Loading…
Reference in New Issue
Block a user