gnu: LLVM: Add missing include statement for compatibility with GCC 11.
* gnu/packages/patches/llvm-8-missing-include.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/llvm.scm (llvm-11, llvm-10, llvm-9, llvm-8)[source](patches): Add it.
This commit is contained in:
parent
c9085d3bf6
commit
e9afd8a005
@ -1443,6 +1443,7 @@ dist_patch_DATA = \
|
||||
%D%/packages/patches/llvm-3.6-fix-build-with-gcc-10.patch \
|
||||
%D%/packages/patches/llvm-3.x.1-fix-build-with-gcc.patch \
|
||||
%D%/packages/patches/llvm-8-fix-build-with-gcc-10.patch \
|
||||
%D%/packages/patches/llvm-8-missing-include.patch \
|
||||
%D%/packages/patches/llvm-9-fix-bitcast-miscompilation.patch \
|
||||
%D%/packages/patches/llvm-9-fix-lpad-miscompilation.patch \
|
||||
%D%/packages/patches/llvm-9-fix-scev-miscompilation.patch \
|
||||
|
@ -866,6 +866,7 @@ with that of libgomp, the GNU Offloading and Multi Processing Library.")
|
||||
(origin
|
||||
(method url-fetch)
|
||||
(uri (llvm-uri "llvm" version))
|
||||
(patches (search-patches "llvm-8-missing-include.patch"))
|
||||
(sha256
|
||||
(base32
|
||||
"0s94lwil98w7zb7cjrbnxli0z7gklb312pkw74xs1d6zk346hgwi"))))))
|
||||
@ -899,6 +900,7 @@ with that of libgomp, the GNU Offloading and Multi Processing Library.")
|
||||
(origin
|
||||
(method url-fetch)
|
||||
(uri (llvm-uri "llvm" version))
|
||||
(patches (search-patches "llvm-8-missing-include.patch"))
|
||||
(sha256
|
||||
(base32
|
||||
"1wydhbp9kyjp5y0rc627imxgkgqiv3dfirbqil9dgpnbaw5y7n65"))))
|
||||
@ -943,6 +945,7 @@ with that of libgomp, the GNU Offloading and Multi Processing Library.")
|
||||
(base32
|
||||
"16hwp3qa54c3a3v7h8nlw0fh5criqh0hlr1skybyk0cz70gyx880"))
|
||||
(patches (search-patches
|
||||
"llvm-8-missing-include.patch"
|
||||
"llvm-9-fix-bitcast-miscompilation.patch"
|
||||
"llvm-9-fix-scev-miscompilation.patch"
|
||||
"llvm-9-fix-lpad-miscompilation.patch"))))
|
||||
@ -986,7 +989,8 @@ with that of libgomp, the GNU Offloading and Multi Processing Library.")
|
||||
(sha256
|
||||
(base32
|
||||
"1rvm5gqp5v8hfn17kqws3zhk94w4kxndal12bqa0y57p09nply24"))
|
||||
(patches (search-patches "llvm-8-fix-build-with-gcc-10.patch"))))
|
||||
(patches (search-patches "llvm-8-fix-build-with-gcc-10.patch"
|
||||
"llvm-8-missing-include.patch"))))
|
||||
(license license:ncsa)))
|
||||
|
||||
(define-public clang-runtime-8
|
||||
|
17
gnu/packages/patches/llvm-8-missing-include.patch
Normal file
17
gnu/packages/patches/llvm-8-missing-include.patch
Normal file
@ -0,0 +1,17 @@
|
||||
Add missing include statement for compatibility with libstdc++ 11.
|
||||
|
||||
Taken from upstream:
|
||||
|
||||
https://github.com/llvm/llvm-project/commit/b498303066a63a203d24f739b2d2e0e56dca70d1
|
||||
|
||||
diff --git a/utils/benchmark/src/benchmark_register.h b/utils/benchmark/src/benchmark_register.h
|
||||
--- a/utils/benchmark/src/benchmark_register.h
|
||||
+++ b/utils/benchmark/src/benchmark_register.h
|
||||
@@ -1,6 +1,7 @@
|
||||
#ifndef BENCHMARK_REGISTER_H
|
||||
#define BENCHMARK_REGISTER_H
|
||||
|
||||
+#include <limits>
|
||||
#include <vector>
|
||||
|
||||
#include "check.h"
|
Loading…
Reference in New Issue
Block a user