gnu: beets: Fix build with newer Werkzeug.
* gnu/packages/patches/beets-werkzeug-compat.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/music.scm (beets)[source](patches): New field.
This commit is contained in:
parent
066c21cda4
commit
e76cbdcd90
@ -756,6 +756,7 @@ dist_patch_DATA = \
|
||||
%D%/packages/patches/bash-completion-directories.patch \
|
||||
%D%/packages/patches/bastet-change-source-of-unordered_set.patch \
|
||||
%D%/packages/patches/bazaar-CVE-2017-14176.patch \
|
||||
%D%/packages/patches/beets-werkzeug-compat.patch \
|
||||
%D%/packages/patches/beignet-correct-file-names.patch \
|
||||
%D%/packages/patches/benchmark-unbundle-googletest.patch \
|
||||
%D%/packages/patches/biber-fix-encoding-write.patch \
|
||||
|
@ -2941,6 +2941,7 @@ Songs can be searched by artist, name or even by a part of the song text.")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (pypi-uri "beets" version))
|
||||
(patches (search-patches "beets-werkzeug-compat.patch"))
|
||||
(sha256
|
||||
(base32
|
||||
"0m40rjimvfgy1dv04p8f8d5dvi2855v4ix99a9xr900cmcn476yj"))))
|
||||
|
18
gnu/packages/patches/beets-werkzeug-compat.patch
Normal file
18
gnu/packages/patches/beets-werkzeug-compat.patch
Normal file
@ -0,0 +1,18 @@
|
||||
Be compatible with python-werkzeug 1.0.0.
|
||||
|
||||
Taken from upstream:
|
||||
https://github.com/beetbox/beets/commit/d43d54e21cde97f57f19486925ab56b419254cc8
|
||||
|
||||
diff --git a/beetsplug/web/__init__.py b/beetsplug/web/__init__.py
|
||||
index f53fb3a954..21ff5d94ed 100644
|
||||
--- a/beetsplug/web/__init__.py
|
||||
+++ b/beetsplug/web/__init__.py
|
||||
@@ -169,7 +169,7 @@ def to_python(self, value):
|
||||
return ids
|
||||
|
||||
def to_url(self, value):
|
||||
- return ','.join(value)
|
||||
+ return ','.join(str(v) for v in value)
|
||||
|
||||
|
||||
class QueryConverter(PathConverter):
|
Loading…
Reference in New Issue
Block a user