gnu: icedtea-6: Remove obsolete, architecture-dependent patch.
* gnu/packages/java.scm (icedtea-6)[arguments]<#:phases>: Remove special handling of "hotspot-src" input during "unpack" phase. [native-inputs]: Remove patch to "hotspot-src". * gnu/packages/patches/icedtea-6-hotspot-gcc-segfault-workaround.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
This commit is contained in:
parent
31ccd55176
commit
dc3c27554b
@ -1145,7 +1145,6 @@ dist_patch_DATA = \
|
||||
%D%/packages/patches/icecat-use-older-reveal-hidden-html.patch \
|
||||
%D%/packages/patches/icecat-use-system-graphite2+harfbuzz.patch \
|
||||
%D%/packages/patches/icecat-use-system-media-libs.patch \
|
||||
%D%/packages/patches/icedtea-6-hotspot-gcc-segfault-workaround.patch \
|
||||
%D%/packages/patches/icedtea-7-hotspot-gcc-segfault-workaround.patch \
|
||||
%D%/packages/patches/icu4c-CVE-2020-10531.patch \
|
||||
%D%/packages/patches/id3lib-CVE-2007-4460.patch \
|
||||
|
@ -889,11 +889,8 @@ machine.")))
|
||||
(assoc-ref inputs
|
||||
(string-append part "-src"))
|
||||
part))
|
||||
'("jdk" "corba"
|
||||
'("jdk" "hotspot" "corba"
|
||||
"langtools" "jaxp" "jaxws")))
|
||||
(with-directory-excursion "openjdk"
|
||||
(invoke "tar" "xvf" (assoc-ref inputs "hotspot-src"))
|
||||
(rename-file "hg-checkout" "hotspot"))
|
||||
(substitute* "patches/freetypeversion.patch"
|
||||
(("REQUIRED_FREETYPE_VERSION = 2.2.1")
|
||||
"REQUIRED_FREETYPE_VERSION = 2.10.1"))
|
||||
@ -1119,9 +1116,7 @@ machine.")))
|
||||
(changeset "jdk6-b41")))
|
||||
(sha256
|
||||
(base32
|
||||
"07lc1z4k5dj9nrc1wvwmpvxr3xgxrdkdh53xb95skk5ij49yagfd"))
|
||||
(patches
|
||||
(search-patches "icedtea-6-hotspot-gcc-segfault-workaround.patch"))))
|
||||
"07lc1z4k5dj9nrc1wvwmpvxr3xgxrdkdh53xb95skk5ij49yagfd"))))
|
||||
("corba-src"
|
||||
,(origin
|
||||
(method hg-fetch)
|
||||
|
@ -1,42 +0,0 @@
|
||||
# HG changeset patch
|
||||
# User Gábor Boskovits <boskovits@gmail.com>
|
||||
# Date 1530519413 -7200
|
||||
# Mon Jul 02 10:16:53 2018 +0200
|
||||
# Node ID 77e5bc9e238a28d17e097647badc04ed67a6a452
|
||||
# Parent 1ae05a34e052d1672b4a7894ddf5fc2f662eb861
|
||||
Fix gcc segfault.
|
||||
|
||||
diff -r 1ae05a34e052 -r 77e5bc9e238a src/share/vm/opto/output.cpp
|
||||
--- a/src/share/vm/opto/output.cpp Sun Dec 25 23:52:13 2016 +0000
|
||||
+++ b/src/share/vm/opto/output.cpp Mon Jul 02 10:16:53 2018 +0200
|
||||
@@ -1758,6 +1758,8 @@
|
||||
|
||||
// Initializer for class Scheduling
|
||||
|
||||
+volatile const void *eePointer = Pipeline_Use::elaborated_elements;
|
||||
+
|
||||
Scheduling::Scheduling(Arena *arena, Compile &compile)
|
||||
: _arena(arena),
|
||||
_cfg(compile.cfg()),
|
||||
@@ -1802,8 +1804,8 @@
|
||||
|
||||
// Clear the bundling information
|
||||
memcpy(_bundle_use_elements,
|
||||
- Pipeline_Use::elaborated_elements,
|
||||
- sizeof(Pipeline_Use::elaborated_elements));
|
||||
+ (void *)eePointer,
|
||||
+ 11*sizeof(Pipeline_Use_Element));
|
||||
|
||||
// Get the last node
|
||||
Block *bb = _cfg->_blocks[_cfg->_blocks.size()-1];
|
||||
@@ -1854,8 +1856,8 @@
|
||||
_bundle_use.reset();
|
||||
|
||||
memcpy(_bundle_use_elements,
|
||||
- Pipeline_Use::elaborated_elements,
|
||||
- sizeof(Pipeline_Use::elaborated_elements));
|
||||
+ (void *)eePointer,
|
||||
+ 11*sizeof(Pipeline_Use_Element));
|
||||
}
|
||||
|
||||
//------------------------------ScheduleAndBundle------------------------------
|
Loading…
Reference in New Issue
Block a user