gnu: lib2geom: Update to commit 17e0d21f.
* gnu/packages/patches/lib2geom-enable-assertions.patch: Remove file. * gnu/local.mk (dist_patch_DATA): Unregister it. * gnu/packages/graphics.scm (lib2geom): Update to commit 17e0d21f0afc8489656f9184bff7ad024a42394a, and remove obsolete patch.
This commit is contained in:
parent
cb97d07649
commit
d6fcc67de5
@ -1195,7 +1195,6 @@ dist_patch_DATA = \
|
||||
%D%/packages/patches/ldc-disable-phobos-tests.patch \
|
||||
%D%/packages/patches/leela-zero-gtest.patch \
|
||||
%D%/packages/patches/less-hurd-path-max.patch \
|
||||
%D%/packages/patches/lib2geom-enable-assertions.patch \
|
||||
%D%/packages/patches/lib2geom-fix-tests.patch \
|
||||
%D%/packages/patches/liba52-enable-pic.patch \
|
||||
%D%/packages/patches/liba52-link-with-libm.patch \
|
||||
|
@ -486,8 +486,8 @@ exception-handling library.")
|
||||
|
||||
(define-public lib2geom
|
||||
;; Use the latest master commit, as the 1.0 release suffer build problems.
|
||||
(let ((revision "2")
|
||||
(commit "f98256d2a923955af74b8cff3d456f0df1ee4b59"))
|
||||
(let ((revision "3")
|
||||
(commit "17e0d21f0afc8489656f9184bff7ad024a42394a"))
|
||||
(package
|
||||
(name "lib2geom")
|
||||
(version (git-version "1.0" revision commit))
|
||||
@ -499,13 +499,11 @@ exception-handling library.")
|
||||
(file-name (git-file-name name version))
|
||||
(sha256
|
||||
(base32
|
||||
"0w6ijaai8i80d0f35c0shgdspqlsdhw3cvz106k1gm7bmnz1wzpq"))
|
||||
"0waskrmdrrdjw8pr5cvlkrxywgf376viggpc2jzdqxxpy2k78fpr"))
|
||||
(patches
|
||||
;; Patches submitted to upstream (see:
|
||||
;; https://gitlab.com/inkscape/lib2geom/merge_requests/17,
|
||||
;; Patch submitted to upstream (see:
|
||||
;; https://gitlab.com/inkscape/lib2geom/-/merge_requests/32).
|
||||
(search-patches "lib2geom-enable-assertions.patch"
|
||||
"lib2geom-fix-tests.patch"))
|
||||
(search-patches "lib2geom-fix-tests.patch"))
|
||||
(modules '((guix build utils)))
|
||||
(snippet
|
||||
'(begin
|
||||
|
@ -1,36 +0,0 @@
|
||||
From 4aa78f52232682b353eb15c219171e466987bac7 Mon Sep 17 00:00:00 2001
|
||||
From: Maxim Cournoyer <maxim.cournoyer@gmail.com>
|
||||
Date: Thu, 16 Jan 2020 00:19:29 -0500
|
||||
Subject: [PATCH] build: Enable assertions for the RelWithDebugInfo build type.
|
||||
|
||||
This fixes issue #5 (see:
|
||||
https://gitlab.com/inkscape/lib2geom/issues/5).
|
||||
|
||||
* CMakeLists.txt: Remove the "-DNDEBUG" CXX flag from the default
|
||||
configuration for the RelWithDebugInfo build type.
|
||||
---
|
||||
CMakeLists.txt | 8 ++++++++
|
||||
1 file changed, 8 insertions(+)
|
||||
|
||||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||
index bfeb8f03..a663a1b0 100644
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -19,6 +19,14 @@ enable_testing()
|
||||
|
||||
include(CheckCXXSourceCompiles)
|
||||
|
||||
+# Enable assertions for the RelWithDebugInfo build type. This is
|
||||
+# useful as some tests make use of it (see:
|
||||
+# https://gitlab.com/inkscape/lib2geom/issues/5).
|
||||
+if (CMAKE_CXX_COMPILER_ID MATCHES "GNU|Clang")
|
||||
+ string(REPLACE "-DNDEBUG" ""
|
||||
+ CMAKE_CXX_FLAGS_RELWITHDEBINFO "${CMAKE_CXX_FLAGS_RELWITHDEBINFO}")
|
||||
+endif()
|
||||
+
|
||||
# Find dependencies
|
||||
find_package(Boost 1.40 REQUIRED)
|
||||
find_package(DoubleConversion REQUIRED)
|
||||
--
|
||||
2.24.1
|
||||
|
Loading…
x
Reference in New Issue
Block a user