gnu: unzip: Remove redundant and unused "unzip-symlink.patch".
This is a followup to commit 31d289a4759909d24dd309ac24d42902a8c20da0, which added, but did not use, "unzip-symlink.patch", which is redundant with the pre-existing "unzip-initialize-symlink-flag.patch". * gnu/packages/patches/unzip-symlink.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
This commit is contained in:
parent
b082ea9406
commit
d059485257
gnu
@ -1752,7 +1752,6 @@ dist_patch_DATA = \
|
||||
%D%/packages/patches/unzip-fix-recmatch.patch \
|
||||
%D%/packages/patches/unzip-manpage-fix.patch \
|
||||
%D%/packages/patches/unzip-overflow.patch \
|
||||
%D%/packages/patches/unzip-symlink.patch \
|
||||
%D%/packages/patches/unzip-timestamp.patch \
|
||||
%D%/packages/patches/unzip-valgrind.patch \
|
||||
%D%/packages/patches/unzip-x-option.patch \
|
||||
|
@ -1,17 +0,0 @@
|
||||
diff --git a/process.c b/process.c
|
||||
index 1e9a1e1..905732b 100644
|
||||
--- a/process.c
|
||||
+++ b/process.c
|
||||
@@ -1751,6 +1751,12 @@ int process_cdir_file_hdr(__G) /* return PK-type error code */
|
||||
= (G.crec.general_purpose_bit_flag & (1 << 11)) == (1 << 11);
|
||||
#endif
|
||||
|
||||
+#ifdef SYMLINKS
|
||||
+ /* Initialize the symlink flag, may be set by the platform-specific
|
||||
+ mapattr function. */
|
||||
+ G.pInfo->symlink = 0;
|
||||
+#endif
|
||||
+
|
||||
return PK_COOL;
|
||||
|
||||
} /* end function process_cdir_file_hdr() */
|
Loading…
x
Reference in New Issue
Block a user