gnu: openscad: Add patch to fix build.
* gnu/packages/patches/openscad-parser-boost-1.72.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/engineering.scm (openscad)[source]: Use it.
This commit is contained in:
parent
b68bf28c8f
commit
c08a784c58
@ -1326,6 +1326,7 @@ dist_patch_DATA = \
|
||||
%D%/packages/patches/openocd-nrf52.patch \
|
||||
%D%/packages/patches/openssh-hurd.patch \
|
||||
%D%/packages/patches/openresolv-restartcmd-guix.patch \
|
||||
%D%/packages/patches/openscad-parser-boost-1.72.patch \
|
||||
%D%/packages/patches/openssl-runpath.patch \
|
||||
%D%/packages/patches/openssl-1.1-c-rehash-in.patch \
|
||||
%D%/packages/patches/openssl-c-rehash-in.patch \
|
||||
|
@ -2263,7 +2263,9 @@ specification can be downloaded at @url{http://3mf.io/specification/}.")
|
||||
".src.tar.gz"))
|
||||
(sha256
|
||||
(base32
|
||||
"0nbgk5q5pgnw53la0kccdcpz2f4xf6d6076rkn0q08z57hkc85ha"))))
|
||||
"0nbgk5q5pgnw53la0kccdcpz2f4xf6d6076rkn0q08z57hkc85ha"))
|
||||
(patches (search-patches
|
||||
"openscad-parser-boost-1.72.patch"))))
|
||||
(build-system cmake-build-system)
|
||||
(inputs
|
||||
`(("boost" ,boost)
|
||||
|
26
gnu/packages/patches/openscad-parser-boost-1.72.patch
Normal file
26
gnu/packages/patches/openscad-parser-boost-1.72.patch
Normal file
@ -0,0 +1,26 @@
|
||||
https://github.com/openscad/openscad/commit/b6c170cc5d.patch
|
||||
|
||||
From b6c170cc5dd1bc677176ee732cdb0ddae57e5cf0 Mon Sep 17 00:00:00 2001
|
||||
From: Jan Beich <jbeich@FreeBSD.org>
|
||||
Date: Fri, 25 Oct 2019 15:10:26 +0000
|
||||
Subject: [PATCH] Add missing header bootlegged by Boost < 1.72
|
||||
|
||||
src/parser.y:76:6: error: no template named 'stack' in namespace 'std'
|
||||
std::stack<LocalScope *> scope_stack;
|
||||
~~~~~^
|
||||
---
|
||||
src/parser.y | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/src/parser.y b/src/parser.y
|
||||
index 7f4fd56ca7..4c77c989ea 100644
|
||||
--- a/src/parser.y
|
||||
+++ b/src/parser.y
|
||||
@@ -46,6 +46,7 @@
|
||||
#include "printutils.h"
|
||||
#include "memory.h"
|
||||
#include <sstream>
|
||||
+#include <stack>
|
||||
#include <boost/filesystem.hpp>
|
||||
#include "boost-utils.h"
|
||||
#include "feature.h"
|
Loading…
Reference in New Issue
Block a user