gnu: vtk: Update to 9.2.2.

* gnu/packages/patches/vtk-fix-freetypetools-build-failure.patch: New file.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
* gnu/packages/image-processing.scm (vtk): Update to 9.2.2.
[source](patches): Remove.
[arguments]: Remove #:phases.
This commit is contained in:
Marius Bakke 2022-11-18 20:29:30 +01:00
parent 5c9164d5fb
commit b654726c45
No known key found for this signature in database
GPG Key ID: A2A06DF2A33A54FA
3 changed files with 2 additions and 45 deletions

View File

@ -1984,7 +1984,6 @@ dist_patch_DATA = \
%D%/packages/patches/vsearch-unbundle-cityhash.patch \
%D%/packages/patches/vte-CVE-2012-2738-pt1.patch \
%D%/packages/patches/vte-CVE-2012-2738-pt2.patch \
%D%/packages/patches/vtk-fix-freetypetools-build-failure.patch \
%D%/packages/patches/vtk-7-gcc-10-compat.patch \
%D%/packages/patches/vtk-7-hdf5-compat.patch \
%D%/packages/patches/vtk-7-python-compat.patch \

View File

@ -316,7 +316,7 @@ many popular formats.")
(define-public vtk
(package
(name "vtk")
(version "9.0.1")
(version "9.2.2")
(source (origin
(method url-fetch)
(uri (string-append "https://vtk.org/files/release/"
@ -324,9 +324,7 @@ many popular formats.")
"/VTK-" version ".tar.gz"))
(sha256
(base32
"1ir2lq9i45ls374lcmjzw0nrm5l5hnm1w47lg8g8d0n2j7hsaf8v"))
(patches
(search-patches "vtk-fix-freetypetools-build-failure.patch"))
"0x8h2bwxq2870067j7wqd0qym87pa3inkbri93zrdb0zwwmhlnqw"))
(modules '((guix build utils)))
(snippet
'(begin
@ -375,14 +373,6 @@ many popular formats.")
"-DVTK_WRAP_PYTHON=ON"
"-DVTK_PYTHON_VERSION:STRING=3"
)
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'patch-sources
(lambda _
(substitute* "Common/Core/vtkFloatingPointExceptions.cxx"
(("<fenv.h>") "<cfenv>"))
(substitute* "Common/Core/CMakeLists.txt"
(("fenv.h") "cfenv")))))
#:tests? #f)) ;XXX: test data not included
(inputs
(list double-conversion

View File

@ -1,32 +0,0 @@
This fixes a build failure in VTK when building against recent versions
of freetype.
https://gitlab.kitware.com/vtk/vtk/-/merge_requests/7432
Patch by Ben Boeckel <ben.boeckel@kitware.com>
Subject: [PATCH] vtkFreeTypeTools: avoid using an internal macro
This macro has been removed upstream as it was always intended to be
private.
---
Rendering/FreeType/vtkFreeTypeTools.cxx | 7 ++-----
1 file changed, 2 insertions(+), 5 deletions(-)
diff --git a/Rendering/FreeType/vtkFreeTypeTools.cxx b/Rendering/FreeType/vtkFreeTypeTools.cxx
index c54289dc60..03b899c4da 100644
--- a/Rendering/FreeType/vtkFreeTypeTools.cxx
+++ b/Rendering/FreeType/vtkFreeTypeTools.cxx
@@ -378,8 +378,7 @@ FTC_CMapCache* vtkFreeTypeTools::GetCMapCache()
}
//----------------------------------------------------------------------------
-FT_CALLBACK_DEF(FT_Error)
-vtkFreeTypeToolsFaceRequester(
+static FT_Error vtkFreeTypeToolsFaceRequester(
FTC_FaceID face_id, FT_Library lib, FT_Pointer request_data, FT_Face* face)
{
#if VTK_FTFC_DEBUG_CD
--
2.30.1