gnu: jami: Update to 20230206.0.
* gnu/packages/jami.scm (jami): Update to 20230206.0. (%jami-version): Update version. (%jami-sources): Adjust URI. Streamline snippet. (jami-apply-custom-patches): Use a wildcard to match the top-level directory, which now includes the version. (%ffmpeg-default-configure-flags): Adjust URL in top comment. * gnu/packages/patches/jami-libjami-headers-search.patch: Adjust file names for new tarball layout.
This commit is contained in:
parent
a083a9b512
commit
b5e300f9c1
@ -2,7 +2,7 @@
|
||||
;;; Copyright © 2019 Pierre Neidhardt <mail@ambrevar.xyz>
|
||||
;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
|
||||
;;; Copyright © 2019, 2020 Jan Wielkiewicz <tona_kosmicznego_smiecia@interia.pl>
|
||||
;;; Copyright © 2020, 2021, 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
|
||||
;;; Copyright © 2020, 2021, 2022, 2023 Maxim Cournoyer <maxim.cournoyer@gmail.com>
|
||||
;;;
|
||||
;;; This file is part of GNU Guix.
|
||||
;;;
|
||||
@ -69,31 +69,24 @@
|
||||
#:use-module (guix packages)
|
||||
#:use-module (guix utils))
|
||||
|
||||
(define %jami-version "20221220.0956.79e1207")
|
||||
(define %jami-version "20230206.0")
|
||||
|
||||
(define %jami-sources
|
||||
;; Return an origin object of the tarball release sources archive of the
|
||||
;; Jami project.
|
||||
(origin
|
||||
(method url-fetch)
|
||||
(uri (string-append "https://dl.jami.net/release/tarballs/jami_"
|
||||
%jami-version
|
||||
".tar.gz"))
|
||||
(uri (string-append "https://dl.jami.net/release/tarballs/jami-"
|
||||
%jami-version ".tar.gz"))
|
||||
(modules '((guix build utils)))
|
||||
(snippet
|
||||
`(begin
|
||||
;; Delete multiple MiBs of bundled tarballs. The contrib directory
|
||||
;; contains the custom patches for pjproject and other libraries used
|
||||
;; by Jami.
|
||||
(delete-file-recursively "daemon/contrib/tarballs")
|
||||
;; Remove the git submodule directories of unused Jami clients.
|
||||
(for-each delete-file-recursively '("client-android"
|
||||
"client-ios"
|
||||
"client-macosx"
|
||||
"plugins"))))
|
||||
;; Delete multiple MiBs of bundled tarballs. The daemon/contrib
|
||||
;; directory contains the custom patches for pjproject and other
|
||||
;; libraries used by Jami.
|
||||
'(delete-file-recursively "daemon/contrib/tarballs"))
|
||||
(sha256
|
||||
(base32
|
||||
"0g5709rmb9944s0ij9g4pm1b871f5z0s5nawvm10z14wx3y1np8m"))
|
||||
"1fx7c6q8j0x3q8cgzzd4kpsw3npqggsi1n493cv1jg7v5d01d3jz"))
|
||||
(patches (search-patches "jami-disable-integration-tests.patch"
|
||||
"jami-libjami-headers-search.patch"))))
|
||||
|
||||
@ -107,14 +100,12 @@
|
||||
(invoke "tar" "-xvf" #$%jami-sources
|
||||
"-C" patches-directory
|
||||
"--strip-components=5"
|
||||
(string-append "jami-project/daemon/contrib/src/"
|
||||
dep-name))
|
||||
(for-each
|
||||
(lambda (file)
|
||||
(invoke "patch" "--force" "--ignore-whitespace" "-p1" "-i"
|
||||
(string-append patches-directory "/"
|
||||
file ".patch")))
|
||||
patches))))
|
||||
"--wildcards"
|
||||
(string-append "jami-*/daemon/contrib/src/" dep-name))
|
||||
(for-each (lambda (f)
|
||||
(invoke "patch" "--force" "--ignore-whitespace" "-p1" "-i"
|
||||
(string-append patches-directory "/" f ".patch")))
|
||||
patches))))
|
||||
|
||||
(define-public pjproject-jami
|
||||
(let ((commit "513a3f14c44b2c2652f9219ec20dea64b236b713")
|
||||
@ -153,10 +144,10 @@
|
||||
'("0009-add-config-site")))))))))))
|
||||
|
||||
;; The following variables are configure flags used by ffmpeg-jami. They're
|
||||
;; from the jami-project/daemon/contrib/src/ffmpeg/rules.mak file. We try to
|
||||
;; keep it as close to the official Jami package as possible, to provide all
|
||||
;; the codecs and extra features that are expected (see:
|
||||
;; https://review.jami.net/plugins/gitiles/ring-daemon/+/refs/heads/master/contrib/src/ffmpeg/rules.mak)
|
||||
;; from the jami/daemon/contrib/src/ffmpeg/rules.mak file. We try to keep it
|
||||
;; as close to the official Jami package as possible, to provide all the
|
||||
;; codecs and extra features that are expected (see:
|
||||
;; https://review.jami.net/plugins/gitiles/jami-daemon/+/refs/heads/master/contrib/src/ffmpeg/rules.mak)
|
||||
(define %ffmpeg-default-configure-flags
|
||||
'("--disable-everything"
|
||||
"--enable-zlib"
|
||||
|
@ -20,9 +20,9 @@ Upstream status: https://review.jami.net/c/jami-client-qt/+/22973
|
||||
src/libclient/qtwrapper/CMakeLists.txt | 2 +-
|
||||
4 files changed, 9 insertions(+), 18 deletions(-)
|
||||
|
||||
diff --git a/client-qt/CMakeLists.txt b/CMakeLists.txt
|
||||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||
index d0a8fd70..94ac6074 100644
|
||||
--- a/client-qt/CMakeLists.txt
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -118,7 +118,7 @@ set(CMAKE_MODULE_PATH
|
||||
${CMAKE_MODULE_PATH} "${EXTRAS_DIR}/build/cmake/modules")
|
||||
@ -33,9 +33,9 @@ index d0a8fd70..94ac6074 100644
|
||||
endif()
|
||||
|
||||
include(FindPython3)
|
||||
diff --git a/client-qt/extras/build/cmake/modules/FindLibJami.cmake b/extras/build/cmake/modules/FindLibJami.cmake
|
||||
diff --git a/extras/build/cmake/modules/FindLibJami.cmake b/extras/build/cmake/modules/FindLibJami.cmake
|
||||
index ddb05319..9ad20d2b 100644
|
||||
--- a/client-qt/extras/build/cmake/modules/FindLibJami.cmake
|
||||
--- a/extras/build/cmake/modules/FindLibJami.cmake
|
||||
+++ b/extras/build/cmake/modules/FindLibJami.cmake
|
||||
@@ -20,28 +20,19 @@
|
||||
|
||||
@ -78,9 +78,9 @@ index ddb05319..9ad20d2b 100644
|
||||
-message(STATUS "Jami daemon headers are in " ${LIBJAMI_INCLUDE_DIRS})
|
||||
+message(STATUS "Jami daemon headers are in " ${LIBJAMI_INCLUDE_DIR})
|
||||
message(STATUS "Jami daemon library is at " ${LIBJAMI_LIB})
|
||||
diff --git a/client-qt/src/libclient/CMakeLists.txt b/src/libclient/CMakeLists.txt
|
||||
diff --git a/src/libclient/CMakeLists.txt b/src/libclient/CMakeLists.txt
|
||||
index 2676c9c4..ac58ea2b 100644
|
||||
--- a/client-qt/src/libclient/CMakeLists.txt
|
||||
--- a/src/libclient/CMakeLists.txt
|
||||
+++ b/src/libclient/CMakeLists.txt
|
||||
@@ -62,7 +62,7 @@ set(CMAKE_MODULE_PATH
|
||||
${CMAKE_MODULE_PATH} "${EXTRAS_DIR}/build/cmake/modules")
|
||||
@ -91,10 +91,10 @@ index 2676c9c4..ac58ea2b 100644
|
||||
endif()
|
||||
|
||||
string(SUBSTRING ${CMAKE_GENERATOR} 0 14 CMAKE_GENERATOR_SHORT)
|
||||
diff --git a/client-qt/src/libclient/qtwrapper/CMakeLists.txt b/src/libclient/qtwrapper/CMakeLists.txt
|
||||
diff --git a/src/libclient/qtwrapper/CMakeLists.txt b/src/libclient/qtwrapper/CMakeLists.txt
|
||||
index acee0d0c..ba68aac4 100644
|
||||
--- a/client-qt/src/libclient/qtwrapper/CMakeLists.txt
|
||||
+++ b/client-qt/src/libclient/qtwrapper/CMakeLists.txt
|
||||
--- a/src/libclient/qtwrapper/CMakeLists.txt
|
||||
+++ b/src/libclient/qtwrapper/CMakeLists.txt
|
||||
@@ -46,7 +46,7 @@ else()
|
||||
endif()
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user