gnu: u-boot: Update to 2023.07.02.
* gnu/packages/patches/u-boot-infodocs-target.patch: Delete file. * gnu/packages/patches/u-boot-patman-guix-integration.patch: Delete file. * gnu/local.mk: De-register patches. * gnu/packages/patches/u-boot-allow-disabling-openssl.patch: Refresh. * gnu/packages/patches/u-boot-sifive-prevent-reloc-initrd-fdt.patch: Refresh. * gnu/packages/bootloaders.scm (u-boot): Update to 2023.07.02. [native-inputs]: Add python-pyelftools. [source]: Remove patches. (u-boot-tools)[phases]: Update substitution for python3-coverage. Adjust 'patch to catch more openssl incompatibilities. Split lines in 'patch phase. [native-inputs]: Add python-filelock and python-pytest-xdist. (make-u-boot-sunxi64-package): Set SCP environment variable. (u-boot-sifive-unleashed): Update to use opensbi. (u-boot-puma-rk3399)[inputs]: Add arm-trusted-firmware-rk3399 to package-inputs instead of native-inputs. (u-boot-rockpro64-rk3399): Disable CONFIG_SPL_FIT_SIGNATURE in config. Reviewed-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
This commit is contained in:
parent
d6a5384993
commit
b0d47d9e18
@ -2005,8 +2005,6 @@ dist_patch_DATA = \
|
||||
%D%/packages/patches/twinkle-bcg729.patch \
|
||||
%D%/packages/patches/u-boot-allow-disabling-openssl.patch \
|
||||
%D%/packages/patches/u-boot-fix-build-python-3.10.patch \
|
||||
%D%/packages/patches/u-boot-infodocs-target.patch \
|
||||
%D%/packages/patches/u-boot-patman-guix-integration.patch \
|
||||
%D%/packages/patches/u-boot-nintendo-nes-serial.patch \
|
||||
%D%/packages/patches/u-boot-rockchip-inno-usb.patch \
|
||||
%D%/packages/patches/u-boot-sifive-prevent-reloc-initrd-fdt.patch \
|
||||
|
@ -648,23 +648,21 @@ tree binary files. These are board description files used by Linux and BSD.")
|
||||
(define u-boot
|
||||
(package
|
||||
(name "u-boot")
|
||||
(version "2022.10")
|
||||
(version "2023.07.02")
|
||||
(source (origin
|
||||
(patches
|
||||
(list %u-boot-rockchip-inno-usb-patch
|
||||
%u-boot-allow-disabling-openssl-patch
|
||||
%u-boot-sifive-prevent-relocating-initrd-fdt
|
||||
%u-boot-rk3399-enable-emmc-phy-patch
|
||||
(search-patch "u-boot-fix-build-python-3.10.patch")
|
||||
(search-patch "u-boot-infodocs-target.patch")
|
||||
(search-patch "u-boot-patman-guix-integration.patch")))
|
||||
(search-patch "u-boot-fix-build-python-3.10.patch")))
|
||||
(method url-fetch)
|
||||
(uri (string-append
|
||||
"https://ftp.denx.de/pub/u-boot/"
|
||||
"u-boot-" version ".tar.bz2"))
|
||||
(sha256
|
||||
(base32
|
||||
"1y5x8vxdgsqdqlsvq01mn8lmw53fqairkhvhhjx83hjva0m4id2h"))))
|
||||
"1m91w3fpywllkwm000dqsw3294j0szs1lz6qbgwv1aql3ic4hskb"))))
|
||||
(build-system gnu-build-system)
|
||||
(native-inputs
|
||||
(list bison
|
||||
@ -676,6 +674,7 @@ tree binary files. These are board description files used by Linux and BSD.")
|
||||
perl
|
||||
pkg-config ;for 'make menuconfig'
|
||||
python
|
||||
python-pyelftools
|
||||
swig
|
||||
(list util-linux "lib")))
|
||||
(home-page "https://www.denx.de/wiki/U-Boot/")
|
||||
@ -726,7 +725,12 @@ Info manual.")))
|
||||
(name "u-boot-tools")
|
||||
(native-inputs
|
||||
(modify-inputs (package-native-inputs u-boot)
|
||||
(prepend python-coverage python-pycryptodomex python-pytest sdl2)))
|
||||
(prepend python-coverage
|
||||
python-filelock
|
||||
python-pycryptodomex
|
||||
python-pytest
|
||||
python-pytest-xdist
|
||||
sdl2)))
|
||||
(arguments
|
||||
`(#:make-flags '("HOSTCC=gcc")
|
||||
#:test-target "tcheck"
|
||||
@ -739,7 +743,7 @@ Info manual.")))
|
||||
(("/bin/false") (which "false")))
|
||||
(substitute* "tools/dtoc/fdt_util.py"
|
||||
(("'cc'") "'gcc'"))
|
||||
(substitute* "tools/patman/test_util.py"
|
||||
(substitute* "tools/u_boot_pylib/test_util.py"
|
||||
;; python3-coverage is simply called coverage in guix.
|
||||
(("python3-coverage") "coverage")
|
||||
|
||||
@ -777,7 +781,16 @@ def test_ctrl_c"))
|
||||
;; See https://bugs.gnu.org/34717 for
|
||||
;; details.
|
||||
(("CONFIG_FIT_SIGNATURE=y")
|
||||
"CONFIG_FIT_SIGNATURE=n\nCONFIG_UT_LIB_ASN1=n\nCONFIG_TOOLS_LIBCRYPTO=n")
|
||||
"CONFIG_FIT_SIGNATURE=n
|
||||
CONFIG_UT_LIB_ASN1=n
|
||||
CONFIG_TOOLS_LIBCRYPTO=n")
|
||||
;; Catch instances of implied CONFIG_FIG_SIGNATURE
|
||||
;; with VPL targets
|
||||
(("CONFIG_SANDBOX_VPL=y")
|
||||
"CONFIG_SANDBOX_VPL=y
|
||||
CONFIG_FIT_SIGNATURE=n
|
||||
CONFIG_VPL_FIT_SIGNATURE=n
|
||||
CONFIG_TOOLS_LIBCRYPTO=n")
|
||||
;; This test requires a sound system, which is un-used
|
||||
;; in u-boot-tools.
|
||||
(("CONFIG_SOUND=y") "CONFIG_SOUND=n")))
|
||||
@ -1009,6 +1022,9 @@ removed so that it fits within common partitioning schemes.")))
|
||||
#~(modify-phases #$phases
|
||||
(add-after 'unpack 'set-environment
|
||||
(lambda* (#:key native-inputs inputs #:allow-other-keys)
|
||||
;; Avoid dependency on crust-firmware
|
||||
;; https://issues.guix.gnu.org/48371
|
||||
(setenv "SCP" "/dev/null")
|
||||
(setenv "BL31" (search-input-file inputs "bl31.bin"))))))))
|
||||
(inputs
|
||||
(modify-inputs (package-inputs base)
|
||||
@ -1104,7 +1120,7 @@ partition."))
|
||||
(delete 'strip)
|
||||
(delete 'validate-runpath)))))
|
||||
(inputs
|
||||
(modify-inputs (package-native-inputs base)
|
||||
(modify-inputs (package-inputs base)
|
||||
(append arm-trusted-firmware-rk3399))))))
|
||||
|
||||
(define-public u-boot-qemu-arm
|
||||
@ -1170,7 +1186,20 @@ Documentation} for more information (for example by running @samp{info
|
||||
(append sdl2))))))
|
||||
|
||||
(define-public u-boot-sifive-unleashed
|
||||
(make-u-boot-package "sifive_unleashed" "riscv64-linux-gnu"))
|
||||
(let ((base (make-u-boot-package "sifive_unleashed" "riscv64-linux-gnu")))
|
||||
(package
|
||||
(inherit base)
|
||||
(arguments
|
||||
(substitute-keyword-arguments (package-arguments base)
|
||||
((#:phases phases)
|
||||
#~(modify-phases #$phases
|
||||
(add-after 'unpack 'set-environment
|
||||
(lambda* (#:key inputs #:allow-other-keys)
|
||||
(setenv "OPENSBI" (search-input-file inputs
|
||||
"fw_dynamic.bin"))))))))
|
||||
(inputs
|
||||
(modify-inputs (package-inputs base)
|
||||
(append opensbi-generic))))))
|
||||
|
||||
(define-public u-boot-sifive-unmatched
|
||||
(let ((base (make-u-boot-package "sifive_unmatched" "riscv64-linux-gnu")))
|
||||
@ -1230,7 +1259,11 @@ Documentation} for more information (for example by running @samp{info
|
||||
"CONFIG_SATA_SIL=y"
|
||||
"CONFIG_SCSI=y"
|
||||
"CONFIG_SCSI_AHCI=y"
|
||||
"CONFIG_DM_SCSI=y"))))
|
||||
"CONFIG_DM_SCSI=y"
|
||||
;; Disable SPL FIT signatures,
|
||||
;; due to GPLv2 and Openssl
|
||||
;; license incompatibilities
|
||||
"# CONFIG_SPL_FIT_SIGNATURE is not set"))))
|
||||
(package
|
||||
(inherit base)
|
||||
(arguments
|
||||
|
@ -128,29 +128,28 @@ index 94b7685392..eec599b0ee 100644
|
||||
datai = 0;
|
||||
for (cfgi = 0; cfgi < cfgn; cfgi++) {
|
||||
e = &image_cfg[cfgi];
|
||||
@@ -1552,9 +1568,11 @@ static void *image_create_v1(size_t *imagesz, struct image_tool_params *params,
|
||||
@@ -1624,10 +1640,12 @@ static void *image_create_v1(size_t *dataoff, struct image_tool_params *params,
|
||||
&datai, delay);
|
||||
}
|
||||
|
||||
+#if defined(CONFIG_KWB_SECURE)
|
||||
if (secure_hdr && add_secure_header_v1(params, ptr, payloadsz + headersz,
|
||||
headersz, image, secure_hdr))
|
||||
if (secure_hdr && add_secure_header_v1(params, ptr + *dataoff, payloadsz,
|
||||
image, headersz, secure_hdr))
|
||||
return NULL;
|
||||
+#endif
|
||||
|
||||
*imagesz = headersz;
|
||||
/* Calculate and set the header checksum */
|
||||
main_hdr->checksum = image_checksum8(main_hdr, headersz);
|
||||
|
||||
--- a/tools/image-host.c
|
||||
+++ b/tools/image-host.c
|
||||
@@ -14,10 +14,12 @@
|
||||
@@ -14,8 +14,10 @@
|
||||
#include <image.h>
|
||||
#include <version.h>
|
||||
|
||||
+#ifdef CONFIG_FIT_PRELOAD
|
||||
#include <openssl/pem.h>
|
||||
#include <openssl/evp.h>
|
||||
|
||||
#define IMAGE_PRE_LOAD_PATH "/image/pre-load/sig"
|
||||
+#endif
|
||||
|
||||
/**
|
||||
|
@ -1,84 +0,0 @@
|
||||
Upstream status: https://patchwork.ozlabs.org/project/uboot/list/?series=333259
|
||||
|
||||
diff --git a/Makefile b/Makefile
|
||||
index de5746399a..597a8886c3 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -2372,7 +2372,7 @@ tcheck:
|
||||
# Documentation targets
|
||||
# ---------------------------------------------------------------------------
|
||||
DOC_TARGETS := xmldocs latexdocs pdfdocs htmldocs epubdocs cleandocs \
|
||||
- linkcheckdocs dochelp refcheckdocs
|
||||
+ linkcheckdocs dochelp refcheckdocs texinfodocs infodocs
|
||||
PHONY += $(DOC_TARGETS)
|
||||
$(DOC_TARGETS): scripts_basic FORCE
|
||||
$(Q)$(MAKE) $(build)=doc $@
|
||||
diff --git a/doc/Makefile b/doc/Makefile
|
||||
index f5de65e927..d0904a9f99 100644
|
||||
--- a/doc/Makefile
|
||||
+++ b/doc/Makefile
|
||||
@@ -69,6 +69,14 @@ quiet_cmd_sphinx = SPHINX $@ --> file://$(abspath $(BUILDDIR)/$3/$4)
|
||||
htmldocs:
|
||||
@+$(foreach var,$(SPHINXDIRS),$(call loop_cmd,sphinx,html,$(var),,$(var)))
|
||||
|
||||
+texinfodocs:
|
||||
+ @+$(foreach var,$(SPHINXDIRS),$(call loop_cmd,sphinx,texinfo,$(var),texinfo,$(var)))
|
||||
+
|
||||
+# Note: the 'info' Make target is generated by sphinx itself when
|
||||
+# running the texinfodocs target defined above.
|
||||
+infodocs: texinfodocs
|
||||
+ $(MAKE) -C $(BUILDDIR)/texinfo info
|
||||
+
|
||||
linkcheckdocs:
|
||||
@$(foreach var,$(SPHINXDIRS),$(call loop_cmd,sphinx,linkcheck,$(var),,$(var)))
|
||||
|
||||
@@ -109,6 +117,8 @@ cleandocs:
|
||||
dochelp:
|
||||
@echo ' U-Boot documentation in different formats from ReST:'
|
||||
@echo ' htmldocs - HTML'
|
||||
+ @echo ' texinfodocs - Texinfo'
|
||||
+ @echo ' infodocs - Info'
|
||||
@echo ' latexdocs - LaTeX'
|
||||
@echo ' pdfdocs - PDF'
|
||||
@echo ' epubdocs - EPUB'
|
||||
diff --git a/doc/conf.py b/doc/conf.py
|
||||
index 62c8d31270..3db70f80c1 100644
|
||||
--- a/doc/conf.py
|
||||
+++ b/doc/conf.py
|
||||
@@ -449,7 +449,7 @@ for fn in os.listdir('.'):
|
||||
# One entry per manual page. List of tuples
|
||||
# (source start file, name, description, authors, manual section).
|
||||
man_pages = [
|
||||
- (master_doc, 'dasuboot', 'The U-Boot Documentation',
|
||||
+ (master_doc, 'u-boot', 'The U-Boot Documentation',
|
||||
[author], 1)
|
||||
]
|
||||
|
||||
@@ -463,8 +463,8 @@ man_pages = [
|
||||
# (source start file, target name, title, author,
|
||||
# dir menu entry, description, category)
|
||||
texinfo_documents = [
|
||||
- (master_doc, 'DasUBoot', 'The U-Boot Documentation',
|
||||
- author, 'DasUBoot', 'One line description of project.',
|
||||
+ (master_doc, 'u-boot', 'The U-Boot Documentation',
|
||||
+ author, 'U-Boot', 'Boot loader for embedded systems',
|
||||
'Miscellaneous'),
|
||||
]
|
||||
|
||||
diff --git a/doc/media/Makefile b/doc/media/Makefile
|
||||
index b9b43a34c3..9b32258696 100644
|
||||
--- a/doc/media/Makefile
|
||||
+++ b/doc/media/Makefile
|
||||
@@ -22,10 +22,11 @@ $(BUILDDIR)/linker_lists.h.rst: ${API}/linker_lists.h ${PARSER} $(SRC_DIR)/linke
|
||||
|
||||
# Media build rules
|
||||
|
||||
-.PHONY: all html epub xml latex
|
||||
+.PHONY: all html texinfo epub xml latex
|
||||
|
||||
all: $(IMGDOT) $(BUILDDIR) ${TARGETS}
|
||||
html: all
|
||||
+texinfo: all
|
||||
epub: all
|
||||
xml: all
|
||||
latex: $(IMGPDF) all
|
File diff suppressed because it is too large
Load Diff
@ -5,12 +5,12 @@ Index: u-boot-2021.07~rc4+dfsg/include/configs/sifive-unmatched.h
|
||||
===================================================================
|
||||
--- u-boot-2021.07~rc4+dfsg.orig/include/configs/sifive-unmatched.h
|
||||
+++ u-boot-2021.07~rc4+dfsg/include/configs/sifive-unmatched.h
|
||||
@@ -62,6 +62,8 @@
|
||||
@@ -55,6 +55,8 @@
|
||||
"name=system,size=-,bootable,type=${type_guid_gpt_system};"
|
||||
|
||||
#define CONFIG_EXTRA_ENV_SETTINGS \
|
||||
#define CFG_EXTRA_ENV_SETTINGS \
|
||||
+ "fdt_high=0xffffffffffffffff\0" \
|
||||
+ "initrd_high=0xffffffffffffffff\0" \
|
||||
"kernel_addr_r=0x84000000\0" \
|
||||
"fdt_addr_r=0x88000000\0" \
|
||||
"scriptaddr=0x88100000\0" \
|
||||
"kernel_comp_addr_r=0x88000000\0" \
|
||||
"kernel_comp_size=0x4000000\0" \
|
||||
|
Loading…
Reference in New Issue
Block a user