gnu: libvirt: Update to 5.8.0.

* gnu/local.mk (dist_patch_DATA): Add new patch file.
* gnu/packages/patches/libvirt-create-machine-cgroup.patch: New patch,
submitted to upstream for upstream bug 1760233.
* gnu/packages/virtualization.scm (libvirt): Update version to 5.8.0.
Include patch.  Avoid execution of failing tests qemuxml2argvtest and
qemuhotplugtest.  Replace python by python-wrapper to avoid warnings on
patch-shebangs phase.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
This commit is contained in:
Miguel Ángel Arruga Vivas 2019-11-02 00:31:44 +01:00 committed by Ludovic Courtès
parent cd2c3dc2d6
commit aa1f0896fb
No known key found for this signature in database
GPG Key ID: 090B11993D9AEBB5
3 changed files with 56 additions and 3 deletions

View File

@ -1005,6 +1005,7 @@ dist_patch_DATA = \
%D%/packages/patches/java-xerces-xjavac_taskdef.patch \
%D%/packages/patches/jbig2dec-ignore-testtest.patch \
%D%/packages/patches/kdbusaddons-kinit-file-name.patch \
%D%/packages/patches/libvirt-create-machine-cgroup.patch \
%D%/packages/patches/libziparchive-add-includes.patch \
%D%/packages/patches/localed-xorg-keyboard.patch \
%D%/packages/patches/kiki-level-selection-crash.patch \

View File

@ -0,0 +1,48 @@
From 9ca0b2955edea162b255b428e493cd8ffac52167 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Miguel=20=C3=81ngel=20Arruga=20Vivas?=
<rosen644835@gmail.com>
Date: Fri, 1 Nov 2019 17:29:00 +0100
Subject: [PATCH] vircgroup: Ensure /machine group is associated with its
parent.
Call first virCgroupNew on the parent group virCgroupNewPartition if
it is available on before the creation of the child group. This
ensures that the creation of a first level group on the unified
architecture, as the check at virCgroupV2ParseControllersFile as the
parent file is there.
Fixes: https://bugzilla.redhat.com/show_bug.cgi?id=1760233
---
src/util/vircgroup.c | 8 +++++---
1 file changed, 5 insertions(+), 3 deletions(-)
diff --git a/src/util/vircgroup.c b/src/util/vircgroup.c
index b46f20abfd..33c61f2d45 100644
--- a/src/util/vircgroup.c
+++ b/src/util/vircgroup.c
@@ -855,9 +855,6 @@ virCgroupNewPartition(const char *path,
if (virCgroupSetPartitionSuffix(path, &newPath) < 0)
goto cleanup;
- if (virCgroupNew(-1, newPath, NULL, controllers, group) < 0)
- goto cleanup;
-
if (STRNEQ(newPath, "/")) {
char *tmp;
parentPath = g_strdup(newPath);
@@ -868,7 +865,12 @@ virCgroupNewPartition(const char *path,
if (virCgroupNew(-1, parentPath, NULL, controllers, &parent) < 0)
goto cleanup;
+ }
+ if (virCgroupNew(-1, newPath, parent, controllers, group) < 0)
+ goto cleanup;
+
+ if (parent) {
if (virCgroupMakeGroup(parent, *group, create, VIR_CGROUP_NONE) < 0)
goto cleanup;
}
--
2.23.0

View File

@ -400,14 +400,16 @@ manage system or application containers.")
(define-public libvirt
(package
(name "libvirt")
(version "5.6.0")
(version "5.8.0")
(source
(origin
(method url-fetch)
(uri (string-append "https://libvirt.org/sources/libvirt-"
version ".tar.xz"))
(sha256
(base32 "1d5rmcx5fgb024hw8chbiv886n3jal5wp2yajjk5l4qh9s9gkx35"))))
(base32 "0m8cqaqflvys5kaqpvb0qr4k365j09jc5xk6x70yvg8qkcl2hcz2"))
(patches
(search-patches "libvirt-create-machine-cgroup.patch"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags
@ -439,6 +441,8 @@ manage system or application containers.")
(add-before 'configure 'disable-broken-tests
(lambda _
(let ((tests (list "commandtest" ; hangs idly
"qemuxml2argvtest" ; fails
"qemuhotplugtest" ; fails
"virnetsockettest" ; tries to network
"virshtest"))) ; fails
(substitute* "tests/Makefile.in"
@ -480,7 +484,7 @@ manage system or application containers.")
("perl" ,perl)
("pkg-config" ,pkg-config)
("polkit" ,polkit)
("python" ,python)))
("python" ,python-wrapper)))
(home-page "https://libvirt.org")
(synopsis "Simple API for virtualization")
(description "Libvirt is a C toolkit to interact with the virtualization