gnu: widelands: Fix build against boost 1.77.
Widelands fails to build with boost 1.77 due to a missing include in one of Wideland's header files that was previously indirectly included by boost 1.76. * gnu/packages/patches/widelands-add-missing-map-include.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/games.scm (widelands)[source]: Add patch. Signed-off-by: Leo Famulari <leo@famulari.name>
This commit is contained in:
parent
6f83a503af
commit
a83dc5022b
@ -1928,6 +1928,7 @@ dist_patch_DATA = \
|
||||
%D%/packages/patches/wicd-get-selected-profile-fix.patch \
|
||||
%D%/packages/patches/wicd-urwid-1.3.patch \
|
||||
%D%/packages/patches/wicd-wpa2-ttls.patch \
|
||||
%D%/packages/patches/widelands-add-missing-map-include.patch \
|
||||
%D%/packages/patches/widelands-system-wide_minizip.patch \
|
||||
%D%/packages/patches/wmctrl-64-fix.patch \
|
||||
%D%/packages/patches/wmfire-update-for-new-gdk-versions.patch \
|
||||
|
@ -61,7 +61,7 @@
|
||||
;;; Copyright © 2021 Stefan Reichör <stefan@xsteve.at>
|
||||
;;; Copyright © 2021 Greg Hogan <code@greghogan.com>
|
||||
;;; Copyright © 2021 David Pflug <david@pflug.io>
|
||||
;;; Copyright © 2021 Felix Gruber <felgru@posteo.net>
|
||||
;;; Copyright © 2021, 2022 Felix Gruber <felgru@posteo.net>
|
||||
;;; Copyright © 2021 Solene Rapenne <solene@perso.pw>
|
||||
;;; Copyright © 2021 Noisytoot <noisytoot@disroot.org>
|
||||
;;; Copyright © 2021 Petr Hodina <phodina@protonmail.com>
|
||||
@ -5135,7 +5135,8 @@ tactics.")
|
||||
(patches
|
||||
;; Use system Minizip. Patch is provided by Debian, and discussed
|
||||
;; upstream at <https://github.com/widelands/widelands/issues/399>.
|
||||
(search-patches "widelands-system-wide_minizip.patch"))))
|
||||
(search-patches "widelands-system-wide_minizip.patch"
|
||||
"widelands-add-missing-map-include.patch"))))
|
||||
(build-system cmake-build-system)
|
||||
(arguments
|
||||
`(#:configure-flags
|
||||
|
28
gnu/packages/patches/widelands-add-missing-map-include.patch
Normal file
28
gnu/packages/patches/widelands-add-missing-map-include.patch
Normal file
@ -0,0 +1,28 @@
|
||||
From 316eaea209754368a57f445ea4dd016ecf8eded6 Mon Sep 17 00:00:00 2001
|
||||
From: matthiakl <t-m.42@mailpost.spdns.org>
|
||||
Date: Sat, 14 Aug 2021 19:24:08 +0200
|
||||
Subject: [PATCH] Added missing direct incude (#5025)
|
||||
|
||||
---
|
||||
This patch is from
|
||||
https://github.com/widelands/widelands/pull/5025
|
||||
which has been merged after the release of Widelands 1.0.
|
||||
|
||||
src/network/bufferedconnection.h | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/src/network/bufferedconnection.h b/src/network/bufferedconnection.h
|
||||
index fe974b9e..7e1ecf87 100644
|
||||
--- a/src/network/bufferedconnection.h
|
||||
+++ b/src/network/bufferedconnection.h
|
||||
@@ -20,6 +20,7 @@
|
||||
#ifndef WL_NETWORK_BUFFEREDCONNECTION_H
|
||||
#define WL_NETWORK_BUFFEREDCONNECTION_H
|
||||
|
||||
+#include <map>
|
||||
#include <memory>
|
||||
#include <mutex>
|
||||
#include <thread>
|
||||
--
|
||||
2.30.2
|
||||
|
Loading…
Reference in New Issue
Block a user