gnu: tor: Update to 0.4.8.6.
* gnu/packages/tor.scm (tor): Update to 0.4.8.6. [source]: Remove patch. * gnu/packages/patches/tor-remove-defensive-assert.patch: Remove file. * gnu/local.mk (dist_patch_DATA): Remove it.
This commit is contained in:
parent
926a79a86a
commit
a515f8b1d8
@ -2023,7 +2023,6 @@ dist_patch_DATA = \
|
|||||||
%D%/packages/patches/tofi-32bit-compat.patch \
|
%D%/packages/patches/tofi-32bit-compat.patch \
|
||||||
%D%/packages/patches/tootle-glib-object-naming.patch \
|
%D%/packages/patches/tootle-glib-object-naming.patch \
|
||||||
%D%/packages/patches/tootle-reason-phrase.patch \
|
%D%/packages/patches/tootle-reason-phrase.patch \
|
||||||
%D%/packages/patches/tor-remove-defensive-assert.patch \
|
|
||||||
%D%/packages/patches/transcode-ffmpeg.patch \
|
%D%/packages/patches/transcode-ffmpeg.patch \
|
||||||
%D%/packages/patches/transfig-gcc10-fno-common.patch \
|
%D%/packages/patches/transfig-gcc10-fno-common.patch \
|
||||||
%D%/packages/patches/trytond-add-egg-modules-to-path.patch \
|
%D%/packages/patches/trytond-add-egg-modules-to-path.patch \
|
||||||
|
@ -1,28 +0,0 @@
|
|||||||
This patch removes a call to `tor_assert_nonfatal_unreached()` in
|
|
||||||
`relay_key_is_unavailable_()` that is only called when Tor is compiled
|
|
||||||
without relay support.
|
|
||||||
|
|
||||||
Unfortunately, the non-fatal assertion causes a BUG log
|
|
||||||
message to appear for clients when they start up without relay support
|
|
||||||
for each CPU worker we spawn. This makes it spotting issues during
|
|
||||||
bootstrap harder particularly for our iOS developers.
|
|
||||||
|
|
||||||
Since the call sites to `get_master_identity_key()` handles `NULL`
|
|
||||||
values already, we do not think this will be an issue later on.
|
|
||||||
|
|
||||||
Reported by Benjamin Erhart (@tla) from Guardian Project.
|
|
||||||
|
|
||||||
Fixes tpo/core/tor#40848.
|
|
||||||
|
|
||||||
diff --git a/src/feature/relay/routerkeys.h b/src/feature/relay/routerkeys.h
|
|
||||||
index 7b6d80773c..b97615a9c9 100644
|
|
||||||
--- a/src/feature/relay/routerkeys.h
|
|
||||||
+++ b/src/feature/relay/routerkeys.h
|
|
||||||
@@ -53,7 +53,6 @@ void routerkeys_free_all(void);
|
|
||||||
static inline void *
|
|
||||||
relay_key_is_unavailable_(void)
|
|
||||||
{
|
|
||||||
- tor_assert_nonfatal_unreached();
|
|
||||||
return NULL;
|
|
||||||
}
|
|
||||||
#define relay_key_is_unavailable(type) \
|
|
@ -1,7 +1,7 @@
|
|||||||
;;; GNU Guix --- Functional package management for GNU
|
;;; GNU Guix --- Functional package management for GNU
|
||||||
;;; Copyright © 2013, 2014, 2015, 2021 Ludovic Courtès <ludo@gnu.org>
|
;;; Copyright © 2013, 2014, 2015, 2021 Ludovic Courtès <ludo@gnu.org>
|
||||||
;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
|
;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
|
||||||
;;; Copyright © 2016, 2017, 2018, 2020, 2021, 2022 Efraim Flashner <efraim@flashner.co.il>
|
;;; Copyright © 2016-2018, 2020-2023 Efraim Flashner <efraim@flashner.co.il>
|
||||||
;;; Copyright © 2016, 2017 Nikita <nikita@n0.is>
|
;;; Copyright © 2016, 2017 Nikita <nikita@n0.is>
|
||||||
;;; Copyright © 2017–2021 Tobias Geerinckx-Rice <me@tobias.gr>
|
;;; Copyright © 2017–2021 Tobias Geerinckx-Rice <me@tobias.gr>
|
||||||
;;; Copyright © 2017, 2018, 2019, 2021, 2023 Eric Bavier <bavier@posteo.net>
|
;;; Copyright © 2017, 2018, 2019, 2021, 2023 Eric Bavier <bavier@posteo.net>
|
||||||
@ -63,15 +63,14 @@
|
|||||||
(define-public tor
|
(define-public tor
|
||||||
(package
|
(package
|
||||||
(name "tor")
|
(name "tor")
|
||||||
(version "0.4.8.5")
|
(version "0.4.8.6")
|
||||||
(source (origin
|
(source (origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
(uri (string-append "https://dist.torproject.org/tor-"
|
(uri (string-append "https://dist.torproject.org/tor-"
|
||||||
version ".tar.gz"))
|
version ".tar.gz"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"06g1awb4piqvgxa97pyswxgjzkpj8rx3iy2jbiaygvi99b8wymv9"))
|
"122h6l3nh8xrpzkmn4alsbz30jw8nxivwnhgnp97qv7nr9gqjbam"))))
|
||||||
(patches (search-patches "tor-remove-defensive-assert.patch"))))
|
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
(arguments
|
(arguments
|
||||||
(list #:configure-flags
|
(list #:configure-flags
|
||||||
|
Loading…
Reference in New Issue
Block a user