gnu: Update kde frameworks to 5.34.0.
* gnu/packages/kde-frameworks.scm (solid): Update to 5.34.0 [native-inputs]: Add dbus. <check>: Replace standard phase. (networkmanager-qt): Update to 5.34.0. [source]: Remove patches. (kfilemetadata) Update to 5.32.0. <check-setup>: New phase <check> Move phase after install phase. [inputs] Add catdoc, exiv2, ffmpeg, poppler, taglib. (attica, baloo, bluez-qt, breeze-icons, extra-cmake-modules, kactivities, kactivities-stats, kapidox, karchive, kauth, kbookmarks, kcmutils, kcodecs, kcompletion, kconfig, kconfigwidgets, kcoreaddons, kcrash, kdbusaddons, kdeclarative, kded, kdesignerplugin, kdesu, kdnssd, kdoctools, kemoticons, kglobalaccel, kguiaddons, ki18n, kiconthemes, kidletime, kimageformats, kinit, kio, kitemmodels, kitemviews, kjobwidgets, knewstuff, knotification, knotifyconfig, kpackages, kparts, kpeople, kplotting, kpty, krunner, kservice, ksyntaxhighlighting, ktexteditor, ktextwidgets, kunitconversion, kwallet, kwayland, kwidgetsaddons, kwindowsystem, kxmlgui, kxmlrpcclient, modemmanager-qt, networkmanager-qt, oxygen-icons, plasma-framework, sonnet, threadweaver): Update to 5.34.0. * gnu/packages/patches/networkmanager-qt-activeconnection-test-1.patch, gnu/packages/patches/networkmanager-qt-activeconnection-test-2.patch: Remove files. * gnu/local.mk (dist_patch_DATA): Remove the patch files.
This commit is contained in:
parent
d0abaf8960
commit
9eb0f43031
@ -834,8 +834,6 @@ dist_patch_DATA = \
|
||||
%D%/packages/patches/netsurf-system-utf8proc.patch \
|
||||
%D%/packages/patches/netsurf-y2038-tests.patch \
|
||||
%D%/packages/patches/netsurf-longer-test-timeout.patch \
|
||||
%D%/packages/patches/networkmanager-qt-activeconnection-test-1.patch \
|
||||
%D%/packages/patches/networkmanager-qt-activeconnection-test-2.patch \
|
||||
%D%/packages/patches/ngircd-handle-zombies.patch \
|
||||
%D%/packages/patches/ninja-zero-mtime.patch \
|
||||
%D%/packages/patches/node-9077.patch \
|
||||
|
File diff suppressed because it is too large
Load Diff
@ -1,60 +0,0 @@
|
||||
From 61337983ba74361938b7d5323de5d2819a235fdc Mon Sep 17 00:00:00 2001
|
||||
From: Jan Grulich <jgrulich@redhat.com>
|
||||
Date: Mon, 3 Apr 2017 12:53:12 +0200
|
||||
Subject: Fix unit test for active connections
|
||||
|
||||
Instead of sending PropertiesChanged signal for an active connection we
|
||||
added recently we should set all properties initially and just advertise
|
||||
that we have a new active connection once everything is set
|
||||
---
|
||||
src/fakenetwork/fakenetwork.cpp | 26 +++++++-------------------
|
||||
1 file changed, 7 insertions(+), 19 deletions(-)
|
||||
|
||||
diff --git a/src/fakenetwork/fakenetwork.cpp b/src/fakenetwork/fakenetwork.cpp
|
||||
index bc1144e..261fe8e 100644
|
||||
--- a/src/fakenetwork/fakenetwork.cpp
|
||||
+++ b/src/fakenetwork/fakenetwork.cpp
|
||||
@@ -215,8 +215,14 @@ void FakeNetwork::unregisterService()
|
||||
|
||||
QDBusObjectPath FakeNetwork::ActivateConnection(const QDBusObjectPath &connection, const QDBusObjectPath &device, const QDBusObjectPath &specific_object)
|
||||
{
|
||||
- ActiveConnection *newActiveConnection = new ActiveConnection(this);
|
||||
QString newActiveConnectionPath = QString("/org/kde/fakenetwork/ActiveConnection/") + QString::number(m_activeConnectionsCounter++);
|
||||
+ ActiveConnection *newActiveConnection = new ActiveConnection(this);
|
||||
+ newActiveConnection->addDevice(device);
|
||||
+ newActiveConnection->setActiveConnectionPath(newActiveConnectionPath);
|
||||
+ newActiveConnection->setConnection(connection);
|
||||
+ newActiveConnection->setSpecificObject(specific_object);
|
||||
+ newActiveConnection->setState(NetworkManager::ActiveConnection::Activating);
|
||||
+
|
||||
m_activeConnections.insert(QDBusObjectPath(newActiveConnectionPath), newActiveConnection);
|
||||
QDBusConnection::sessionBus().registerObject(newActiveConnectionPath, newActiveConnection, QDBusConnection::ExportScriptableContents);
|
||||
|
||||
@@ -227,24 +233,6 @@ QDBusObjectPath FakeNetwork::ActivateConnection(const QDBusObjectPath &connectio
|
||||
map.insert(QLatin1Literal("ActivatingConnection"), QVariant::fromValue(QDBusObjectPath(newActiveConnectionPath)));
|
||||
Q_EMIT PropertiesChanged(map);
|
||||
|
||||
- newActiveConnection->addDevice(device);
|
||||
- newActiveConnection->setActiveConnectionPath(newActiveConnectionPath);
|
||||
- newActiveConnection->setConnection(connection);
|
||||
- newActiveConnection->setSpecificObject(specific_object);
|
||||
- newActiveConnection->setState(NetworkManager::ActiveConnection::Activating);
|
||||
-
|
||||
- map.clear();
|
||||
- const QList<QDBusObjectPath> deviceList { device };
|
||||
- map.insert(QLatin1Literal("Devices"), QVariant::fromValue<QList<QDBusObjectPath> >(deviceList));
|
||||
- map.insert(QLatin1Literal("Connection"), QVariant::fromValue<QDBusObjectPath>(connection));
|
||||
- if (!specific_object.path().isEmpty()) {
|
||||
- map.insert(QLatin1Literal("SpecificObject"), QVariant::fromValue<QDBusObjectPath>(connection));
|
||||
- }
|
||||
- map.insert(QLatin1Literal("State"), NetworkManager::ActiveConnection::Activating);
|
||||
- QDBusMessage message = QDBusMessage::createSignal(newActiveConnectionPath, QLatin1Literal("org.kde.fakenetwork.Connection.Active"), QLatin1Literal("PropertiesChanged"));
|
||||
- message << map;
|
||||
- QDBusConnection::sessionBus().send(message);
|
||||
-
|
||||
Device *usedDevice = static_cast<Device *>(QDBusConnection::sessionBus().objectRegisteredAt(device.path()));
|
||||
if (usedDevice) {
|
||||
m_activatedDevice = usedDevice->devicePath();
|
||||
--
|
||||
cgit v0.11.2
|
||||
|
@ -1,57 +0,0 @@
|
||||
From 3f6155389abc8e2b3dafc5eefa1ce0c929b007fa Mon Sep 17 00:00:00 2001
|
||||
From: Jan Grulich <jgrulich@redhat.com>
|
||||
Date: Mon, 3 Apr 2017 14:13:54 +0200
|
||||
Subject: One more attempt to fix unit test for active connections
|
||||
|
||||
---
|
||||
src/activeconnection.cpp | 10 ++++++++++
|
||||
1 file changed, 10 insertions(+)
|
||||
|
||||
diff --git a/src/activeconnection.cpp b/src/activeconnection.cpp
|
||||
index 05582fa..3a8e6b2 100644
|
||||
--- a/src/activeconnection.cpp
|
||||
+++ b/src/activeconnection.cpp
|
||||
@@ -79,11 +79,13 @@ NetworkManager::ActiveConnection::ActiveConnection(const QString &path, QObject
|
||||
connect(&d->iface, &OrgFreedesktopNetworkManagerConnectionActiveInterface::PropertiesChanged, d, &ActiveConnectionPrivate::propertiesChanged);
|
||||
#endif
|
||||
|
||||
+#ifndef NMQT_STATIC
|
||||
/*
|
||||
* Workaround: Re-check connection state before we watch changes in case it gets changed too quickly
|
||||
* BUG:352326
|
||||
*/
|
||||
d->recheckProperties();
|
||||
+#endif
|
||||
}
|
||||
|
||||
NetworkManager::ActiveConnection::ActiveConnection(ActiveConnectionPrivate &dd, QObject *parent)
|
||||
@@ -91,18 +93,26 @@ NetworkManager::ActiveConnection::ActiveConnection(ActiveConnectionPrivate &dd,
|
||||
{
|
||||
Q_D(ActiveConnection);
|
||||
|
||||
+#ifndef NMQT_STATIC
|
||||
#if NM_CHECK_VERSION(1, 4, 0)
|
||||
QDBusConnection::systemBus().connect(NetworkManagerPrivate::DBUS_SERVICE, d->path, NetworkManagerPrivate::FDO_DBUS_PROPERTIES,
|
||||
QLatin1String("PropertiesChanged"), d, SLOT(dbusPropertiesChanged(QString,QVariantMap,QStringList)));
|
||||
#else
|
||||
connect(&d->iface, &OrgFreedesktopNetworkManagerConnectionActiveInterface::PropertiesChanged, d, &ActiveConnectionPrivate::propertiesChanged);
|
||||
#endif
|
||||
+#endif
|
||||
+
|
||||
+#ifdef NMQT_STATIC
|
||||
+ connect(&d->iface, &OrgFreedesktopNetworkManagerConnectionActiveInterface::PropertiesChanged, d, &ActiveConnectionPrivate::propertiesChanged);
|
||||
+#endif
|
||||
|
||||
+#ifndef NMQT_STATIC
|
||||
/*
|
||||
* Workaround: Re-check connection state before we watch changes in case it gets changed too quickly
|
||||
* BUG:352326
|
||||
*/
|
||||
d->recheckProperties();
|
||||
+#endif
|
||||
}
|
||||
|
||||
NetworkManager::ActiveConnection::~ActiveConnection()
|
||||
--
|
||||
cgit v0.11.2
|
||||
|
Loading…
Reference in New Issue
Block a user