gnu: mars: Update to commit 84664cda.
* gnu/packages/games.scm (mars): Update commit to 84664cda, revision2. [source]: Remove upstreamed patches. [arguments]: Move 'fix-install-path' phase to #:configure-flags. Remove boolean return values from phases. [home-page]: Use https. * gnu/packages/patches/mars-install.patch, gnu/packages/patches/mars-sfml-2.3.patch: Delete files. * gnu/local.mk (dist_patch_DATA): Adjust accordingly.
This commit is contained in:
parent
b24e05788c
commit
97abc5d45a
@ -1540,8 +1540,6 @@ dist_patch_DATA = \
|
||||
%D%/packages/patches/lxqt-session-procps-4.patch \
|
||||
%D%/packages/patches/mailutils-variable-lookup.patch \
|
||||
%D%/packages/patches/make-impure-dirs.patch \
|
||||
%D%/packages/patches/mars-install.patch \
|
||||
%D%/packages/patches/mars-sfml-2.3.patch \
|
||||
%D%/packages/patches/mathjax-disable-webpack.patch \
|
||||
%D%/packages/patches/mathjax-no-a11y.patch \
|
||||
%D%/packages/patches/mathjax-3.1.2-no-a11y.patch \
|
||||
|
@ -2,7 +2,7 @@
|
||||
;;; Copyright © 2013 John Darrington <jmd@gnu.org>
|
||||
;;; Copyright © 2013 Nikita Karetnikov <nikita@karetnikov.org>
|
||||
;;; Copyright © 2014, 2015 David Thompson <dthompson2@worcester.edu>
|
||||
;;; Copyright © 2014-2022 Eric Bavier <bavier@posteo.net>
|
||||
;;; Copyright © 2014-2023 Eric Bavier <bavier@posteo.net>
|
||||
;;; Copyright © 2014 Cyrill Schenkel <cyrill.schenkel@gmail.com>
|
||||
;;; Copyright © 2014 Sylvain Beucler <beuc@beuc.net>
|
||||
;;; Copyright © 2014, 2015, 2018, 2019, 2021 Ludovic Courtès <ludo@gnu.org>
|
||||
@ -3739,11 +3739,11 @@ for common mesh file formats, and collision detection.")
|
||||
;; The latest release on SourceForge relies on an unreleased version of SFML
|
||||
;; with a different API, so we take the latest version from the official
|
||||
;; repository on Github.
|
||||
(let ((commit "c855d044094a1d92317e38935d81ba938946132e")
|
||||
(revision "1"))
|
||||
(let ((commit "84664cda094efe6e49d9b1550e4f4f98c33eefa2")
|
||||
(revision "2"))
|
||||
(package
|
||||
(name "mars")
|
||||
(version (string-append "0.7.5." revision "." (string-take commit 7) ))
|
||||
(version (git-version "0.7.5" revision commit))
|
||||
(source (origin
|
||||
(method git-fetch)
|
||||
(uri (git-reference
|
||||
@ -3752,31 +3752,24 @@ for common mesh file formats, and collision detection.")
|
||||
(file-name (git-file-name name version))
|
||||
(sha256
|
||||
(base32
|
||||
"1r4c5gap1z2zsv4yjd34qriqkxaq4lb4rykapyzkkdf4g36lc3nh"))
|
||||
(patches (search-patches "mars-sfml-2.3.patch"
|
||||
"mars-install.patch"))))
|
||||
"0bdi4ja39rark742qvqixm8khai5k8qd84z5kzim9jcjdvvwyqj9"))))
|
||||
(build-system cmake-build-system)
|
||||
(arguments
|
||||
`(#:tests? #f ; There are no tests
|
||||
#:configure-flags (list (string-append "-Dmars_EXE_DEST_DIR="
|
||||
%output "/bin"))
|
||||
#:phases
|
||||
(modify-phases %standard-phases
|
||||
(add-after 'unpack 'fix-install-path
|
||||
(lambda _
|
||||
(substitute* "src/CMakeLists.txt"
|
||||
(("\\$\\{CMAKE_INSTALL_PREFIX\\}/games")
|
||||
"${CMAKE_INSTALL_PREFIX}/bin"))
|
||||
#t))
|
||||
(add-after 'unpack 'fix-data-path
|
||||
(lambda* (#:key outputs #:allow-other-keys)
|
||||
(substitute* "src/System/settings.cpp"
|
||||
(("C_dataPath = \"./data/\";")
|
||||
(string-append "C_dataPath = \""
|
||||
(assoc-ref outputs "out")
|
||||
"/share/games/marsshooter/\";")))
|
||||
#t)))))
|
||||
"/share/games/marsshooter/\";"))))))))
|
||||
(inputs
|
||||
(list mesa fribidi taglib sfml))
|
||||
(home-page "http://mars-game.sourceforge.net/")
|
||||
(home-page "https://mars-game.sourceforge.net/")
|
||||
(synopsis "2D space shooter")
|
||||
(description
|
||||
"M.A.R.S. is a 2D space shooter with pretty visual effects and
|
||||
|
@ -1,17 +0,0 @@
|
||||
Remove install target for non-existant directory.
|
||||
|
||||
--- a/src/CMakeLists.txt 2015-09-13 20:52:28.517344327 +0200
|
||||
+++ b/src/CMakeLists.txt 2015-09-13 20:53:04.842453987 +0200
|
||||
@@ -122,12 +122,6 @@
|
||||
DESTINATION
|
||||
${CMAKE_INSTALL_PREFIX}/share/applications
|
||||
)
|
||||
- install(
|
||||
- FILES
|
||||
- ${MARS_SOURCE_DIR}/resources/mars
|
||||
- DESTINATION
|
||||
- ${CMAKE_INSTALL_PREFIX}/share/menu
|
||||
- )
|
||||
|
||||
else(UNIX)
|
||||
# executable
|
@ -1,151 +0,0 @@
|
||||
This is a concatenation of the following two patches:
|
||||
|
||||
https://github.com/jcowgill/M.A.R.S./commit/33d5affabf8ff84f2c028b9303c6a9e83cc824ad.patch
|
||||
https://patch-diff.githubusercontent.com/raw/thelaui/M.A.R.S./pull/2.patch
|
||||
|
||||
Their purpose is to allow Mars to be built against the latest version of SFML.
|
||||
|
||||
From 33d5affabf8ff84f2c028b9303c6a9e83cc824ad Mon Sep 17 00:00:00 2001
|
||||
From: James Cowgill <james410@cowgill.org.uk>
|
||||
Date: Sat, 9 May 2015 01:54:14 +0100
|
||||
Subject: [PATCH] Remove dependency on GLU - fixes build with SFML 2.3
|
||||
|
||||
---
|
||||
premake4.lua | 8 ++++----
|
||||
src/Shaders/postFX.cpp | 2 +-
|
||||
src/System/window.cpp | 12 ++++++------
|
||||
3 files changed, 11 insertions(+), 11 deletions(-)
|
||||
|
||||
diff --git a/premake4.lua b/premake4.lua
|
||||
index 023dddd..5af4495 100755
|
||||
--- a/premake4.lua
|
||||
+++ b/premake4.lua
|
||||
@@ -11,11 +11,11 @@ project "mars"
|
||||
defines { "NDEBUG" }
|
||||
flags { "Optimize" }
|
||||
if os.get() == "windows" then
|
||||
- links { "sfml-graphics", "sfml-audio", "sfml-system", "sfml-window", "glu32", "opengl32", "fribidi-0", "tag" }
|
||||
+ links { "sfml-graphics", "sfml-audio", "sfml-system", "sfml-window", "opengl32", "fribidi-0", "tag" }
|
||||
elseif os.get() == "macosx" then
|
||||
links { "sfml-graphics.framework", "sfml-audio.framework", "sfml-system.framework", "sfml-window.framework", "opengl.framework", "fribidi", "tag" }
|
||||
else
|
||||
- links { "GLU", "sfml-graphics", "sfml-audio", "sfml-system", "sfml-window", "fribidi", "tag" }
|
||||
+ links { "sfml-graphics", "sfml-audio", "sfml-system", "sfml-window", "fribidi", "tag" }
|
||||
libdirs { "/usr/lib", "/usr/local/lib" }
|
||||
end
|
||||
|
||||
@@ -23,10 +23,10 @@ project "mars"
|
||||
defines { "_DEBUG", "DEBUG" }
|
||||
flags { "Symbols" }
|
||||
if os.get() == "windows" then
|
||||
- links { "sfml-graphics", "sfml-audio", "sfml-system", "sfml-window", "glu32", "opengl32", "fribidi-0", "tag" }
|
||||
+ links { "sfml-graphics", "sfml-audio", "sfml-system", "sfml-window", "opengl32", "fribidi-0", "tag" }
|
||||
elseif os.get() == "macosx" then
|
||||
links { "sfml-graphics.framework", "sfml-audio.framework", "sfml-system.framework", "sfml-window.framework", "opengl.framework", "fribidi", "tag" }
|
||||
else
|
||||
- links { "GLU", "sfml-graphics", "sfml-audio", "sfml-system", "sfml-window", "fribidi", "tag" }
|
||||
+ links { "sfml-graphics", "sfml-audio", "sfml-system", "sfml-window", "fribidi", "tag" }
|
||||
libdirs { "/usr/lib", "/usr/local/lib" }
|
||||
end
|
||||
diff --git a/src/Shaders/postFX.cpp b/src/Shaders/postFX.cpp
|
||||
index 987f411..f767a47 100644
|
||||
--- a/src/Shaders/postFX.cpp
|
||||
+++ b/src/Shaders/postFX.cpp
|
||||
@@ -78,7 +78,7 @@ namespace postFX {
|
||||
postFX_.loadFromFile(settings::C_dataPath + "shaders/bump.frag", sf::Shader::Fragment);
|
||||
bumpMap_.create(SPACE_X_RESOLUTION*0.5f, SPACE_Y_RESOLUTION*0.5f);
|
||||
glViewport(0,0,SPACE_X_RESOLUTION*0.5f,SPACE_Y_RESOLUTION*0.5f);
|
||||
- gluOrtho2D(0, SPACE_X_RESOLUTION, SPACE_Y_RESOLUTION, 0);
|
||||
+ glOrtho(0, SPACE_X_RESOLUTION, SPACE_Y_RESOLUTION, 0, -1, 1);
|
||||
glEnable(GL_BLEND);
|
||||
glMatrixMode(GL_MODELVIEW);
|
||||
postFX_.setParameter("BumpMap", bumpMap_.getTexture());
|
||||
diff --git a/src/System/window.cpp b/src/System/window.cpp
|
||||
index e9a099a..8e12dcc 100644
|
||||
--- a/src/System/window.cpp
|
||||
+++ b/src/System/window.cpp
|
||||
@@ -222,7 +222,7 @@ namespace window {
|
||||
glLoadIdentity();
|
||||
|
||||
// Setup translation (according to left-upper corner)
|
||||
- gluOrtho2D(0.f, SPACE_X_RESOLUTION, SPACE_Y_RESOLUTION, 0.f);
|
||||
+ glOrtho(0.f, SPACE_X_RESOLUTION, SPACE_Y_RESOLUTION, 0.f, -1, 1);
|
||||
|
||||
// probably improves performance...
|
||||
glDisable(GL_LIGHTING);
|
||||
@@ -247,7 +247,7 @@ namespace window {
|
||||
|
||||
glMatrixMode(GL_PROJECTION);
|
||||
glLoadIdentity();
|
||||
- gluOrtho2D(0.f, viewPort_.x_, viewPort_.y_, 0.f);
|
||||
+ glOrtho(0.f, viewPort_.x_, viewPort_.y_, 0.f, -1, 1);
|
||||
glMatrixMode(GL_MODELVIEW);
|
||||
glLoadIdentity();
|
||||
|
||||
@@ -255,7 +255,7 @@ namespace window {
|
||||
|
||||
glMatrixMode(GL_PROJECTION);
|
||||
glLoadIdentity();
|
||||
- gluOrtho2D(0.f, SPACE_X_RESOLUTION, SPACE_Y_RESOLUTION, 0.f);
|
||||
+ glOrtho(0.f, SPACE_X_RESOLUTION, SPACE_Y_RESOLUTION, 0.f, -1, 1);
|
||||
glMatrixMode(GL_MODELVIEW);
|
||||
glLoadIdentity();
|
||||
}
|
||||
@@ -270,7 +270,7 @@ namespace window {
|
||||
glLoadIdentity();
|
||||
setViewPort();
|
||||
|
||||
- gluOrtho2D(0.f, viewPort_.x_, viewPort_.y_, 0.f);
|
||||
+ glOrtho(0.f, viewPort_.x_, viewPort_.y_, 0.f, -1, 1);
|
||||
|
||||
glMatrixMode(GL_MODELVIEW);
|
||||
glLoadIdentity();
|
||||
@@ -284,7 +284,7 @@ namespace window {
|
||||
glLoadIdentity();
|
||||
setViewPort();
|
||||
|
||||
- gluOrtho2D(0.f, viewPort_.x_, viewPort_.y_, 0.f);
|
||||
+ glOrtho(0.f, viewPort_.x_, viewPort_.y_, 0.f, -1, 1);
|
||||
|
||||
glMatrixMode(GL_MODELVIEW);
|
||||
glLoadIdentity();
|
||||
@@ -294,7 +294,7 @@ namespace window {
|
||||
else {
|
||||
glMatrixMode(GL_PROJECTION);
|
||||
glLoadIdentity();
|
||||
- gluOrtho2D(0.f, viewPort_.x_, viewPort_.y_, 0.f);
|
||||
+ glOrtho(0.f, viewPort_.x_, viewPort_.y_, 0.f, -1, 1);
|
||||
glMatrixMode(GL_MODELVIEW);
|
||||
glLoadIdentity();
|
||||
}
|
||||
|
||||
From a97d0d6a19b5b43e3c53081e36f1f1747b6674e6 Mon Sep 17 00:00:00 2001
|
||||
From: Sylvain BOILARD <boilard@crans.org>
|
||||
Date: Wed, 23 Jan 2013 02:02:47 +0100
|
||||
Subject: [PATCH] Use sf::Shader::Bind() correctly after latest update of the
|
||||
SFML's API.
|
||||
|
||||
---
|
||||
src/System/window.cpp | 6 ++----
|
||||
1 file changed, 2 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/src/System/window.cpp b/src/System/window.cpp
|
||||
index e9a099a..3ffcf65 100644
|
||||
--- a/src/System/window.cpp
|
||||
+++ b/src/System/window.cpp
|
||||
@@ -307,13 +307,11 @@ namespace window {
|
||||
window_.setActive(true);
|
||||
glEnable(GL_TEXTURE_2D);
|
||||
|
||||
- if (shader)
|
||||
- shader->bind();
|
||||
+ sf::Shader::bind(shader);
|
||||
|
||||
window_.draw(toBeDrawn, states);
|
||||
|
||||
- if (shader)
|
||||
- shader->unbind();
|
||||
+ sf::Shader::bind(NULL);
|
||||
|
||||
window_.popGLStates();
|
||||
glPopMatrix();
|
Loading…
Reference in New Issue
Block a user