gnu: librsvg: Update to 2.40.13 [fixes CVE-2015-7558].
* gnu/packages/patches/librsvg-tests.patch: Delete file. * gnu-system.am (dist_patch_DATA): Remove it. * gnu/packages/gnome.scm (librsvg): Update to 2.40.13. [source]: Remove patch.
This commit is contained in:
parent
89b48232f8
commit
8d9bae4ed7
@ -546,7 +546,6 @@ dist_patch_DATA = \
|
||||
gnu/packages/patches/libmad-armv7-thumb-pt2.patch \
|
||||
gnu/packages/patches/libmad-frame-length.patch \
|
||||
gnu/packages/patches/libmad-mips-newgcc.patch \
|
||||
gnu/packages/patches/librsvg-tests.patch \
|
||||
gnu/packages/patches/libtheora-config-guess.patch \
|
||||
gnu/packages/patches/libtool-skip-tests2.patch \
|
||||
gnu/packages/patches/libsndfile-CVE-2014-9496.patch \
|
||||
|
@ -9,7 +9,7 @@
|
||||
;;; Copyright © 2015 Andy Wingo <wingo@igalia.com>
|
||||
;;; Copyright © 2015 David Hashe <david.hashe@dhashe.com>
|
||||
;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
|
||||
;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
|
||||
;;; Copyright © 2015, 2016 Mark H Weaver <mhw@netris.org>
|
||||
;;; Copyright © 2015 David Thompson <davet@gnu.org>
|
||||
;;; Copyright © 2015 Efraim Flashner <efraim@flashner.co.il>
|
||||
;;;
|
||||
@ -841,7 +841,7 @@ dealing with different structured file formats.")
|
||||
(define-public librsvg
|
||||
(package
|
||||
(name "librsvg")
|
||||
(version "2.40.11")
|
||||
(version "2.40.13")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append "mirror://gnome/sources/" name "/"
|
||||
@ -849,9 +849,7 @@ dealing with different structured file formats.")
|
||||
name "-" version ".tar.xz"))
|
||||
(sha256
|
||||
(base32
|
||||
"00ifd9wjjjsw0ybk5j6qs4yyh66jj34hjmggy6dhrgfy8ksw06k1"))
|
||||
(patches
|
||||
(list (search-patch "librsvg-tests.patch")))))
|
||||
"014q7gz6mgfa7pfn0lr13qqv568ad8j1sw9d4vksnpazq0zajvjd"))))
|
||||
(build-system gnu-build-system)
|
||||
(arguments
|
||||
`(#:phases
|
||||
|
@ -1,27 +0,0 @@
|
||||
From e06fc71a57156123e4e50a39957100a651ab632b Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?=E5=AE=8B=E6=96=87=E6=AD=A6?= <iyzsong@gmail.com>
|
||||
Date: Sat, 17 Oct 2015 10:20:33 +0800
|
||||
Subject: [PATCH] tests/styles: Don't duplicate test names.
|
||||
|
||||
---
|
||||
tests/styles.c | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/tests/styles.c b/tests/styles.c
|
||||
index d09b1f2..a938835 100644
|
||||
--- a/tests/styles.c
|
||||
+++ b/tests/styles.c
|
||||
@@ -97,8 +97,8 @@ static const FixtureData fixtures[] =
|
||||
{"/styles/selectors/2 or more selectors (stroke)", "592207", "styles/bug592207.svg", "#target", "stroke", .expected.color = 0xff0000ff},
|
||||
{"/styles/svg-element-style", "615701", "styles/svg-class.svg", "#svg", "fill", .expected.color = 0xff0000ff},
|
||||
{"/styles/presentation attribute in svg element", "620693", "styles/bug620693.svg", "#svg", "stroke", .expected.color = 0xffff0000},
|
||||
- {"/styles/!important", "379629", "styles/bug379629.svg", "#base_shadow", "stroke", .expected.color = 0xffffc0cb /* pink */},
|
||||
- {"/styles/!important", "379629", "styles/bug379629.svg", "#base_shadow", "stroke-width", .expected.length = {POINTS_LENGTH(5.), 'i'}},
|
||||
+ {"/styles/!important/1", "379629", "styles/bug379629.svg", "#base_shadow", "stroke", .expected.color = 0xffffc0cb /* pink */},
|
||||
+ {"/styles/!important/2", "379629", "styles/bug379629.svg", "#base_shadow", "stroke-width", .expected.length = {POINTS_LENGTH(5.), 'i'}},
|
||||
{"/styles/!important/class", "614606", "styles/bug614606.svg", "#path6306", "fill", .expected.color = 0xffff0000 /* red */ },
|
||||
{"/styles/!important/element", "614606", "styles/bug614606.svg", "#path6308", "fill", .expected.color = 0xff000000},
|
||||
{"/styles/!important/#id prior than class", NULL, "styles/important.svg", "#red", "fill", .expected.color = 0xffff0000 },
|
||||
--
|
||||
2.5.0
|
||||
|
Loading…
Reference in New Issue
Block a user