gnu: boost: Patch to avoid -m32 flag on mips.
* gnu/packages/patches/boost-mips-avoid-m32.patch: New file. * gnu-system.am (dist_patch_DATA): Register patch. * gnu/packages/boost.scm (boost): Use it.
This commit is contained in:
parent
31e0ed9592
commit
8d662672fc
@ -392,6 +392,7 @@ dist_patch_DATA = \
|
||||
gnu/packages/patches/binutils-ld-new-dtags.patch \
|
||||
gnu/packages/patches/binutils-loongson-workaround.patch \
|
||||
gnu/packages/patches/bitlbee-configure-doc-fix.patch \
|
||||
gnu/packages/patches/boost-mips-avoid-m32.patch \
|
||||
gnu/packages/patches/calibre-drop-unrar.patch \
|
||||
gnu/packages/patches/calibre-no-updates-dialog.patch \
|
||||
gnu/packages/patches/cdparanoia-fpic.patch \
|
||||
|
@ -42,7 +42,8 @@
|
||||
".tar.bz2"))
|
||||
(sha256
|
||||
(base32
|
||||
"1rfkqxns60171q62cppiyzj8pmsbwp1l8jd7p6crriryqd7j1z7x"))))
|
||||
"1rfkqxns60171q62cppiyzj8pmsbwp1l8jd7p6crriryqd7j1z7x"))
|
||||
(patches (list (search-patch "boost-mips-avoid-m32.patch")))))
|
||||
(build-system gnu-build-system)
|
||||
(inputs `(("zlib" ,zlib)))
|
||||
(native-inputs
|
||||
|
15
gnu/packages/patches/boost-mips-avoid-m32.patch
Normal file
15
gnu/packages/patches/boost-mips-avoid-m32.patch
Normal file
@ -0,0 +1,15 @@
|
||||
The following patch prevents the use of the -m32 flag on mips, where it
|
||||
is not understood by gcc, as well as other non-x86 architectures.
|
||||
|
||||
diff -u -r boost_1_58_0.orig/tools/build/src/tools/gcc.jam boost_1_58_0/tools/build/src/tools/gcc.jam
|
||||
--- boost_1_58_0.orig/tools/build/src/tools/gcc.jam 2015-04-04 19:25:07.000000000 +0200
|
||||
+++ boost_1_58_0/tools/build/src/tools/gcc.jam 2015-07-10 01:08:19.822733823 +0200
|
||||
@@ -451,7 +451,7 @@
|
||||
else
|
||||
{
|
||||
local arch = [ feature.get-values architecture : $(properties) ] ;
|
||||
- if $(arch) != arm
|
||||
+ if $(arch) = x86
|
||||
{
|
||||
if $(model) = 32
|
||||
{
|
Loading…
Reference in New Issue
Block a user