gnu: Add ocaml-graph.
* gnu/packages/ocaml.scm (ocaml-graph): New variable. * gnu/packages/patches/ocaml-graph-honor-source-date-epoch.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it.
This commit is contained in:
parent
88b1533c27
commit
8a238180fd
@ -894,6 +894,7 @@ dist_patch_DATA = \
|
||||
%D%/packages/patches/ocaml-CVE-2015-8869.patch \
|
||||
%D%/packages/patches/ocaml-Add-a-.file-directive.patch \
|
||||
%D%/packages/patches/ocaml-findlib-make-install.patch \
|
||||
%D%/packages/patches/ocaml-graph-honor-source-date-epoch.patch \
|
||||
%D%/packages/patches/omake-fix-non-determinism.patch \
|
||||
%D%/packages/patches/ola-readdir-r.patch \
|
||||
%D%/packages/patches/openscenegraph-ffmpeg3.patch \
|
||||
|
@ -3391,6 +3391,33 @@ unique identifiers (UUIDs) version 3, 5 (named based with MD5, SHA-1 hashing)
|
||||
and 4 (random based) according to RFC 4122.")
|
||||
(license license:isc)))
|
||||
|
||||
(define-public ocaml-graph
|
||||
(package
|
||||
(name "ocaml-graph")
|
||||
(version "1.8.7")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append "http://ocamlgraph.lri.fr/download/"
|
||||
"ocamlgraph-" version ".tar.gz"))
|
||||
(sha256
|
||||
(base32
|
||||
"1845r537swjil2fcj7lgbibc2zybfwqqasrd2s7bncajs83cl1nz"))
|
||||
(patches (search-patches "ocaml-graph-honor-source-date-epoch.patch"))))
|
||||
(build-system ocaml-build-system)
|
||||
(arguments
|
||||
`(#:install-target "install-findlib"
|
||||
#:phases
|
||||
(modify-phases %standard-phases
|
||||
(add-before 'configure 'set-shell
|
||||
(lambda* (#:key inputs #:allow-other-keys)
|
||||
(setenv "CONFIG_SHELL" (string-append (assoc-ref inputs "bash")
|
||||
"/bin/sh")))))))
|
||||
(inputs `(("lablgtk" ,lablgtk)))
|
||||
(home-page "http://ocamlgraph.lri.fr/")
|
||||
(synopsis "Graph library for OCaml")
|
||||
(description "OCamlgraph is a generic graph library for OCaml.")
|
||||
(license license:lgpl2.1)))
|
||||
|
||||
(define-public coq-flocq
|
||||
(package
|
||||
(name "coq-flocq")
|
||||
|
@ -0,0 +1,34 @@
|
||||
From 354ef78aac0b887fae3c10b28eb2b0d83f66bdfe Mon Sep 17 00:00:00 2001
|
||||
From: Julien Lepiller <julien@lepiller.eu>
|
||||
Date: Mon, 2 Jan 2017 17:05:24 +0100
|
||||
Subject: [PATCH] Honor SOURCE_DATE_EPOCH
|
||||
|
||||
---
|
||||
Makefile.in | 7 ++++++-
|
||||
1 file changed, 6 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/Makefile.in b/Makefile.in
|
||||
index a32b4b8..ef4c174 100644
|
||||
--- a/Makefile.in
|
||||
+++ b/Makefile.in
|
||||
@@ -113,11 +113,16 @@ graph.cmx: $(CMI) $(CMX)
|
||||
$(OCAMLOPT) $(INCLUDES) -pack -o $@ $^
|
||||
|
||||
VERSION=1.8.7
|
||||
+ifdef SOURCE_DATE_EPOCH
|
||||
+BUILD_DATE=$(shell date -u -d "@$(SOURCE_DATE_EPOCH)" 2>/dev/null || date -u -r "$(SOURCE_DATE_EPOCH)" 2>/dev/null || date)
|
||||
+else
|
||||
+BUILD_DATE=$(shell date)
|
||||
+endif
|
||||
|
||||
src/version.ml: Makefile
|
||||
rm -f $@
|
||||
echo "let version = \""$(VERSION)"\"" > $@
|
||||
- echo "let date = \""`date`"\"" >> $@
|
||||
+ echo "let date = \""$(BUILD_DATE)"\"" >> $@
|
||||
|
||||
# gtk2 graph editor
|
||||
###################
|
||||
--
|
||||
2.11.0
|
||||
|
Loading…
Reference in New Issue
Block a user