gnu: gnutls: Update to 3.4.0.
* gnu/packages/patches/gnutls-fix-duplicate-manpages.patch: New file. * gnu-system.am (dist_patch_DATA): Add it. * gnu/packages/gnutls.scm (gnutls)[source]: Update to 3.4.0. Add patch. [arguments]: Pass --without-p11-kit to 'configure'. [propagated-inputs]: Use 'nettle' instead of 'nettle-2'. Add 'libidn'.
This commit is contained in:
parent
7ae3e06a32
commit
866f469edd
@ -427,6 +427,7 @@ dist_patch_DATA = \
|
||||
gnu/packages/patches/glibc-ldd-x86_64.patch \
|
||||
gnu/packages/patches/glibc-locales.patch \
|
||||
gnu/packages/patches/gmp-arm-asm-nothumb.patch \
|
||||
gnu/packages/patches/gnutls-fix-duplicate-manpages.patch \
|
||||
gnu/packages/patches/gobject-introspection-absolute-shlib-path.patch \
|
||||
gnu/packages/patches/gobject-introspection-cc.patch \
|
||||
gnu/packages/patches/gobject-introspection-girepository.patch \
|
||||
|
@ -29,6 +29,7 @@
|
||||
#:use-module (gnu packages)
|
||||
#:use-module (gnu packages guile)
|
||||
#:use-module (gnu packages libffi)
|
||||
#:use-module (gnu packages libidn)
|
||||
#:use-module (gnu packages nettle)
|
||||
#:use-module (gnu packages perl)
|
||||
#:use-module (gnu packages pkg-config)
|
||||
@ -103,7 +104,7 @@ living in the same process.")
|
||||
(define-public gnutls
|
||||
(package
|
||||
(name "gnutls")
|
||||
(version "3.3.14")
|
||||
(version "3.4.0")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri
|
||||
@ -114,7 +115,9 @@ living in the same process.")
|
||||
"/gnutls-" version ".tar.xz"))
|
||||
(sha256
|
||||
(base32
|
||||
"0lpcgkp8bb1b7f9z935f7h9c0srd4fc52404x70hk2ddz8q01yhd"))))
|
||||
"0bj7ydvsyvml59b6040wg7694iz37rwnqnv09bic9ddz652588ml"))
|
||||
(patches
|
||||
(list (search-patch "gnutls-fix-duplicate-manpages.patch")))))
|
||||
(build-system gnu-build-system)
|
||||
(arguments
|
||||
'(#:configure-flags
|
||||
@ -130,7 +133,11 @@ living in the same process.")
|
||||
;; store is used, so each program has to provide its own
|
||||
;; fallback, and users have to configure each program
|
||||
;; independently. This seems suboptimal.
|
||||
"--with-default-trust-store-dir=/etc/ssl/certs")))
|
||||
"--with-default-trust-store-dir=/etc/ssl/certs"
|
||||
|
||||
;; FIXME: Temporarily disable p11-kit support since it is not
|
||||
;; working on mips64el.
|
||||
"--without-p11-kit")))
|
||||
(outputs '("out" "debug"))
|
||||
(native-inputs
|
||||
`(("pkg-config" ,pkg-config)
|
||||
@ -141,7 +148,8 @@ living in the same process.")
|
||||
(propagated-inputs
|
||||
;; These are all in the 'Requires.private' field of gnutls.pc.
|
||||
`(("libtasn1" ,libtasn1)
|
||||
("nettle" ,nettle-2)
|
||||
("libidn" ,libidn)
|
||||
("nettle" ,nettle)
|
||||
("zlib" ,zlib)))
|
||||
(home-page "http://www.gnu.org/software/gnutls/")
|
||||
(synopsis "Transport layer security library")
|
||||
|
30
gnu/packages/patches/gnutls-fix-duplicate-manpages.patch
Normal file
30
gnu/packages/patches/gnutls-fix-duplicate-manpages.patch
Normal file
@ -0,0 +1,30 @@
|
||||
Remove duplicate manpage entries from Makefile.
|
||||
|
||||
--- gnutls-3.4.0/doc/manpages/Makefile.am.orig 2015-04-06 04:48:30.000000000 -0400
|
||||
+++ gnutls-3.4.0/doc/manpages/Makefile.am 2015-04-12 16:52:58.029694525 -0400
|
||||
@@ -134,11 +134,8 @@
|
||||
APIMANS += gnutls_certificate_get_peers_subkey_id.3
|
||||
APIMANS += gnutls_certificate_get_trust_list.3
|
||||
APIMANS += gnutls_certificate_get_verify_flags.3
|
||||
-APIMANS += gnutls_certificate_get_verify_flags.3
|
||||
-APIMANS += gnutls_certificate_get_x509_crt.3
|
||||
APIMANS += gnutls_certificate_get_x509_crt.3
|
||||
APIMANS += gnutls_certificate_get_x509_key.3
|
||||
-APIMANS += gnutls_certificate_get_x509_key.3
|
||||
APIMANS += gnutls_certificate_send_x509_rdn_sequence.3
|
||||
APIMANS += gnutls_certificate_server_set_request.3
|
||||
APIMANS += gnutls_certificate_set_dh_params.3
|
||||
--- gnutls-3.4.0/doc/manpages/Makefile.in.orig 2015-04-08 02:08:30.000000000 -0400
|
||||
+++ gnutls-3.4.0/doc/manpages/Makefile.in 2015-04-12 16:53:13.319694530 -0400
|
||||
@@ -1275,11 +1275,8 @@
|
||||
gnutls_certificate_get_peers_subkey_id.3 \
|
||||
gnutls_certificate_get_trust_list.3 \
|
||||
gnutls_certificate_get_verify_flags.3 \
|
||||
- gnutls_certificate_get_verify_flags.3 \
|
||||
- gnutls_certificate_get_x509_crt.3 \
|
||||
gnutls_certificate_get_x509_crt.3 \
|
||||
gnutls_certificate_get_x509_key.3 \
|
||||
- gnutls_certificate_get_x509_key.3 \
|
||||
gnutls_certificate_send_x509_rdn_sequence.3 \
|
||||
gnutls_certificate_server_set_request.3 \
|
||||
gnutls_certificate_set_dh_params.3 \
|
Loading…
Reference in New Issue
Block a user