gnu: docbook: Remove leftovers.
docbook-xsl patches are probably remnants from
1f7d94597f
.
* gnu/packages/docbook.scm: Remove unused import.
* gnu/packages/patches/docbook-xsl-nonrecursive-string-subst.patch: Remove.
* gnu/packages/patches/docbook-xsl-support-old-url.patch: Ditto.
* gnu/local.mk: Unregister it.
* gnu/packages/moreutils.scm (moreutils)[native-inputs]: Drop obsolete
comment.
Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
This commit is contained in:
parent
07114a3f34
commit
7e4ddd2d2e
@ -1124,8 +1124,6 @@ dist_patch_DATA = \
|
||||
%D%/packages/patches/diffutils-fix-signal-processing.patch \
|
||||
%D%/packages/patches/directfb-davinci-glibc-228-compat.patch \
|
||||
%D%/packages/patches/dkimproxy-add-ipv6-support.patch \
|
||||
%D%/packages/patches/docbook-xsl-nonrecursive-string-subst.patch \
|
||||
%D%/packages/patches/docbook-xsl-support-old-url.patch \
|
||||
%D%/packages/patches/doc++-include-directives.patch \
|
||||
%D%/packages/patches/doc++-segfault-fix.patch \
|
||||
%D%/packages/patches/dovecot-opensslv3.patch \
|
||||
|
@ -47,7 +47,6 @@
|
||||
#:use-module (guix git-download)
|
||||
#:use-module (guix build-system copy)
|
||||
#:use-module (guix build-system gnu)
|
||||
#:use-module (guix build-system trivial)
|
||||
#:use-module (guix build-system python))
|
||||
|
||||
;; The fetch-plan, install-plan and phases for docbook-xml tend to vary
|
||||
|
@ -71,7 +71,7 @@
|
||||
;; For building the manual pages.
|
||||
(native-inputs
|
||||
(list docbook-xml-4.4
|
||||
docbook-xsl ;without -next, man pages are corrupted
|
||||
docbook-xsl
|
||||
libxml2
|
||||
libxslt))
|
||||
(home-page "https://joeyh.name/code/moreutils/")
|
||||
|
@ -1,40 +0,0 @@
|
||||
Use a non-recursive replace function when the parser supports it.
|
||||
|
||||
https://bugs.gnu.org/29782
|
||||
https://bugzilla.samba.org/show_bug.cgi?id=9515
|
||||
https://bugzilla.gnome.org/show_bug.cgi?id=736077 (for xsltproc)
|
||||
|
||||
Patch copied from Debian:
|
||||
https://salsa.debian.org/debian/docbook-xsl/-/blob/master/debian/patches/765567_non-recursive_string_subst.patch
|
||||
|
||||
Description: use EXSLT "replace" function when available
|
||||
A recursive implementation of string.subst is problematic,
|
||||
long strings with many matches will cause stack overflows.
|
||||
Author: Peter De Wachter <pdewacht@gmail.com>
|
||||
Bug-Debian: https://bugs.debian.org/750593
|
||||
|
||||
--- a/lib/lib.xsl
|
||||
+++ b/lib/lib.xsl
|
||||
@@ -6,7 +6,11 @@
|
||||
|
||||
This module implements DTD-independent functions
|
||||
|
||||
- ******************************************************************** --><xsl:stylesheet xmlns:xsl="http://www.w3.org/1999/XSL/Transform" version="1.0">
|
||||
+ ******************************************************************** -->
|
||||
+<xsl:stylesheet xmlns:xsl="http://www.w3.org/1999/XSL/Transform"
|
||||
+ xmlns:str="http://exslt.org/strings"
|
||||
+ exclude-result-prefixes="str"
|
||||
+ version="1.0">
|
||||
|
||||
<xsl:template name="dot.count">
|
||||
<!-- Returns the number of "." characters in a string -->
|
||||
@@ -52,6 +56,9 @@
|
||||
<xsl:param name="replacement"/>
|
||||
|
||||
<xsl:choose>
|
||||
+ <xsl:when test="function-available('str:replace')">
|
||||
+ <xsl:value-of select="str:replace($string, string($target), string($replacement))"/>
|
||||
+ </xsl:when>
|
||||
<xsl:when test="contains($string, $target)">
|
||||
<xsl:variable name="rest">
|
||||
<xsl:call-template name="string.subst">
|
@ -1,17 +0,0 @@
|
||||
Docbook 1.79.2 makes very few changes apart from changing the canonical URL
|
||||
to cdn.docbook.org. This patch adds support for the previous URL to avoid
|
||||
breaking packages that still use that.
|
||||
|
||||
Adapted from Debian:
|
||||
https://salsa.debian.org/debian/docbook-xsl/-/blob/master/debian/patches/0005-catalog.xml-Compatibility-with-1.79.1-or-earlier.patch
|
||||
|
||||
--- a/catalog.xml
|
||||
+++ b/catalog.xml
|
||||
@@ -5,4 +5,7 @@
|
||||
<rewriteSystem systemIdStartString="http://cdn.docbook.org/release/xsl/current/" rewritePrefix="./"/>
|
||||
<rewriteURI uriStartString="http://cdn.docbook.org/release/xsl/1.79.2/" rewritePrefix="./"/>
|
||||
<rewriteSystem systemIdStartString="http://cdn.docbook.org/release/xsl/1.79.2/" rewritePrefix="./"/>
|
||||
+ <!-- Also support old URI of v1.79.1 or earlier -->
|
||||
+ <rewriteURI uriStartString="http://docbook.sourceforge.net/release/xsl/current/" rewritePrefix="./"/>
|
||||
+ <rewriteSystem systemIdStartString="http://docbook.sourceforge.net/release/xsl/current/" rewritePrefix="./"/>
|
||||
</catalog>
|
Loading…
Reference in New Issue
Block a user