gnu: Add aws-c-cal.
* gnu/packages/c.scm (aws-c-cal): New variable. * gnu/packages/patches/aws-c-cal-cmake-prefix.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
This commit is contained in:
parent
cc95d03ec7
commit
748e2ec07a
@ -830,6 +830,7 @@ dist_patch_DATA = \
|
||||
%D%/packages/patches/avahi-localstatedir.patch \
|
||||
%D%/packages/patches/avidemux-install-to-lib.patch \
|
||||
%D%/packages/patches/awesome-reproducible-png.patch \
|
||||
%D%/packages/patches/aws-c-cal-cmake-prefix.patch \
|
||||
%D%/packages/patches/aws-c-event-stream-cmake-prefix.patch \
|
||||
%D%/packages/patches/aws-checksums-cmake-prefix.patch \
|
||||
%D%/packages/patches/azr3.patch \
|
||||
|
@ -52,6 +52,7 @@
|
||||
#:use-module (gnu packages autotools)
|
||||
#:use-module (gnu packages gettext)
|
||||
#:use-module (gnu packages pkg-config)
|
||||
#:use-module (gnu packages tls)
|
||||
#:use-module (gnu packages xml))
|
||||
|
||||
(define-public tcc
|
||||
@ -619,3 +620,32 @@ event stream encoding, a binary format for bidirectional client-server
|
||||
communication.")
|
||||
(home-page "https://github.com/awslabs/aws-c-event-stream")
|
||||
(license license:asl2.0)))
|
||||
|
||||
(define-public aws-c-cal
|
||||
(package
|
||||
(name "aws-c-cal")
|
||||
(version "0.4.5")
|
||||
(source (origin
|
||||
(method git-fetch)
|
||||
(uri (git-reference
|
||||
(url (string-append "https://github.com/awslabs/" name))
|
||||
(commit (string-append "v" version))))
|
||||
(file-name (git-file-name name version))
|
||||
(sha256
|
||||
(base32
|
||||
"04acra1mnzw9q7jycs5966akfbgnx96hkrq90nq0dhw8pvarlyv6"))
|
||||
(patches (search-patches "aws-c-cal-cmake-prefix.patch"))))
|
||||
(build-system cmake-build-system)
|
||||
(arguments
|
||||
'(#:configure-flags
|
||||
'("-DBUILD_SHARED_LIBS=ON")))
|
||||
(propagated-inputs
|
||||
`(("aws-c-common" ,aws-c-common)))
|
||||
(inputs
|
||||
`(("openssl" ,openssl)
|
||||
("openssl:static" ,openssl "static")))
|
||||
(synopsis "Amazon Web Services Crypto Abstraction Layer")
|
||||
(description "This library provides a C99 wrapper for hash, HMAC, and ECC
|
||||
cryptographic primitives for the @acronym{AWS,Amazon Web Services} SDK.")
|
||||
(home-page "https://github.com/awslabs/aws-c-cal")
|
||||
(license license:asl2.0)))
|
||||
|
13
gnu/packages/patches/aws-c-cal-cmake-prefix.patch
Normal file
13
gnu/packages/patches/aws-c-cal-cmake-prefix.patch
Normal file
@ -0,0 +1,13 @@
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -10,6 +10,10 @@ endif()
|
||||
|
||||
option(BYO_CRYPTO "Set this if you want to provide your own cryptography implementation. This will cause the defaults to not be compiled." OFF)
|
||||
|
||||
+if (DEFINED ENV{CMAKE_PREFIX_PATH})
|
||||
+ set(CMAKE_PREFIX_PATH $ENV{CMAKE_PREFIX_PATH})
|
||||
+endif()
|
||||
+
|
||||
if (DEFINED CMAKE_PREFIX_PATH)
|
||||
file(TO_CMAKE_PATH "${CMAKE_PREFIX_PATH}" CMAKE_PREFIX_PATH)
|
||||
endif()
|
Loading…
Reference in New Issue
Block a user