gnu: zig: Remove unneeded patch.
* gnu/packages/zig.scm (zig)[source]: Remove one patch. * gnu/packages/patches/zig-disable-libc-note-test.patch: Remove file. * gnu/local.mk (dist_patch_DATA): Remove it.
This commit is contained in:
parent
58bc976b5b
commit
738da660ff
@ -1982,7 +1982,6 @@ dist_patch_DATA = \
|
||||
%D%/packages/patches/ytfzf-updates.patch \
|
||||
%D%/packages/patches/ytnef-CVE-2021-3403.patch \
|
||||
%D%/packages/patches/ytnef-CVE-2021-3404.patch \
|
||||
%D%/packages/patches/zig-disable-libc-note-test.patch \
|
||||
%D%/packages/patches/zig-use-system-paths.patch
|
||||
|
||||
MISC_DISTRO_FILES = \
|
||||
|
@ -1,31 +0,0 @@
|
||||
This test fails with "error.CompilationIncorrectlySucceeded".
|
||||
|
||||
diff --git a/test/compile_errors.zig b/test/compile_errors.zig
|
||||
index b1eaa0302..621f9db0a 100644
|
||||
--- a/test/compile_errors.zig
|
||||
+++ b/test/compile_errors.zig
|
||||
@@ -2943,15 +2943,15 @@ pub fn addCases(ctx: *TestContext) !void {
|
||||
"tmp.zig:3:5: error: dependency on libc must be explicitly specified in the build command",
|
||||
});
|
||||
|
||||
- ctx.testErrStage1("libc headers note",
|
||||
- \\const c = @cImport(@cInclude("stdio.h"));
|
||||
- \\export fn entry() void {
|
||||
- \\ _ = c.printf("hello, world!\n");
|
||||
- \\}
|
||||
- , &[_][]const u8{
|
||||
- "tmp.zig:1:11: error: C import failed",
|
||||
- "tmp.zig:1:11: note: libc headers not available; compilation does not link against libc",
|
||||
- });
|
||||
+ // ctx.testErrStage1("libc headers note",
|
||||
+ // \\const c = @cImport(@cInclude("stdio.h"));
|
||||
+ // \\export fn entry() void {
|
||||
+ // \\ _ = c.printf("hello, world!\n");
|
||||
+ // \\}
|
||||
+ // , &[_][]const u8{
|
||||
+ // "tmp.zig:1:11: error: C import failed",
|
||||
+ // "tmp.zig:1:11: note: libc headers not available; compilation does not link against libc",
|
||||
+ // });
|
||||
}
|
||||
|
||||
ctx.testErrStage1("comptime vector overflow shows the index",
|
@ -39,10 +39,7 @@
|
||||
(file-name (git-file-name name version))
|
||||
(sha256
|
||||
(base32 "0nfvgg23sw50ksy0z0ml6lkdsvmd0278mq29m23dbb2jsirkhry7"))
|
||||
(patches
|
||||
(search-patches
|
||||
"zig-disable-libc-note-test.patch"
|
||||
"zig-use-system-paths.patch"))))
|
||||
(patches (search-patches "zig-use-system-paths.patch"))))
|
||||
(build-system cmake-build-system)
|
||||
(inputs
|
||||
(list clang-13 ; Clang propagates llvm.
|
||||
|
Loading…
Reference in New Issue
Block a user