gnu: python-packaging: Update to 20.4.
* gnu/packages/python-xyz.scm (python-packaging): Update to 20.4. [source]: Remove patch that has been merged upstream. * gnu/packages/patches/python-packaging-test-arch.patch: Remove file. * gnu/local.mk (dist_patch_DATA): Apply removal. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
This commit is contained in:
parent
265e1858fb
commit
71b15b4874
@ -1527,7 +1527,6 @@ dist_patch_DATA = \
|
|||||||
%D%/packages/patches/python-mox3-python3.6-compat.patch \
|
%D%/packages/patches/python-mox3-python3.6-compat.patch \
|
||||||
%D%/packages/patches/python-testtools.patch \
|
%D%/packages/patches/python-testtools.patch \
|
||||||
%D%/packages/patches/python-onnx-use-system-googletest.patch \
|
%D%/packages/patches/python-onnx-use-system-googletest.patch \
|
||||||
%D%/packages/patches/python-packaging-test-arch.patch \
|
|
||||||
%D%/packages/patches/python2-parameterized-docstring-test.patch \
|
%D%/packages/patches/python2-parameterized-docstring-test.patch \
|
||||||
%D%/packages/patches/python-paste-remove-timing-test.patch \
|
%D%/packages/patches/python-paste-remove-timing-test.patch \
|
||||||
%D%/packages/patches/python-pycrypto-CVE-2013-7459.patch \
|
%D%/packages/patches/python-pycrypto-CVE-2013-7459.patch \
|
||||||
|
@ -1,65 +0,0 @@
|
|||||||
Fix tests that are "hard coded" to expect x86_64 output by mocking the platform interface.
|
|
||||||
|
|
||||||
Submitted upstream:
|
|
||||||
https://github.com/pypa/packaging/pull/176
|
|
||||||
|
|
||||||
diff --git a/tests/test_tags.py b/tests/test_tags.py
|
|
||||||
index 1eacf68..0a3f1b4 100644
|
|
||||||
--- a/tests/test_tags.py
|
|
||||||
+++ b/tests/test_tags.py
|
|
||||||
@@ -435,37 +435,43 @@ class TestManylinuxPlatform:
|
|
||||||
linux_platform = list(tags._linux_platforms(is_32bit=False))
|
|
||||||
assert linux_platform == ["linux_x86_64"]
|
|
||||||
|
|
||||||
- def test_linux_platforms_manylinux1(self, monkeypatch):
|
|
||||||
+ def test_linux_platforms_manylinux1(self, is_x86, monkeypatch):
|
|
||||||
monkeypatch.setattr(
|
|
||||||
tags, "_is_manylinux_compatible", lambda name, _: name == "manylinux1"
|
|
||||||
)
|
|
||||||
- if platform.system() != "Linux":
|
|
||||||
+ if platform.system() != "Linux" or not is_x86:
|
|
||||||
monkeypatch.setattr(distutils.util, "get_platform", lambda: "linux_x86_64")
|
|
||||||
+ monkeypatch.setattr(platform, "machine", lambda: "x86_64")
|
|
||||||
platforms = list(tags._linux_platforms(is_32bit=False))
|
|
||||||
- assert platforms == ["manylinux1_x86_64", "linux_x86_64"]
|
|
||||||
+ arch = platform.machine()
|
|
||||||
+ assert platforms == ["manylinux1_" + arch, "linux_" + arch]
|
|
||||||
|
|
||||||
- def test_linux_platforms_manylinux2010(self, monkeypatch):
|
|
||||||
+ def test_linux_platforms_manylinux2010(self, is_x86, monkeypatch):
|
|
||||||
monkeypatch.setattr(
|
|
||||||
tags, "_is_manylinux_compatible", lambda name, _: name == "manylinux2010"
|
|
||||||
)
|
|
||||||
- if platform.system() != "Linux":
|
|
||||||
+ if platform.system() != "Linux" or not is_x86:
|
|
||||||
monkeypatch.setattr(distutils.util, "get_platform", lambda: "linux_x86_64")
|
|
||||||
+ monkeypatch.setattr(platform, "machine", lambda: "x86_64")
|
|
||||||
platforms = list(tags._linux_platforms(is_32bit=False))
|
|
||||||
- expected = ["manylinux2010_x86_64", "manylinux1_x86_64", "linux_x86_64"]
|
|
||||||
+ arch = platform.machine()
|
|
||||||
+ expected = ["manylinux2010_" + arch, "manylinux1_" + arch, "linux_" + arch]
|
|
||||||
assert platforms == expected
|
|
||||||
|
|
||||||
- def test_linux_platforms_manylinux2014(self, monkeypatch):
|
|
||||||
+ def test_linux_platforms_manylinux2014(self, is_x86, monkeypatch):
|
|
||||||
monkeypatch.setattr(
|
|
||||||
tags, "_is_manylinux_compatible", lambda name, _: name == "manylinux2014"
|
|
||||||
)
|
|
||||||
- if platform.system() != "Linux":
|
|
||||||
+ if platform.system() != "Linux" or not is_x86:
|
|
||||||
monkeypatch.setattr(distutils.util, "get_platform", lambda: "linux_x86_64")
|
|
||||||
+ monkeypatch.setattr(platform, "machine", lambda: "x86_64")
|
|
||||||
platforms = list(tags._linux_platforms(is_32bit=False))
|
|
||||||
+ arch = platform.machine()
|
|
||||||
expected = [
|
|
||||||
- "manylinux2014_x86_64",
|
|
||||||
- "manylinux2010_x86_64",
|
|
||||||
- "manylinux1_x86_64",
|
|
||||||
- "linux_x86_64",
|
|
||||||
+ "manylinux2014_" + arch,
|
|
||||||
+ "manylinux2010_" + arch,
|
|
||||||
+ "manylinux1_" + arch,
|
|
||||||
+ "linux_" + arch,
|
|
||||||
]
|
|
||||||
assert platforms == expected
|
|
||||||
|
|
@ -15974,17 +15974,14 @@ several utilities, as well as an API for building localization tools.")
|
|||||||
(define-public python-packaging
|
(define-public python-packaging
|
||||||
(package
|
(package
|
||||||
(name "python-packaging")
|
(name "python-packaging")
|
||||||
(version "20.0")
|
(version "20.4")
|
||||||
(source
|
(source
|
||||||
(origin
|
(origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
(uri (pypi-uri "packaging" version))
|
(uri (pypi-uri "packaging" version))
|
||||||
;; XXX: The URL in the patch file is wrong, it should be
|
|
||||||
;; <https://github.com/pypa/packaging/pull/256>.
|
|
||||||
(patches (search-patches "python-packaging-test-arch.patch"))
|
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"1y2ip3a4ykkpgnwgn85j6hkspcl0cg3mzms97f40mk57vwqq67gy"))))
|
"1y3rc1ams1i25calk6b9jf1gl85ix5a23a146swjvhdr8x7zfms3"))))
|
||||||
(build-system python-build-system)
|
(build-system python-build-system)
|
||||||
(arguments
|
(arguments
|
||||||
`(#:phases (modify-phases %standard-phases
|
`(#:phases (modify-phases %standard-phases
|
||||||
|
Loading…
Reference in New Issue
Block a user