gnu: binutils: Update to 2.31.1.
* gnu/packages/base.scm (binutils): Update to 2.31.1. (binutils/fixed): Remove variable * gnu/packages/linux.scm (make-linux-libre): Remove AArch64 workaround. * gnu/packages/patches/binutils-aarch64-symbol-relocation.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
This commit is contained in:
parent
45719c1dfb
commit
6c4709889c
@ -585,7 +585,6 @@ dist_patch_DATA = \
|
|||||||
%D%/packages/patches/bazaar-CVE-2017-14176.patch \
|
%D%/packages/patches/bazaar-CVE-2017-14176.patch \
|
||||||
%D%/packages/patches/beignet-correct-file-names.patch \
|
%D%/packages/patches/beignet-correct-file-names.patch \
|
||||||
%D%/packages/patches/bind-CVE-2018-5738.patch \
|
%D%/packages/patches/bind-CVE-2018-5738.patch \
|
||||||
%D%/packages/patches/binutils-aarch64-symbol-relocation.patch \
|
|
||||||
%D%/packages/patches/binutils-loongson-workaround.patch \
|
%D%/packages/patches/binutils-loongson-workaround.patch \
|
||||||
%D%/packages/patches/blast+-fix-makefile.patch \
|
%D%/packages/patches/blast+-fix-makefile.patch \
|
||||||
%D%/packages/patches/boost-fix-icu-build.patch \
|
%D%/packages/patches/boost-fix-icu-build.patch \
|
||||||
|
@ -435,14 +435,14 @@ change. GNU make offers many powerful extensions over the standard utility.")
|
|||||||
(define-public binutils
|
(define-public binutils
|
||||||
(package
|
(package
|
||||||
(name "binutils")
|
(name "binutils")
|
||||||
(version "2.30")
|
(version "2.31.1")
|
||||||
(source (origin
|
(source (origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
(uri (string-append "mirror://gnu/binutils/binutils-"
|
(uri (string-append "mirror://gnu/binutils/binutils-"
|
||||||
version ".tar.bz2"))
|
version ".tar.bz2"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"028cklfqaab24glva1ks2aqa1zxa6w6xmc8q34zs1sb7h22dxspg"))
|
"1l34hn1zkmhr1wcrgf0d4z7r3najxnw3cx2y2fk7v55zjlk3ik7z"))
|
||||||
(patches (search-patches "binutils-loongson-workaround.patch"))))
|
(patches (search-patches "binutils-loongson-workaround.patch"))))
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
|
|
||||||
@ -480,17 +480,6 @@ included.")
|
|||||||
(license gpl3+)
|
(license gpl3+)
|
||||||
(home-page "https://www.gnu.org/software/binutils/")))
|
(home-page "https://www.gnu.org/software/binutils/")))
|
||||||
|
|
||||||
(define-public binutils/fixed
|
|
||||||
;; TODO: Incorporate this in binutils during the next rebuild cycle.
|
|
||||||
(hidden-package
|
|
||||||
(package
|
|
||||||
(inherit binutils)
|
|
||||||
(source (origin
|
|
||||||
(inherit (package-source binutils))
|
|
||||||
(patches (append (origin-patches (package-source binutils))
|
|
||||||
(search-patches
|
|
||||||
"binutils-aarch64-symbol-relocation.patch"))))))))
|
|
||||||
|
|
||||||
(define* (make-ld-wrapper name #:key
|
(define* (make-ld-wrapper name #:key
|
||||||
(target (const #f))
|
(target (const #f))
|
||||||
binutils
|
binutils
|
||||||
|
@ -296,12 +296,6 @@ for ARCH and optionally VARIANT, or #f if there is no such configuration."
|
|||||||
(or (%current-target-system) (%current-system)))
|
(or (%current-target-system) (%current-system)))
|
||||||
((or "x86_64" "i386")
|
((or "x86_64" "i386")
|
||||||
`(("gcc" ,gcc-7)))
|
`(("gcc" ,gcc-7)))
|
||||||
("arm64"
|
|
||||||
;; Work around a binutils 2.30 bug where some kernel symbols would
|
|
||||||
;; be incorrectly marked as relocatable:
|
|
||||||
;; <https://sourceware.org/bugzilla/show_bug.cgi?id=22764>.
|
|
||||||
`(("ld-wrapper" ,(make-ld-wrapper "ld-wrapper"
|
|
||||||
#:binutils binutils/fixed))))
|
|
||||||
(_
|
(_
|
||||||
'()))
|
'()))
|
||||||
,@(match (and configuration-file
|
,@(match (and configuration-file
|
||||||
|
@ -1,36 +0,0 @@
|
|||||||
Fix a regression in Binutils 2.30 where some symbols are incorrectly assumed
|
|
||||||
to be addresses:
|
|
||||||
|
|
||||||
https://sourceware.org/bugzilla/show_bug.cgi?id=22764
|
|
||||||
|
|
||||||
Patch taken from upstream (with ChangeLog entries and tests omitted):
|
|
||||||
|
|
||||||
https://sourceware.org/git/gitweb.cgi?p=binutils-gdb.git;a=commitdiff;h=279b2f94168ee91e02ccd070d27c983fc001fe12
|
|
||||||
|
|
||||||
diff --git a/bfd/elfnn-aarch64.c b/bfd/elfnn-aarch64.c
|
|
||||||
index af448f9..2737773 100644
|
|
||||||
--- a/bfd/elfnn-aarch64.c
|
|
||||||
+++ b/bfd/elfnn-aarch64.c
|
|
||||||
@@ -7189,10 +7189,19 @@ elfNN_aarch64_check_relocs (bfd *abfd, struct bfd_link_info *info,
|
|
||||||
#if ARCH_SIZE == 64
|
|
||||||
case BFD_RELOC_AARCH64_32:
|
|
||||||
#endif
|
|
||||||
- if (bfd_link_pic (info)
|
|
||||||
- && (sec->flags & SEC_ALLOC) != 0
|
|
||||||
- && (sec->flags & SEC_READONLY) != 0)
|
|
||||||
+ if (bfd_link_pic (info) && (sec->flags & SEC_ALLOC) != 0)
|
|
||||||
{
|
|
||||||
+ if (h != NULL
|
|
||||||
+ /* This is an absolute symbol. It represents a value instead
|
|
||||||
+ of an address. */
|
|
||||||
+ && ((h->root.type == bfd_link_hash_defined
|
|
||||||
+ && bfd_is_abs_section (h->root.u.def.section))
|
|
||||||
+ /* This is an undefined symbol. */
|
|
||||||
+ || h->root.type == bfd_link_hash_undefined))
|
|
||||||
+ break;
|
|
||||||
+
|
|
||||||
+ /* For local symbols, defined global symbols in a non-ABS section,
|
|
||||||
+ it is assumed that the value is an address. */
|
|
||||||
int howto_index = bfd_r_type - BFD_RELOC_AARCH64_RELOC_START;
|
|
||||||
_bfd_error_handler
|
|
||||||
/* xgettext:c-format */
|
|
Loading…
Reference in New Issue
Block a user