gnu: python-rarfile: Update to 2.8.
* gnu/packages/python.scm (python-rarfile, python2-rarfile): Update to 2.8. [source]: Remove obsolete patch. * gnu/packages/patches/python-rarfile-fix-tests.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
This commit is contained in:
parent
8c4964dd51
commit
6782444764
@ -827,7 +827,6 @@ dist_patch_DATA = \
|
||||
%D%/packages/patches/python-file-double-encoding-bug.patch \
|
||||
%D%/packages/patches/python-fix-tests.patch \
|
||||
%D%/packages/patches/python-parse-too-many-fields.patch \
|
||||
%D%/packages/patches/python-rarfile-fix-tests.patch \
|
||||
%D%/packages/patches/python2-rdflib-drop-sparqlwrapper.patch \
|
||||
%D%/packages/patches/python-statsmodels-fix-tests.patch \
|
||||
%D%/packages/patches/python-configobj-setuptools.patch \
|
||||
|
@ -1,14 +0,0 @@
|
||||
There is no test.sh, but there are test1.sh and test2.sh.
|
||||
|
||||
diff --git a/test/Makefile b/test/Makefile
|
||||
index 027bc5f..5383db3 100644
|
||||
--- a/test/Makefile
|
||||
+++ b/test/Makefile
|
||||
@@ -1,5 +1,6 @@
|
||||
test:
|
||||
- ./test.sh
|
||||
+ ./test1.sh
|
||||
+ ./test2.sh
|
||||
|
||||
clean:
|
||||
rm -rf __pycache__
|
@ -9816,15 +9816,13 @@ module, adding support for Unicode strings.")
|
||||
(define-public python-rarfile
|
||||
(package
|
||||
(name "python-rarfile")
|
||||
(version "2.7")
|
||||
(version "2.8")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (pypi-uri "rarfile" version))
|
||||
(sha256
|
||||
(base32
|
||||
"0d8n1dlpiz7av8dmbp0vclrwl9cnxizr4f2c9xvj1h5nvn480527"))
|
||||
;; https://github.com/markokr/rarfile/pull/17/
|
||||
(patches (search-patches "python-rarfile-fix-tests.patch"))))
|
||||
"0qfad483kcbga0bn4qmcz953xjk16r52fahiy46zzn56v80y89ra"))))
|
||||
(build-system python-build-system)
|
||||
(arguments
|
||||
'(#:phases
|
||||
|
Loading…
Reference in New Issue
Block a user