gnu: gobject-introspection: Update to 1.42.0 and add new patch.
* gnu/packages/glib.scm (gobject-introspection): Update to version 1.42.0. Add patch 'gobject-introspection-absolute-shlib-path.patch' provided by Luca Bruno <lucabru@src.gnome.org> for Nix.
This commit is contained in:
parent
a415f036e8
commit
66717243d0
@ -197,17 +197,18 @@ dynamic loading, and an object system.")
|
||||
(define gobject-introspection
|
||||
(package
|
||||
(name "gobject-introspection")
|
||||
(version "1.38.0")
|
||||
(version "1.42.0")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append "http://ftp.gnome.org/pub/GNOME/sources/"
|
||||
"gobject-introspection/"
|
||||
(substring version 0 (string-rindex version #\.))
|
||||
"/gobject-introspection-"
|
||||
version ".tar.xz"))
|
||||
"gobject-introspection/" (version-major+minor version)
|
||||
"/gobject-introspection-" version ".tar.xz"))
|
||||
(sha256
|
||||
(base32 "0wvxyvgajmms2bb6k3pf1rdpnd79xdxamykzvxzmcyn1ag9yax9m"))
|
||||
(patches (list (search-patch "gobject-introspection-cc.patch")))))
|
||||
(base32 "1xwm7wmr9r9wp6xljb3bckx3a4siybavaq39w46ly7gpskxfv8iv"))
|
||||
(patches (list
|
||||
(search-patch "gobject-introspection-cc.patch")
|
||||
(search-patch
|
||||
"gobject-introspection-absolute-shlib-path.patch")))))
|
||||
(build-system gnu-build-system)
|
||||
(inputs
|
||||
`(("bison" ,bison)
|
||||
@ -223,7 +224,10 @@ dynamic loading, and an object system.")
|
||||
;; gobject-introspection.
|
||||
("libffi" ,libffi)))
|
||||
(arguments
|
||||
`(#:phases
|
||||
`(;; The patch 'gobject-introspection-absolute-shlib-path.patch' causes
|
||||
;; some tests to fail.
|
||||
#:tests? #f
|
||||
#:phases
|
||||
(alist-cons-before
|
||||
'configure 'patch-paths
|
||||
(lambda _
|
||||
|
@ -0,0 +1,30 @@
|
||||
# Names of libraries included in typelib files are opened by dlopen. Here we
|
||||
# add the full path.
|
||||
#
|
||||
# This patch was provided by Luca Bruno <lucabru@src.gnome.org> for
|
||||
# 'gobject-introspection' 1.40.0 in Nix.
|
||||
--- ./giscanner/utils.py.orig 2014-08-14 22:05:05.055334080 +0200
|
||||
+++ ./giscanner/utils.py 2014-08-14 22:05:24.687497334 +0200
|
||||
@@ -110,17 +110,11 @@
|
||||
if dlname is None:
|
||||
return None
|
||||
|
||||
- # Darwin uses absolute paths where possible; since the libtool files never
|
||||
- # contain absolute paths, use the libdir field
|
||||
- if platform.system() == 'Darwin':
|
||||
- dlbasename = os.path.basename(dlname)
|
||||
- libdir = _extract_libdir_field(la_file)
|
||||
- if libdir is None:
|
||||
- return dlbasename
|
||||
- return libdir + '/' + dlbasename
|
||||
- # From the comments in extract_libtool(), older libtools had
|
||||
- # a path rather than the raw dlname
|
||||
- return os.path.basename(dlname)
|
||||
+ dlbasename = os.path.basename(dlname)
|
||||
+ libdir = _extract_libdir_field(la_file)
|
||||
+ if libdir is None:
|
||||
+ return dlbasename
|
||||
+ return libdir + '/' + dlbasename
|
||||
|
||||
|
||||
def extract_libtool(la_file):
|
Loading…
Reference in New Issue
Block a user