gnu: certbot, python-acme: Update to 0.18.2.
* gnu/packages/tls.scm (certbot, python-acme): Update to 0.18.2. * gnu/packages/patches/python-acme-dont-use-openssl-rand.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
This commit is contained in:
parent
edd38aa898
commit
66660960ba
@ -553,7 +553,6 @@ dist_patch_DATA = \
|
|||||||
%D%/packages/patches/ceph-disable-unittest-throttle.patch \
|
%D%/packages/patches/ceph-disable-unittest-throttle.patch \
|
||||||
%D%/packages/patches/ceph-skip-collect-sys-info-test.patch \
|
%D%/packages/patches/ceph-skip-collect-sys-info-test.patch \
|
||||||
%D%/packages/patches/ceph-skip-unittest_blockdev.patch \
|
%D%/packages/patches/ceph-skip-unittest_blockdev.patch \
|
||||||
%D%/packages/patches/python-acme-dont-use-openssl-rand.patch \
|
|
||||||
%D%/packages/patches/chicken-CVE-2017-6949.patch \
|
%D%/packages/patches/chicken-CVE-2017-6949.patch \
|
||||||
%D%/packages/patches/chicken-CVE-2017-11343.patch \
|
%D%/packages/patches/chicken-CVE-2017-11343.patch \
|
||||||
%D%/packages/patches/chmlib-inttypes.patch \
|
%D%/packages/patches/chmlib-inttypes.patch \
|
||||||
|
@ -1,28 +0,0 @@
|
|||||||
Fix build with PyOpenSSL > 17.2.0.
|
|
||||||
|
|
||||||
See <https://github.com/certbot/certbot/issues/5111>.
|
|
||||||
|
|
||||||
Patch copied from upstream source repository:
|
|
||||||
https://github.com/certbot/certbot/commit/f6be07da74c664b57ac8c053585f919c79f9af44
|
|
||||||
|
|
||||||
diff --git a/acme/crypto_util.py b/acme/crypto_util.py
|
|
||||||
index de15284c03..b8fba03488 100644
|
|
||||||
--- a/acme/crypto_util.py
|
|
||||||
+++ b/acme/crypto_util.py
|
|
||||||
@@ -2,6 +2,7 @@
|
|
||||||
import binascii
|
|
||||||
import contextlib
|
|
||||||
import logging
|
|
||||||
+import os
|
|
||||||
import re
|
|
||||||
import socket
|
|
||||||
import sys
|
|
||||||
@@ -243,7 +244,7 @@ def gen_ss_cert(key, domains, not_before=None,
|
|
||||||
"""
|
|
||||||
assert domains, "Must provide one or more hostnames for the cert."
|
|
||||||
cert = OpenSSL.crypto.X509()
|
|
||||||
- cert.set_serial_number(int(binascii.hexlify(OpenSSL.rand.bytes(16)), 16))
|
|
||||||
+ cert.set_serial_number(int(binascii.hexlify(os.urandom(16)), 16))
|
|
||||||
cert.set_version(2)
|
|
||||||
|
|
||||||
extensions = [
|
|
@ -486,14 +486,13 @@ netcat implementation that supports TLS.")
|
|||||||
(package
|
(package
|
||||||
(name "python-acme")
|
(name "python-acme")
|
||||||
;; Remember to update the hash of certbot when updating python-acme.
|
;; Remember to update the hash of certbot when updating python-acme.
|
||||||
(version "0.18.1")
|
(version "0.18.2")
|
||||||
(source (origin
|
(source (origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
(uri (pypi-uri "acme" version))
|
(uri (pypi-uri "acme" version))
|
||||||
(patches (search-patches "python-acme-dont-use-openssl-rand.patch"))
|
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"0ry6vhfkhds28sg232hngwfnkqihsxv9r8w92c6nz45r7w56qk0y"))))
|
"1xiy8m7501g5l9kpdmyvyz72nfnl72l19qkrf76fyvby7adzm3ki"))))
|
||||||
(build-system python-build-system)
|
(build-system python-build-system)
|
||||||
(arguments
|
(arguments
|
||||||
`(#:phases
|
`(#:phases
|
||||||
@ -541,7 +540,7 @@ netcat implementation that supports TLS.")
|
|||||||
(uri (pypi-uri name version))
|
(uri (pypi-uri name version))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"0k3bqfkjxyg0qivs4a6iz6gyqx8li4hgn8m268r72lxgq46ay2mf"))))
|
"16lw4n7kwnkvh9sz2f97c7ad1wwp33mg5fc332lpy5n17zpfc8h1"))))
|
||||||
(build-system python-build-system)
|
(build-system python-build-system)
|
||||||
(arguments
|
(arguments
|
||||||
`(,@(substitute-keyword-arguments (package-arguments python-acme)
|
`(,@(substitute-keyword-arguments (package-arguments python-acme)
|
||||||
|
Loading…
Reference in New Issue
Block a user