gnu: python-pygit2: Update to 0.26.4.
* gnu/packages/python.scm (python-pygit2, python2-pygit2): Update to 0.26.4. [source]: Remove 'python-pygit2-disable-network-tests.patch'. * gnu/packages/patches/python-pygit2-disable-network-tests.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
This commit is contained in:
parent
a30cbd5dfb
commit
6635a3cc7f
@ -1087,7 +1087,6 @@ dist_patch_DATA = \
|
||||
%D%/packages/patches/python-mox3-python3.6-compat.patch \
|
||||
%D%/packages/patches/python-paste-remove-website-test.patch \
|
||||
%D%/packages/patches/python-paste-remove-timing-test.patch \
|
||||
%D%/packages/patches/python-pygit2-disable-network-tests.patch \
|
||||
%D%/packages/patches/python-pycrypto-CVE-2013-7459.patch \
|
||||
%D%/packages/patches/python2-pygobject-2-gi-info-type-error-domain.patch \
|
||||
%D%/packages/patches/python-pygpgme-fix-pinentry-tests.patch \
|
||||
|
@ -1,43 +0,0 @@
|
||||
Disable tests trying to look up remote servers.
|
||||
|
||||
diff --git a/test/test_credentials.py b/test/test_credentials.py
|
||||
--- a/test/test_credentials.py
|
||||
+++ b/test/test_credentials.py
|
||||
@@ -68,6 +68,7 @@ class CredentialCreateTest(utils.NoRepoTestCase):
|
||||
self.assertEqual((username, None, None, None), cred.credential_tuple)
|
||||
|
||||
|
||||
+@unittest.skipIf(True, "network tests are not supported in Guix")
|
||||
class CredentialCallback(utils.RepoTestCase):
|
||||
def test_callback(self):
|
||||
class MyCallbacks(pygit2.RemoteCallbacks):
|
||||
@@ -92,6 +93,7 @@ class CredentialCallback(utils.RepoTestCase):
|
||||
remote = self.repo.create_remote("github", url)
|
||||
self.assertRaises(TypeError, lambda: remote.fetch(callbacks=MyCallbacks()))
|
||||
|
||||
+@unittest.skipIf(True, "network tests are not supported in Guix")
|
||||
class CallableCredentialTest(utils.RepoTestCase):
|
||||
|
||||
def test_user_pass(self):
|
||||
diff --git a/test/test_repository.py b/test/test_repository.py
|
||||
--- a/test/test_repository.py
|
||||
+++ b/test/test_repository.py
|
||||
@@ -573,6 +573,7 @@ class CloneRepositoryTest(utils.NoRepoTestCase):
|
||||
self.assertTrue('refs/remotes/custom_remote/master' in repo.listall_references())
|
||||
self.assertIsNotNone(repo.remotes["custom_remote"])
|
||||
|
||||
+ @unittest.skipIf(True, "network tests are not supported in Guix")
|
||||
def test_clone_with_credentials(self):
|
||||
repo = clone_repository(
|
||||
"https://bitbucket.org/libgit2/testgitrepository.git",
|
||||
diff --git a/test/test_submodule.py b/test/test_submodule.py
|
||||
--- a/test/test_submodule.py
|
||||
+++ b/test/test_submodule.py
|
||||
@@ -42,6 +42,7 @@ SUBM_PATH = 'submodule'
|
||||
SUBM_URL = 'https://github.com/libgit2/pygit2'
|
||||
SUBM_HEAD_SHA = '819cbff552e46ac4b8d10925cc422a30aa04e78e'
|
||||
|
||||
+@unittest.skipIf(True, "network tests are not supported in Guix")
|
||||
class SubmoduleTest(utils.SubmoduleRepoTestCase):
|
||||
|
||||
def test_lookup_submodule(self):
|
@ -3265,16 +3265,14 @@ association studies (GWAS) on extremely large data sets.")
|
||||
(define-public python-pygit2
|
||||
(package
|
||||
(name "python-pygit2")
|
||||
(version "0.26.0")
|
||||
(version "0.26.4")
|
||||
(source
|
||||
(origin
|
||||
(method url-fetch)
|
||||
(uri (pypi-uri "pygit2" version))
|
||||
(sha256
|
||||
(base32
|
||||
"1cbc488ra3kg7r3qky17ms0szi3cda2d96qfkv1l9djsy9hnvw57"))
|
||||
(patches
|
||||
(search-patches "python-pygit2-disable-network-tests.patch"))))
|
||||
"145k3fsd21274swia7mcc7n3kzlbd47xmg55mxsjdb5d9b7fr858"))))
|
||||
(build-system python-build-system)
|
||||
(propagated-inputs
|
||||
`(("python-six" ,python-six)
|
||||
|
Loading…
Reference in New Issue
Block a user