gnu: libusb-for-axoloti: Adjust patch.
* gnu/packages/patches/libusb-for-axoloti.patch: Adjust patch for use with current version of libusb.
This commit is contained in:
parent
8efe2a22ea
commit
6623bd826b
@ -1,8 +1,8 @@
|
||||
diff -rpu4 libusb-1.0.22.orig/libusb/descriptor.c libusb-1.0.22/libusb/descriptor.c
|
||||
--- libusb-1.0.22.orig/libusb/descriptor.c 2018-03-17 08:23:37.000000000 +0100
|
||||
+++ libusb-1.0.22/libusb/descriptor.c 2018-03-29 10:36:09.968429473 +0200
|
||||
@@ -1173,9 +1173,9 @@ int API_EXPORTED libusb_get_string_descr
|
||||
if (tbuf[1] != LIBUSB_DT_STRING)
|
||||
diff --git a/libusb/descriptor.c b/libusb/descriptor.c
|
||||
index 74d6de5..0b0e314 100644
|
||||
--- a/libusb/descriptor.c
|
||||
+++ b/libusb/descriptor.c
|
||||
@@ -1174,7 +1174,7 @@ int API_EXPORTED libusb_get_string_descriptor_ascii(libusb_device_handle *dev_ha
|
||||
return LIBUSB_ERROR_IO;
|
||||
|
||||
if (tbuf[0] > r)
|
||||
@ -11,4 +11,6 @@ diff -rpu4 libusb-1.0.22.orig/libusb/descriptor.c libusb-1.0.22/libusb/descripto
|
||||
|
||||
di = 0;
|
||||
for (si = 2; si < tbuf[0]; si += 2) {
|
||||
if (di >= (length - 1))
|
||||
--
|
||||
2.17.0
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user