gnu: telepathy-glib: Fix test failure.
* gnu/packages/patches/telepathy-glib-channel-memory-leak.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/glib.scm (telepathy-glib)[source](patches): Add it.
This commit is contained in:
parent
fedce7b2b4
commit
6457ae1339
@ -1435,6 +1435,7 @@ dist_patch_DATA = \
|
|||||||
%D%/packages/patches/texinfo-5-perl-compat.patch \
|
%D%/packages/patches/texinfo-5-perl-compat.patch \
|
||||||
%D%/packages/patches/texlive-bin-poppler-0.83.patch \
|
%D%/packages/patches/texlive-bin-poppler-0.83.patch \
|
||||||
%D%/packages/patches/telegram-purple-adjust-test.patch \
|
%D%/packages/patches/telegram-purple-adjust-test.patch \
|
||||||
|
%D%/packages/patches/telepathy-glib-channel-memory-leak.patch \
|
||||||
%D%/packages/patches/texi2html-document-encoding.patch \
|
%D%/packages/patches/texi2html-document-encoding.patch \
|
||||||
%D%/packages/patches/texi2html-i18n.patch \
|
%D%/packages/patches/texi2html-i18n.patch \
|
||||||
%D%/packages/patches/thefuck-test-environ.patch \
|
%D%/packages/patches/thefuck-test-environ.patch \
|
||||||
|
@ -805,6 +805,7 @@ up the Gnome environment, and are used in many unrelated projects.")
|
|||||||
"1symyzbjmxvksn2ifdkk50lafjm2llf2sbmky062gq2pz3cg23cy"))
|
"1symyzbjmxvksn2ifdkk50lafjm2llf2sbmky062gq2pz3cg23cy"))
|
||||||
(patches
|
(patches
|
||||||
(list
|
(list
|
||||||
|
(search-patch "telepathy-glib-channel-memory-leak.patch")
|
||||||
;; Don't use the same test name for multiple tests.
|
;; Don't use the same test name for multiple tests.
|
||||||
;; <https://bugs.freedesktop.org/show_bug.cgi?id=92245>
|
;; <https://bugs.freedesktop.org/show_bug.cgi?id=92245>
|
||||||
(origin
|
(origin
|
||||||
|
@ -0,0 +1,19 @@
|
|||||||
|
Prevent a memory leak in call-channel, which otherwise would cause a
|
||||||
|
test failure in file-transfer-channel.c.
|
||||||
|
|
||||||
|
Taken from upstream:
|
||||||
|
https://gitlab.freedesktop.org/telepathy/telepathy-glib/commit/2e8b2cc0db09b781d99e3755bb6d01548037fe7b
|
||||||
|
|
||||||
|
diff --git a/telepathy-glib/call-channel.c b/telepathy-glib/call-channel.c
|
||||||
|
index 8ed76323be32f83c5f4d6045a50bc1698d8093fd..2a1fa203d4be9f0c8b99344225f4ba9900666ffc 100644
|
||||||
|
--- a/telepathy-glib/call-channel.c
|
||||||
|
+++ b/telepathy-glib/call-channel.c
|
||||||
|
@@ -525,6 +525,8 @@ update_call_members (TpCallChannel *self,
|
||||||
|
|
||||||
|
_tp_channel_contacts_queue_prepare_async ((TpChannel *) self,
|
||||||
|
contacts, update_call_members_prepared_cb, data);
|
||||||
|
+
|
||||||
|
+ g_ptr_array_unref (contacts);
|
||||||
|
}
|
||||||
|
|
||||||
|
static void
|
Loading…
Reference in New Issue
Block a user